aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/xfe
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2011-11-28 20:52:50 +0800
committergahr <gahr@FreeBSD.org>2011-11-28 20:52:50 +0800
commitd285e1943759ac12588190a08f9189a77ea56ea5 (patch)
tree80192094ba5300eb47fad072bdc5ed940ec89f59 /x11-fm/xfe
parent457cb38d94d32b72d6b159266c625a8bdf343600 (diff)
downloadfreebsd-ports-gnome-d285e1943759ac12588190a08f9189a77ea56ea5.tar.gz
freebsd-ports-gnome-d285e1943759ac12588190a08f9189a77ea56ea5.tar.zst
freebsd-ports-gnome-d285e1943759ac12588190a08f9189a77ea56ea5.zip
- Fix build with clang
PR: 162914 Submitted by: Jan Beich <jbeich@tormail.net> Feature safe: yes
Diffstat (limited to 'x11-fm/xfe')
-rw-r--r--x11-fm/xfe/Makefile2
-rw-r--r--x11-fm/xfe/files/patch-xvt_ttyinit.c16
2 files changed, 15 insertions, 3 deletions
diff --git a/x11-fm/xfe/Makefile b/x11-fm/xfe/Makefile
index dfa4bfb9bb89..213c76fe3846 100644
--- a/x11-fm/xfe/Makefile
+++ b/x11-fm/xfe/Makefile
@@ -30,5 +30,7 @@ post-patch:
${WRKSRC}/src/XFileExplorer.cpp \
${WRKSRC}/src/help.h \
${WRKSRC}/src/xfedefs.h
+ @${REINPLACE_CMD} 's/unsigned FXchar/FXuchar/' \
+ ${WRKSRC}/src/xfeutils.cpp
.include <bsd.port.mk>
diff --git a/x11-fm/xfe/files/patch-xvt_ttyinit.c b/x11-fm/xfe/files/patch-xvt_ttyinit.c
index 5b2a4c8b5b50..ac54a6066d4e 100644
--- a/x11-fm/xfe/files/patch-xvt_ttyinit.c
+++ b/x11-fm/xfe/files/patch-xvt_ttyinit.c
@@ -1,5 +1,5 @@
---- xvt/ttyinit.c.orig 2010-08-24 07:28:17.000000000 +0000
-+++ xvt/ttyinit.c 2010-08-24 07:31:01.000000000 +0000
+--- xvt/ttyinit.c.orig 2010-09-15 16:32:26.000000000 +0200
++++ xvt/ttyinit.c 2011-11-28 12:45:51.000000000 +0100
@@ -37,7 +37,12 @@
#include <unistd.h>
#include <signal.h>
@@ -14,7 +14,17 @@
#include <grp.h>
#include <pwd.h>
#include <errno.h>
-@@ -398,7 +403,7 @@
+@@ -175,7 +180,9 @@
+ #ifdef BSD_UTMP
+ static int tslot = -1; /* index to our slot in the utmp file */
+ #endif /* BSD_UTMP */
++#if defined(BSD_UTMP) || defined(SVR4_UTMP)
+ static struct utmp utent; /* our current utmp entry */
++#endif
+
+ /* Catch a SIGCHLD signal and exit if the direct child has died.
+ */
+@@ -385,7 +392,7 @@
*/
static char* get_pseudo_tty(int* pmaster, int* pslave)
{