aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/cyr-rfx/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2003-01-26 05:16:01 +0800
committermi <mi@FreeBSD.org>2003-01-26 05:16:01 +0800
commit26001a2fa12fabfde0bb516d80e3a24af9769cb6 (patch)
treea3e457feaeb5c697e7a8c56d46c577ecac3d0257 /x11-fonts/cyr-rfx/Makefile
parentcf5f201e651b0275fc05bde5aefe7e213032d303 (diff)
downloadfreebsd-ports-gnome-26001a2fa12fabfde0bb516d80e3a24af9769cb6.tar.gz
freebsd-ports-gnome-26001a2fa12fabfde0bb516d80e3a24af9769cb6.tar.zst
freebsd-ports-gnome-26001a2fa12fabfde0bb516d80e3a24af9769cb6.zip
Cyrillic X11 bitmap fonts from CYR-RFX project
Obtained from: NetBSD (somewhat)
Diffstat (limited to 'x11-fonts/cyr-rfx/Makefile')
-rw-r--r--x11-fonts/cyr-rfx/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-fonts/cyr-rfx/Makefile b/x11-fonts/cyr-rfx/Makefile
new file mode 100644
index 000000000000..d450c7fb8b1d
--- /dev/null
+++ b/x11-fonts/cyr-rfx/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: cyr-rfx
+# Date created: Jan 20, 2003
+# Whom: mi@aldan.algebra.com
+#
+# $NetBSD: Makefile.common,v 1.2 2002/07/13 15:43:36 wiz Exp $
+# $FreeBSD$
+
+PORTNAME= cyr-rfx-${CYR_RFX_ENCODING}
+PORTVERSION= 1.1
+CATEGORIES= x11-fonts ukrainian russian
+MASTER_SITES= ftp://ftp.ptc.spbu.ru/mirror/%SUBDIR%/ \
+ ftp://%SUBDIR%/
+MASTER_SITE_SUBDIR= ftp.inp.nsk.su/pub/BINP/X11/fonts/cyr-rfx/srctgz
+EXTRACT_SUFX= .bdfs.tgz
+
+MAINTAINER= mi@aldan.algebra.com
+
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients \
+ mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+
+# See WWW for other available encodings
+CYR_RFX_ENCODING?= koi8-o
+
+WRKSRC= ${WRKDIR}/${CYR_RFX_ENCODING}
+NCPUS!= sysctl -n hw.ncpu 2> /dev/null || echo 1
+MAKE_ARGS+= -j ${NCPUS}
+MAKEFILE= ${FILESDIR}/Makefile.bdf2pcf
+INST_DIR= "lib/X11/fonts/${PORTNAME}"
+MAKE_ENV+= INST_DIR="${X11BASE}/${INST_DIR}" MKDIR="${MKDIR}"
+PLIST_SUB+= INST_DIR="${INST_DIR}"
+
+post-install:
+ @${SED} -e 's,/usr/X11R6,${X11BASE},g' -e \
+ 's,koi8-o,${CYR_RFX_ENCODING},g' < ${PKGMESSAGE}
+
+.include <bsd.port.mk>