aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/cyr-rfx/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /x11-fonts/cyr-rfx/Makefile
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'x11-fonts/cyr-rfx/Makefile')
-rw-r--r--x11-fonts/cyr-rfx/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/x11-fonts/cyr-rfx/Makefile b/x11-fonts/cyr-rfx/Makefile
index bdf91cdf176a..e5eda1711e03 100644
--- a/x11-fonts/cyr-rfx/Makefile
+++ b/x11-fonts/cyr-rfx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cyr-rfx-${CYR_RFX_ENCODING}
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fonts ukrainian russian
MASTER_SITES= ftp://ftp.ptc.spbu.ru/mirror/ftp.inp.nsk.su/%SUBDIR%/ \
ftp://ftp.inp.nsk.su/%SUBDIR%/
@@ -17,10 +17,11 @@ EXTRACT_SUFX= .bdfs.tgz
MAINTAINER= mi@aldan.algebra.com
COMMENT= Cyrillic X11 bitmap fonts from CYR-RFX project
-BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT} \
- mkfontdir:${X_CLIENTS_PORT}
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-USE_X_PREFIX= yes
+USE_XORG= x11
# See WWW for other available encodings
CYR_RFX_ENCODING?= koi8-o
@@ -30,11 +31,11 @@ NCPUS!= /sbin/sysctl -n hw.ncpu 2> /dev/null || echo 1
MAKE_ARGS+= -j ${NCPUS}
MAKEFILE= ${FILESDIR}/Makefile.bdf2pcf
INST_DIR= "lib/X11/fonts/${PORTNAME}"
-MAKE_ENV+= INST_DIR="${X11BASE}/${INST_DIR}" MKDIR="${MKDIR}"
+MAKE_ENV+= INST_DIR="${LOCALBASE}/${INST_DIR}" MKDIR="${MKDIR}"
PLIST_SUB+= INST_DIR="${INST_DIR}"
post-install:
- @${SED} -e 's,/usr/X11R6,${X11BASE},g' -e \
+ @${SED} -e 's,/usr/X11R6,${LOCALBASE},g' -e \
's,koi8-o,${CYR_RFX_ENCODING},g' < ${PKGMESSAGE}
.include <bsd.port.mk>