aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/gohufont
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-06-18 03:59:44 +0800
committerrakuco <rakuco@FreeBSD.org>2013-06-18 03:59:44 +0800
commit6d8fcda04f85a6613369af5b027e8a4b7c744acc (patch)
tree6314eea9cf858ab713c14e8543cceaaa7b29bad7 /x11-fonts/gohufont
parentbc8e5e848f147205be5461cd7a858bab2161d8ca (diff)
downloadfreebsd-ports-gnome-6d8fcda04f85a6613369af5b027e8a4b7c744acc.tar.gz
freebsd-ports-gnome-6d8fcda04f85a6613369af5b027e8a4b7c744acc.tar.zst
freebsd-ports-gnome-6d8fcda04f85a6613369af5b027e8a4b7c744acc.zip
Add x11-fonts/gohufont.
Gohufont is a monospace bitmap font well suited for programming and terminal use. It is intended to be very legible and offers very discernable glyphs for all characters, including signs and symbols. The small 11 px version is perfect for laptops and netbooks as it enables to fit more text into their small screens. The 14 px is ideal for desktop screens where you sit farther away from it and the 11 px would be too small.
Diffstat (limited to 'x11-fonts/gohufont')
-rw-r--r--x11-fonts/gohufont/Makefile32
-rw-r--r--x11-fonts/gohufont/distinfo2
-rw-r--r--x11-fonts/gohufont/pkg-descr9
-rw-r--r--x11-fonts/gohufont/pkg-plist13
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-fonts/gohufont/Makefile b/x11-fonts/gohufont/Makefile
new file mode 100644
index 000000000000..4b369799055d
--- /dev/null
+++ b/x11-fonts/gohufont/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= gohufont
+PORTVERSION= 2.0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://font.gohu.org/
+
+MAINTAINER= rakuco@FreeBSD.org
+COMMENT= Monospace bitmap font well suited for programming and terminal use
+
+LICENSE= WTFPL
+LICENSE_NAME= Do What The Fuck You Want To Public License, Version 2
+LICENSE_FILE= ${WRKSRC}/COPYING-LICENSE
+LICENSE_PERMS= auto-accept dist-mirror dist-sell pkg-mirror pkg-sell
+
+BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+
+FONTDIR= lib/X11/fonts/${PORTNAME}
+NO_BUILD= yes
+PLIST_SUB+= FONTDIR=${FONTDIR}
+
+do-install:
+ @${MKDIR} ${LOCALBASE}/${FONTDIR}
+ @${INSTALL_DATA} ${WRKSRC}/*.pcf.gz ${LOCALBASE}/${FONTDIR}
+
+post-install:
+ @cd ${LOCALBASE}/${FONTDIR} && mkfontdir
+ @${CP} ${LOCALBASE}/${FONTDIR}/fonts.dir ${LOCALBASE}/${FONTDIR}/fonts.scale
+ @command fc-cache -f -v ${LOCALBASE}/${FONTDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/gohufont/distinfo b/x11-fonts/gohufont/distinfo
new file mode 100644
index 000000000000..3bb5bdd0be32
--- /dev/null
+++ b/x11-fonts/gohufont/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gohufont-2.0.tar.gz) = fa2c1b625056e20199dcf9b7f1f73750b101bc6a789b297ebca2d421b73b286e
+SIZE (gohufont-2.0.tar.gz) = 88993
diff --git a/x11-fonts/gohufont/pkg-descr b/x11-fonts/gohufont/pkg-descr
new file mode 100644
index 000000000000..4858db2f757a
--- /dev/null
+++ b/x11-fonts/gohufont/pkg-descr
@@ -0,0 +1,9 @@
+Gohufont is a monospace bitmap font well suited for programming and terminal
+use. It is intended to be very legible and offers very discernable glyphs for
+all characters, including signs and symbols.
+
+The small 11 px version is perfect for laptops and netbooks as it enables to
+fit more text into their small screens. The 14 px is ideal for desktop screens
+where you sit farther away from it and the 11 px would be too small.
+
+WWW: http://font.gohu.org/
diff --git a/x11-fonts/gohufont/pkg-plist b/x11-fonts/gohufont/pkg-plist
new file mode 100644
index 000000000000..d0c54c1828f5
--- /dev/null
+++ b/x11-fonts/gohufont/pkg-plist
@@ -0,0 +1,13 @@
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+%%FONTDIR%%/gohufont-11.pcf.gz
+%%FONTDIR%%/gohufont-11b.pcf.gz
+%%FONTDIR%%/gohufont-14.pcf.gz
+%%FONTDIR%%/gohufont-14b.pcf.gz
+%%FONTDIR%%/gohufont-uni-11.pcf.gz
+%%FONTDIR%%/gohufont-uni-11b.pcf.gz
+%%FONTDIR%%/gohufont-uni-14.pcf.gz
+%%FONTDIR%%/gohufont-uni-14b.pcf.gz
+@unexec /bin/rm %D/%%FONTSDIR%%/fonts.cache-1 2>/dev/null || /usr/bin/true
+@dirrm %%FONTDIR%%
+@exec %%LOCALBASE%%/bin/fc-cache -f -v %D/%%FONTSDIR%% || /usr/bin/true