aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/pcf2bdf
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-01-20 22:27:51 +0800
committernork <nork@FreeBSD.org>2003-01-20 22:27:51 +0800
commit87961d61918ff10f7edd0289a99d4c1f93f8a60e (patch)
tree9a35b6bffc263fcf27e00b822c1723f9ca04862b /x11-fonts/pcf2bdf
parentf07fa9bc35ac4bf46e98508a2bc7d524b8e13ac1 (diff)
downloadfreebsd-ports-gnome-87961d61918ff10f7edd0289a99d4c1f93f8a60e.tar.gz
freebsd-ports-gnome-87961d61918ff10f7edd0289a99d4c1f93f8a60e.tar.zst
freebsd-ports-gnome-87961d61918ff10f7edd0289a99d4c1f93f8a60e.zip
Add pcf2bdf(1.04), a converter X font from Portable Compiled
Format to Bitmap Distribution Format. Obtained from: NetBSD
Diffstat (limited to 'x11-fonts/pcf2bdf')
-rw-r--r--x11-fonts/pcf2bdf/Makefile27
-rw-r--r--x11-fonts/pcf2bdf/distinfo1
-rw-r--r--x11-fonts/pcf2bdf/files/patch-pcf2bdf.cc29
-rw-r--r--x11-fonts/pcf2bdf/pkg-comment1
-rw-r--r--x11-fonts/pcf2bdf/pkg-descr7
-rw-r--r--x11-fonts/pcf2bdf/pkg-plist1
6 files changed, 66 insertions, 0 deletions
diff --git a/x11-fonts/pcf2bdf/Makefile b/x11-fonts/pcf2bdf/Makefile
new file mode 100644
index 000000000000..d089b3c6037c
--- /dev/null
+++ b/x11-fonts/pcf2bdf/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pcf2bdf
+# Date created: 2003/01/20
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcf2bdf
+PORTVERSION= 1.04
+CATEGORIES= x11-fonts
+MASTER_SITES= http://www.tsg.ne.jp/GANA/S/pcf2bdf/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nork@FreeBSD.org
+
+NO_WRKSUBDIR= YES
+
+MAN1= pcf2bdf.1
+
+do-build:
+ ${CXX} ${CXXFLAGS} -o ${WRKSRC}/pcf2bdf ${WRKSRC}/pcf2bdf.cc
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pcf2bdf ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pcf2bdf.man ${PREFIX}/man/man1/pcf2bdf.1
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/pcf2bdf/distinfo b/x11-fonts/pcf2bdf/distinfo
new file mode 100644
index 000000000000..4b293ede7af9
--- /dev/null
+++ b/x11-fonts/pcf2bdf/distinfo
@@ -0,0 +1 @@
+MD5 (pcf2bdf-1.04.tgz) = 8ce3b6a57491c67ef0cbf2f5413451f3
diff --git a/x11-fonts/pcf2bdf/files/patch-pcf2bdf.cc b/x11-fonts/pcf2bdf/files/patch-pcf2bdf.cc
new file mode 100644
index 000000000000..3327a35c1525
--- /dev/null
+++ b/x11-fonts/pcf2bdf/files/patch-pcf2bdf.cc
@@ -0,0 +1,29 @@
+--- pcf2bdf.cc.orig Mon Oct 21 01:35:29 2002
++++ pcf2bdf.cc Mon Jan 20 23:11:46 2003
+@@ -577,7 +577,7 @@
+ }
+ if (ifilename)
+ {
+- ifp = fopen(ifilename, "rb");
++ ifp = fopen(ifilename, "r");
+ if (!ifp)
+ return error_exit("failed to open input pcf file");
+ }
+@@ -595,7 +595,7 @@
+ fclose(ifp);
+ char buf[1024];
+ sprintf(buf, "gzip -dc %s", ifilename); // TODO
+- ifp = popen(buf, "rb");
++ ifp = popen(buf, "r");
+ _setmode(fileno(ifp), O_BINARY);
+ read_bytes = 0;
+ if (!ifp)
+@@ -604,7 +604,7 @@
+
+ if (ofilename)
+ {
+- ofp = fopen(ofilename, "wb");
++ ofp = fopen(ofilename, "w");
+ if (!ofp)
+ return error_exit("failed to open output bdf file");
+ }
diff --git a/x11-fonts/pcf2bdf/pkg-comment b/x11-fonts/pcf2bdf/pkg-comment
new file mode 100644
index 000000000000..4f1c4d74df83
--- /dev/null
+++ b/x11-fonts/pcf2bdf/pkg-comment
@@ -0,0 +1 @@
+Convert X font from PCF to BDF
diff --git a/x11-fonts/pcf2bdf/pkg-descr b/x11-fonts/pcf2bdf/pkg-descr
new file mode 100644
index 000000000000..5d003e320282
--- /dev/null
+++ b/x11-fonts/pcf2bdf/pkg-descr
@@ -0,0 +1,7 @@
+Pcf2bdf is a font de-compiler. It converts X fonts from Portable
+Compiled Format (PCF) to Bitmap Distribution Format (BDF). It can
+also accept a compressed/gzipped PCF file as input, but gzip must
+be found in your PATH.
+
+FONTBOUNDINGBOX in a BDF file is not used by bdftopcf, so pcf2bdf
+generates irresponsible values.
diff --git a/x11-fonts/pcf2bdf/pkg-plist b/x11-fonts/pcf2bdf/pkg-plist
new file mode 100644
index 000000000000..8eccfba5834c
--- /dev/null
+++ b/x11-fonts/pcf2bdf/pkg-plist
@@ -0,0 +1 @@
+bin/pcf2bdf