aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
committertijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
commit6255104baacfdd2c23e07550f90d2f9a7020ca87 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /x11-fonts
parent016de2316ed16336a58b66dafd7f332614a041ac (diff)
downloadfreebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.gz
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.zst
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/linux-c6-fontconfig/Makefile14
-rw-r--r--x11-fonts/linux-f10-fontconfig/Makefile7
2 files changed, 7 insertions, 14 deletions
diff --git a/x11-fonts/linux-c6-fontconfig/Makefile b/x11-fonts/linux-c6-fontconfig/Makefile
index 38cd97ea86b9..80263052cd86 100644
--- a/x11-fonts/linux-c6-fontconfig/Makefile
+++ b/x11-fonts/linux-c6-fontconfig/Makefile
@@ -11,18 +11,16 @@ COMMENT= XML-based font configuration API for X Windows (Linux CentOS ${LINUX_DI
CONFLICTS= linux-fontconfig-[0-9]* linux-f8-fontconfig-[0-9]* linux-f10-fontconfig-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
RPMVERSION= 5.el6
-USE_LINUX= c6
-USE_LINUX_APPS= expat
-
-USE_LINUX_RPM= yes
-BRANDELF_DIRS= usr/bin
+USES= linux:c6
USE_LDCONFIG= yes
+USE_LINUX= expat
+USE_LINUX_RPM= yes
# We will use some other configuration file, so delete a linux one
# Don't let the linux fc-cache mess up the native cache file
-post-extract:
+post-patch:
@${RM} -r ${WRKSRC}/etc ${WRKSRC}/usr/share/fonts ${WRKSRC}/var \
${WRKSRC}/usr/bin/fc-cache \
${WRKSRC}/usr/share/man/man1/fc-cache.1.gz
@@ -31,6 +29,4 @@ post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc
@${LN} -s ${LOCALBASE}/etc/fonts ${STAGEDIR}${PREFIX}/etc/
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-
.include <bsd.port.mk>
diff --git a/x11-fonts/linux-f10-fontconfig/Makefile b/x11-fonts/linux-f10-fontconfig/Makefile
index 2c6ab667d278..f22dc3e1b2bb 100644
--- a/x11-fonts/linux-f10-fontconfig/Makefile
+++ b/x11-fonts/linux-f10-fontconfig/Makefile
@@ -5,20 +5,17 @@ PORTNAME= fontconfig
PORTVERSION= 2.6.0
PORTREVISION= 1
CATEGORIES= x11-fonts linux
-MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
MAINTAINER= emulation@FreeBSD.org
COMMENT= XML-based font configuration API for X Windows (Linux Fedora 10)
CONFLICTS= linux-fontconfig-[0-9]* linux-f8-fontconfig-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= f10
+USES= linux:f10
USE_LINUX_RPM= yes
-USE_LINUX_APPS= expat
+USE_LINUX= expat
RPMVERSION= 3.fc10
-BRANDELF_DIRS= usr/bin
USE_LDCONFIG= yes
# We will use some other configuration file, so delete a linux one