aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes/lxappearance
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-10-27 09:15:17 +0800
committerwen <wen@FreeBSD.org>2010-10-27 09:15:17 +0800
commitfbe261332dad8d29d7149af8cacb35761bbad4f5 (patch)
tree8cea50d10aa75e4680bb45a09e02683995e6f211 /x11-themes/lxappearance
parentc112592c37c1f02450d92e7070623603dfcb4db5 (diff)
downloadfreebsd-ports-gnome-fbe261332dad8d29d7149af8cacb35761bbad4f5.tar.gz
freebsd-ports-gnome-fbe261332dad8d29d7149af8cacb35761bbad4f5.tar.zst
freebsd-ports-gnome-fbe261332dad8d29d7149af8cacb35761bbad4f5.zip
- Fix build for ${OSVERSION} < 800000
PR: ports/151761 Submitted by: "Pawel Pekala" <c0rn@o2.pl> (maintainer)
Diffstat (limited to 'x11-themes/lxappearance')
-rw-r--r--x11-themes/lxappearance/Makefile12
-rw-r--r--x11-themes/lxappearance/files/extra-src-utils.c11
2 files changed, 21 insertions, 2 deletions
diff --git a/x11-themes/lxappearance/Makefile b/x11-themes/lxappearance/Makefile
index c0f3534aa9bc..3e65fb24b095 100644
--- a/x11-themes/lxappearance/Makefile
+++ b/x11-themes/lxappearance/Makefile
@@ -7,18 +7,26 @@
PORTNAME= lxappearance
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= x11-themes gnome
MASTER_SITES= SF/lxde/LXAppearance
MAINTAINER= c0rn@o2.pl
COMMENT= A desktop-independent theme switcher for GTK+
+LICENSE= GPLv2
+
USE_GNOME= gnomehack gtk20 intlhack
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-LICENSE= GPLv2
+.include <bsd.port.pre.mk>
+
+# earlier versions don't have mkdtemp(3) in stdlib.h
+.if ${OSVERSION} < 800000
+EXTRA_PATCHES+= ${FILESDIR}/extra-src-utils.c
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-themes/lxappearance/files/extra-src-utils.c b/x11-themes/lxappearance/files/extra-src-utils.c
new file mode 100644
index 000000000000..5075b6406729
--- /dev/null
+++ b/x11-themes/lxappearance/files/extra-src-utils.c
@@ -0,0 +1,11 @@
+--- src/utils.c.orig 2010-10-26 20:54:31.000000000 +0200
++++ src/utils.c 2010-10-26 20:55:09.000000000 +0200
+@@ -27,7 +27,7 @@
+ #include <sys/wait.h>
+ #include <stdlib.h>
+ #include <glib/gstdio.h>
+-
++#include <unistd.h>
+ #include "icon-theme.h"
+
+ static void on_pid_exit(GPid pid, gint status, gpointer user_data)