aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2004-11-21 11:17:29 +0800
committerlioux <lioux@FreeBSD.org>2004-11-21 11:17:29 +0800
commitd386010ec4bd66bae6a431e1ebbec8fe6f8ea1e6 (patch)
treeab8f42a2ce33368e097936e513ebf74eaff029b3 /x11-themes
parent1a3ceff8fb0adecc41501a91fe0de3c204651853 (diff)
downloadfreebsd-ports-gnome-d386010ec4bd66bae6a431e1ebbec8fe6f8ea1e6.tar.gz
freebsd-ports-gnome-d386010ec4bd66bae6a431e1ebbec8fe6f8ea1e6.tar.zst
freebsd-ports-gnome-d386010ec4bd66bae6a431e1ebbec8fe6f8ea1e6.zip
Improve both post-patch [1] and generate-install-scripts [2] target:
escape meta-characters PR: 69601 [1], 73998 [2] Submitted by: Christian Hiris <4711@chello.at> [1], Christian Hiris <4711@chello.at> [2]
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/kde-icons-noia/Makefile.icons8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11-themes/kde-icons-noia/Makefile.icons b/x11-themes/kde-icons-noia/Makefile.icons
index 74b51ecf7090..fc5f1df57ba4 100644
--- a/x11-themes/kde-icons-noia/Makefile.icons
+++ b/x11-themes/kde-icons-noia/Makefile.icons
@@ -35,11 +35,11 @@ PLIST_FILE_PATTERN_EXTRA?= .
post-patch:
# correctly inherits crystal per default
.for file in ${INDEX_FILES}
- @if [ -f "${WRKSRC}/${file}" ]; then \
+ @if [ -f ${WRKSRC:Q}/${file:Q} ]; then \
${REINPLACE_CMD} -E \
-e 's| ||' \
-e 's|^Inherits.*$$|Inherits=crystalsvg|' \
- "${WRKSRC}/${file}" ; \
+ ${WRKSRC:Q}/${file:Q} ; \
fi
.endfor
@@ -61,12 +61,12 @@ generate-install-scripts:
# annotate dirs
@${CAT} ${WRKDIR}/dirs.list \
| ${SED} -E \
- -e 's|^\.|${MKDIR} -m 755 ${PREFIX}/share/icons/${PORT_SHAREDIR:S/"//g}|' \
+ -e 's|^\.(.+)$$|${MKDIR} -m 755 ${PREFIX:Q}/share/icons/${PORT_SHAREDIR:S/"//g:Q}/\"\1\"|' \
> ${WRKDIR}/dirs.sh
# annotate files
@${CAT} ${WRKDIR}/files.list \
| ${SED} -E \
- -e 's|^\./(.+)$$|${INSTALL_DATA} ${WRKSRC}/\1 ${PREFIX}/share/icons/${PORT_SHAREDIR:S/"//g}/\1|' \
+ -e 's|^\./(.+)$$|${INSTALL_DATA} ${WRKSRC:Q}/\"\1\" ${PREFIX:Q}/share/icons/${PORT_SHAREDIR:S/"//g:Q}/\"\1\"|' \
> ${WRKDIR}/files.sh
# generate on the fly packaging lists based on aforementioned annotations