aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-01-28 20:41:49 +0800
committerpawel <pawel@FreeBSD.org>2012-01-28 20:41:49 +0800
commitd5b001c2ec4efe37e3a0559ed2a93c7f8aee41b7 (patch)
tree3376f3070889341897d02ef822ab3ddb3dc0a91e /x11-themes
parent1120650c7599675668446ec0f598f0c0f97fc804 (diff)
downloadfreebsd-ports-gnome-d5b001c2ec4efe37e3a0559ed2a93c7f8aee41b7.tar.gz
freebsd-ports-gnome-d5b001c2ec4efe37e3a0559ed2a93c7f8aee41b7.tar.zst
freebsd-ports-gnome-d5b001c2ec4efe37e3a0559ed2a93c7f8aee41b7.zip
Replace ubuntu logo with gnome one on start button
Submitted by: clutton <clutton0@gmail.com>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-icons-faenza/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/x11-themes/gnome-icons-faenza/Makefile b/x11-themes/gnome-icons-faenza/Makefile
index 1789d60fc400..a430a2ed2390 100644
--- a/x11-themes/gnome-icons-faenza/Makefile
+++ b/x11-themes/gnome-icons-faenza/Makefile
@@ -7,6 +7,7 @@
PORTNAME= faenza
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= x11-themes gnome
MASTER_SITES= http://fc05.deviantart.com/fs71/f/2011/320/4/f/
PKGNAMEPREFIX= gnome-icons-
@@ -23,11 +24,24 @@ INSTALLS_ICONS= yes
THEMES= Faenza Faenza-Dark Faenza-Darkest Faenza-Darker \
Faenza-Ambiance Faenza-Radiance
+FAENZA_LIGHT= Faenza
+FAENZA_DARK= Faenza-Dark
do-install:
-.for i in ${THEMES}
- @cd ${WRKDIR} && ${TAR} -xf ${i}.tar.gz
- ${CP} -R ${WRKDIR}/${i} ${PREFIX}/share/icons
+.for theme in ${THEMES}
+ @cd ${WRKDIR} && ${TAR} -xf ${theme}.tar.gz
+
+.if ${FAENZA_LIGHT} == ${theme} || ${FAENZA_DARK} == ${theme}
+ @cd ${WRKDIR}/${theme}/places/scalable && \
+ ${LN} -sf start-here-gnome.svg start-here.svg && \
+ ${LN} -sf start-here-gnome-symbolic.svg start-here-symbolic.svg
+.for size in 22 24 32 48 64 96
+ @cd ${WRKDIR}/${theme}/places/${size} && \
+ ${LN} -sf start-here-gnome.png start-here.png
+.endfor
+.endif
+
+ ${CP} -R ${WRKDIR}/${theme} ${PREFIX}/share/icons
.endfor
.include <bsd.port.mk>