aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/SoXt
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /x11-toolkits/SoXt
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'x11-toolkits/SoXt')
-rw-r--r--x11-toolkits/SoXt/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/SoXt/Makefile b/x11-toolkits/SoXt/Makefile
index 54d6ef5f7bc0..7e5f5e286f19 100644
--- a/x11-toolkits/SoXt/Makefile
+++ b/x11-toolkits/SoXt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= SoXt
PORTVERSION= 1.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.coin3d.org/coin/src/all/
@@ -12,7 +12,7 @@ COMMENT= GUI binding for using Open Inventor with Xt/Motif
LIB_DEPENDS= libCoin.so:${PORTSDIR}/graphics/Coin
-USES= libtool motif pathfix perl5
+USES= libtool:keepla motif pathfix perl5
USE_GL= yes
USE_PERL5= build
USE_XORG= xi