aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/fltk
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-02-11 03:29:46 +0800
committerdanfe <danfe@FreeBSD.org>2015-02-11 03:29:46 +0800
commit7d90226ce16bd2e2c0f7ae5594cd79b31d0d088c (patch)
treea5894f4c13e847e78b008a8024e2613e8b6e1dcc /x11-toolkits/fltk
parent67a7c9b5d0fbbcb68834b5559f6fabefa82ead57 (diff)
downloadfreebsd-ports-gnome-7d90226ce16bd2e2c0f7ae5594cd79b31d0d088c.tar.gz
freebsd-ports-gnome-7d90226ce16bd2e2c0f7ae5594cd79b31d0d088c.tar.zst
freebsd-ports-gnome-7d90226ce16bd2e2c0f7ae5594cd79b31d0d088c.zip
- Since version 1.3.3, FLTK now checks for compiler support of -fvisibility
and -fvisibility-inlines-hidden and uses it if available to reduce shared library size. Unfortunately, this hides Fl_XFont_On_Demand::value, which in turn causes undefined reference errors during linking. Fix by marking Fl_XFont_On_Demand class as FL_EXPORT for the time being (Gentoo Linux is doing the same) - Do not strip libraries for now: FLTK uses the same command for installing both dynamic and static libraries, but "fltk-config(1) --compile" prefers static, which breaks programs like `graphics/iccexamin' (threading test) - Pull another patch from Gentoo to fix segmentation fault in vncview(1) of port `net/tigervnc' (Gentoo bug #529856 by Maxim Britov) - Do not leak non-existent (build-time only) -Lfoo references in LDFLAGS as it can potentially lead to various sporadic bugs in programs which obtain these flags through fltk-config(1). To prevent build-time conflicts that this gimmick was originally used for, we change shared linking command of fluid(1) accordingly Since these are one-line changes likely to be merged upstream sooner rather than later, perform them with sed(1) instead of trivial patches. Reported and reviewed by: antoine
Diffstat (limited to 'x11-toolkits/fltk')
-rw-r--r--x11-toolkits/fltk/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index 268a001cc120..a223a494c445 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fltk
PORTVERSION= 1.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
MASTER_SITES= http://fltk.org/pub/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -26,8 +26,7 @@ CONFIGURE_ARGS= --enable-shared
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CPPFLAGS+= -I${LOCALBASE}/include
-# -L../src is needed to be able to build new version with older one installed
-LDFLAGS+= -L../src -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
PORTEXAMPLES= *
@@ -39,7 +38,14 @@ post-patch: .SILENT
${WRKSRC}/src/Fl_Preferences.cxx
${REINPLACE_CMD} -e 's,$$(docdir)/examples,${EXAMPLESDIR},' \
${WRKSRC}/test/Makefile
- ${REINPLACE_CMD} -E '/^INSTALL_(BIN|LIB)/s,-m,${STRIP} &, ; \
+ ${REINPLACE_CMD} -e '/^INSTALL_BIN/s,-m,${STRIP} &, ; \
s,^\.SILENT,#&,' ${WRKSRC}/makeinclude.in
+ ${REINPLACE_CMD} -E \
+ 's,(.*)LDFLAGS(.*)LINKSHARED(.*),\1LINKSHARED\2LDFLAGS\3,' \
+ ${WRKSRC}/fluid/Makefile
+ ${REINPLACE_CMD} -e '/Fl_XFont_On_Demand/s,class,& FL_EXPORT,' \
+ ${WRKSRC}/FL/x.H
+ ${REINPLACE_CMD} -e 's,result = 0;,fl_open_display(); &,' \
+ ${WRKSRC}/src/Fl_x.cxx
.include <bsd.port.mk>