aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/girara/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-05-19 04:05:46 +0800
committerPawel Pekala <pawel@FreeBSD.org>2012-05-19 04:05:46 +0800
commit1b4a79f6a156e1e074a880294dd264657fa6d622 (patch)
treeeeb4ba287f9f6ddce15a39d297d216fd996028fa /x11-toolkits/girara/Makefile
parentc22ae1ac862b39131325c1b352d955fc22bce705 (diff)
downloadfreebsd-ports-gnome-1b4a79f6a156e1e074a880294dd264657fa6d622.tar.gz
freebsd-ports-gnome-1b4a79f6a156e1e074a880294dd264657fa6d622.tar.zst
freebsd-ports-gnome-1b4a79f6a156e1e074a880294dd264657fa6d622.zip
girara is a library that implements a user interface that focuses
on simplicity and minimalism. WWW: http://pwmt.org/projects/girara/ PR: ports/167328 Submitted by: Mike Krutov <neko@takino.org> (port) Quentin Stievenart <quentin.stievenart@gmail.com> (fixes)
Diffstat (limited to 'x11-toolkits/girara/Makefile')
-rw-r--r--x11-toolkits/girara/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-toolkits/girara/Makefile b/x11-toolkits/girara/Makefile
new file mode 100644
index 000000000000..1643d444baad
--- /dev/null
+++ b/x11-toolkits/girara/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: zathura
+# Date created: 23 April 2012
+# Whom: Mike Krutov <neko@takino.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= girara
+PORTVERSION= 0.1.2
+CATEGORIES= x11-toolkits graphics
+MASTER_SITES= http://pwmt.org/projects/girara/download/
+
+MAINTAINER= neko@takino.org
+COMMENT= GTK2 Interface Library for Zathura PDF Viewer
+
+USE_GNOME= glib20 gtk20
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+FETCH_ARGS= -Fpr
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+LIBDIR= ${PREFIX}/lib
+
+post-patch: .SILENT
+ ${REINPLACE_CMD} -e 's|$${LIBDIR}/pkgconfig|${PREFIX}/libdata/pkgconfig|g'\
+ ${WRKSRC}/Makefile
+.if defined(WITHOUT_NLS)
+ ${REINPLACE_CMD} -e '/-C po/d'\
+ ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.mk>