aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-09-03 06:07:47 +0800
committermezz <mezz@FreeBSD.org>2005-09-03 06:07:47 +0800
commit41ae1cbf8264a232f1076db531f363e5e61a92e5 (patch)
tree782778732ba61e3b89e9904c7f5fccbdc7286cf2 /x11-toolkits/gtk20
parent17d39b3325ebf6e18989a11cc9abaa262252183f (diff)
downloadfreebsd-ports-gnome-41ae1cbf8264a232f1076db531f363e5e61a92e5.tar.gz
freebsd-ports-gnome-41ae1cbf8264a232f1076db531f363e5e61a92e5.tar.zst
freebsd-ports-gnome-41ae1cbf8264a232f1076db531f363e5e61a92e5.zip
There is a SSE2 bug in either GCC or in our libc, when use p4, p-m or else
is being use in CPUTYPE that enable SSE2 will causing Java with GTK2 and Mono/gtk-sharp crash. Disable SSE2 to solve the crash and see ports/72014 for detail. Reported by: Panagiotis Astithas <past@ebs.gr> Reviewed by: marcus
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 4c7ec0daf82c..a02f9ce8f997 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= 2.6.10
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.6,} \
ftp://ftp.gtk.org/pub/gtk/v2.6/ \
@@ -71,6 +72,16 @@ STRIP=
.endif
.endif
+.include <bsd.port.pre.mk>
+
+# There is a SSE2 bug in either GCC or in our libc, when use p4, p-m or else
+# is being use in CPUTYPE that enable SSE2 will causing Java with GTK2 and
+# Mono/gtk-sharp crash. Disable SSE2 to solve the crash and see ports/72014
+# for detail.
+.if ( ${ARCH} == "i386" || ${ARCH} == "amd64" ) && ${CC} != "icc"
+CFLAGS+= -mno-sse2
+.endif
+
pre-everything::
.if !defined(WITH_DROPSHADOW)
@${ECHO_MSG}
@@ -106,4 +117,4 @@ post-install:
@${MKDIR} ${PREFIX}/lib/gtk-2.0/modules
@${MKDIR} ${PREFIX}/lib/gtk-2.0/${GTK_VERSION}/engines
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>