aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-10-14 16:35:50 +0800
committermarcus <marcus@FreeBSD.org>2006-10-14 16:35:50 +0800
commit9b9c902909a87b589432804ec4e8a7fa23943ff4 (patch)
treeaa2e443568b953ce772558b2be74a8451e38ec3d /x11-toolkits/gtk20
parentf5a682ff4e0a5d73ce8bffeb88c799eb8ef0e816 (diff)
downloadfreebsd-ports-gnome-9b9c902909a87b589432804ec4e8a7fa23943ff4.tar.gz
freebsd-ports-gnome-9b9c902909a87b589432804ec4e8a7fa23943ff4.tar.zst
freebsd-ports-gnome-9b9c902909a87b589432804ec4e8a7fa23943ff4.zip
Presenting GNOME 2.16.1 for FreeBSD. This release represents a massive
amount of work by the FreeBSD GNOME Team and our testers. On top of the usual GNOME update, we have taken this opportunity to move GNOME from X11BASE to LOCALBASE. This means roughly 600 ports NOT part of the GNOME Desktop also need to be changed. The bulk of the move was carried out by ahze, mezz, and pav, but it would not have been possible without cooperation from the FreeBSD KDE team who worked with us to make sure GNOME and KDE can still coexist happily. We would also like to send a shout out to kris and pointyhat for putting up with multiple test runs until we got something that was solid. Back to GNOME 2.16. This release brings a huge amount of new functionality to FreeBSD. The standard release notes can be read at http://www.gnome.org/start/2.16/ . But on top of what you will read there, jylefort and marcus have completed work on a port of HAL to FreeBSD. This will allow FreeBSD to take advantage of closer hardware interaction such as auto-mounting CD-ROMs, USB drives, and music players; auto-playing audio CDs; and managing laptop power consumption. But where would this all be without our loyal testers and contributors? Therefore, the FreeBSD GNOME team would like to thank the following users: Phillip Neumann <pneumann@gmail.com> tmclaugh mux Yuri Pankov <yuri.pankov@gmail.com> chinsan Thomas <freebsdlists@bsdunix.ch> Brian Gruber <knightbg@yahoo.com> Franz Klammer <klammer@webonaut.com> Dominique Goncalves <dominique.goncalves@gmail.com> Pascal Hofstee <caelian@gmail.com> Yasuda Keisuke <kysd@po.harenet.ne.jp> backyard <backyard1454-bsd@yahoo.com> Andris Raugulis <endrju@null.lv> <endrju@null.lv> Eric L. Chen <d9364104@mail.nchu.edu.tw> Pawel Worach <pawel.worach@gmail.com> QuiRK on #freebsd-gnome Shane Bell <decept0@gmail.com> luigi sajd on #freebsd-gnome sat Chris Coleman <chrisc@vmunix.com> kaeru on #freebsd-gnome crsd_ via irc.freenode.org/#FreeBSD-GNOME Joel Diaz <joeldiaz@mac.com> Enjoy! Approved by: portmgr (implicit, kris)
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile31
-rw-r--r--x11-toolkits/gtk20/distinfo6
-rw-r--r--x11-toolkits/gtk20/files/patch-ak2
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_Makefile.in13
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_gtkcalendar.c10
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.h17
-rw-r--r--x11-toolkits/gtk20/pkg-plist118
7 files changed, 152 insertions, 45 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index c5153fc719cc..5a1783c426e3 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -3,15 +3,15 @@
# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
#
# $FreeBSD$
-# $MCom: ports-stable/x11-toolkits/gtk20/Makefile,v 1.8 2006/03/13 22:32:30 mezz Exp $
+# $MCom: ports/x11-toolkits/gtk20/Makefile,v 1.101 2006/10/08 21:05:26 marcus Exp $
#
PORTNAME= gtk
-PORTVERSION= 2.8.20
-PORTREVISION?= 0
+PORTVERSION= 2.10.6
+PORTREVISION?= 1
CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.8,} \
- ftp://ftp.gtk.org/pub/gtk/v2.8/ \
+MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
+ ftp://ftp.gtk.org/pub/gtk/v2.10/ \
ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
http://www.ameth.org/gimp/%SUBDIR%/ \
@@ -33,20 +33,21 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= ${LOCALBASE}/share/mime/magic:${PORTSDIR}/misc/shared-mime-info \
- ${X11BASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+ ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+USE_GMAKE= yes
USE_XPM= yes
USE_PERL5= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack atk pango ltverhack
USE_GETTEXT= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
CONFIGURE_ARGS= --enable-static --with-xinput=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-GTK_VERSION= 2.4.0
+GTK_VERSION= 2.10.0
PLIST_SUB= GTK_VERSION="${GTK_VERSION}"
gdk_pixbuf_MAN= gdk-pixbuf-query-loaders.1
@@ -77,13 +78,20 @@ STRIP=
.include <bsd.port.pre.mk>
+.if defined(WITH_CUPS) || exists(${LOCALBASE}/lib/libcups.so)
+LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+PLIST_SUB+= CUPS:=""
+.else
+PLIST_SUB+= CUPS:="@comment "
+.endif
+
# There is a SSE2 bug in either GCC or in our libc, when use p4, p-m or else
# is being use in CPUTYPE that enable SSE2 will causing Java with GTK2 and
# Mono/gtk-sharp crash. Disable SSE2 to solve the crash and see ports/72014
# for detail.
.if ${OSVERSION} >= 500000 && ( ${ARCH} == "i386" || ${ARCH} == "amd64" ) \
&& ${CC} != "icc"
-CFLAGS+= -mno-sse2
+#CFLAGS+= -mno-sse2
.endif
pre-everything::
@@ -108,12 +116,13 @@ post-patch:
@${REINPLACE_CMD} -e 's|@CFLAGS@|& ${PTHREAD_CFLAGS}|; \
s|@LDFLAGS@|& ${PTHREAD_LIBS}|' \
${WRKSRC}/demos/gtk-demo/Makefile.in
+ @${REINPLACE_CMD} -e 's|@LN_S@|${LN} -sf|' ${WRKSRC}/gtk/Makefile.in
pre-build:
@${RM} -rf ${WRKSRC}/docs/gtk.info*
post-install:
- -@${FIND} ${X11BASE}/share/icons -type d -depth 1 -exec \
+ -@${FIND} ${LOCALBASE}/share/icons -type d -depth 1 -exec \
${PREFIX}/bin/gtk-update-icon-cache -q -f {} \; 2>/dev/null
@${MKDIR} ${PREFIX}/lib/gtk-2.0/modules
@${MKDIR} ${PREFIX}/lib/gtk-2.0/${GTK_VERSION}/engines
diff --git a/x11-toolkits/gtk20/distinfo b/x11-toolkits/gtk20/distinfo
index e7e4075ad27d..0fc02b098bba 100644
--- a/x11-toolkits/gtk20/distinfo
+++ b/x11-toolkits/gtk20/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gtk+-2.8.20.tar.bz2) = 74e7ca98194f1fadfe906e66d763d05d
-SHA256 (gnome2/gtk+-2.8.20.tar.bz2) = 69a9b6c1e78da7e71416f20fab0c4972503139406e89ce7fbdbac0e213b16b79
-SIZE (gnome2/gtk+-2.8.20.tar.bz2) = 12247295
+MD5 (gnome2/gtk+-2.10.6.tar.bz2) = 13c62b610c910255934452d0617403f7
+SHA256 (gnome2/gtk+-2.10.6.tar.bz2) = ca98edcea2034ab36c1024121a44d047de192d282127c8f8b77d14afba0ca468
+SIZE (gnome2/gtk+-2.10.6.tar.bz2) = 14561124
diff --git a/x11-toolkits/gtk20/files/patch-ak b/x11-toolkits/gtk20/files/patch-ak
index f30cec385b9a..27156d238e58 100644
--- a/x11-toolkits/gtk20/files/patch-ak
+++ b/x11-toolkits/gtk20/files/patch-ak
@@ -1,6 +1,6 @@
$FreeBSD$
- $MCom: ports-stable/x11-toolkits/gtk20/files/patch-ak,v 1.6 2006/03/08 20:28:38 mezz Exp $
+ $MCom: ports/x11-toolkits/gtk20/files/patch-ak,v 1.19 2006/10/10 20:22:27 mezz Exp $
--- gdk/Makefile.in.orig Thu Feb 14 12:38:26 2002
+++ gdk/Makefile.in Thu Feb 14 12:45:37 2002
diff --git a/x11-toolkits/gtk20/files/patch-gtk_Makefile.in b/x11-toolkits/gtk20/files/patch-gtk_Makefile.in
index 44589795f769..610ece8f33ac 100644
--- a/x11-toolkits/gtk20/files/patch-gtk_Makefile.in
+++ b/x11-toolkits/gtk20/files/patch-gtk_Makefile.in
@@ -1,6 +1,6 @@
---- gtk/Makefile.in.orig Wed Mar 2 15:57:44 2005
-+++ gtk/Makefile.in Wed Mar 2 15:58:22 2005
-@@ -887,12 +887,12 @@
+--- gtk/Makefile.in.orig Sat May 6 04:47:11 2006
++++ gtk/Makefile.in Sat May 6 04:48:06 2006
+@@ -1009,11 +1009,11 @@ LDADDS = \
bin_PROGRAMS = gtk-query-immodules-2.0 gtk-update-icon-cache
gtk_query_immodules_2_0_DEPENDENCIES = $(DEPS)
@@ -9,9 +9,8 @@
gtk_query_immodules_2_0_SOURCES = queryimmodules.c
- gtk_update_icon_cache_DEPENDENCIES = $(DEPS)
--gtk_update_icon_cache_LDADD = $(LDADDS)
-+gtk_update_icon_cache_LDADD = $(LDADDS) $(GLIB_LIBS)
+-gtk_update_icon_cache_LDADD = $(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la
++gtk_update_icon_cache_LDADD = $(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la $(GLIB_LIBS)
gtk_update_icon_cache_SOURCES = updateiconcache.c
- subdir = gtk
+
diff --git a/x11-toolkits/gtk20/files/patch-gtk_gtkcalendar.c b/x11-toolkits/gtk20/files/patch-gtk_gtkcalendar.c
deleted file mode 100644
index 4dcf1fd052a5..000000000000
--- a/x11-toolkits/gtk20/files/patch-gtk_gtkcalendar.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- gtk/gtkcalendar.c.orig Mon Oct 3 22:01:14 2005
-+++ gtk/gtkcalendar.c Mon Oct 3 22:02:36 2005
-@@ -566,6 +566,7 @@ gtk_calendar_init (GtkCalendar *calendar
- GtkCalendarPrivate *priv;
- gchar *year_before;
- gchar *langinfo;
-+ gchar *week_start;
- gint week_1stday = 0;
- gint first_weekday = 1;
- guint week_origin;
diff --git a/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.h b/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.h
new file mode 100644
index 000000000000..ed81f9280fac
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.h
@@ -0,0 +1,17 @@
+--- gtk/xdgmime/xdgmime.h.orig Sat Oct 7 10:42:32 2006
++++ gtk/xdgmime/xdgmime.h Sat Oct 7 11:01:57 2006
+@@ -52,11 +52,14 @@ typedef void (*XdgMimeDestroy) (void *u
+ #define xdg_mime_get_mime_type_from_file_name XDG_ENTRY(get_mime_type_from_file_name)
+ #define xdg_mime_is_valid_mime_type XDG_ENTRY(is_valid_mime_type)
+ #define xdg_mime_mime_type_equal XDG_ENTRY(mime_type_equal)
++#define _xdg_mime_mime_type_equal XDG_ENTRY(mime_type_equal_p)
+ #define xdg_mime_media_type_equal XDG_ENTRY(media_type_equal)
+ #define xdg_mime_mime_type_subclass XDG_ENTRY(mime_type_subclass)
++#define _xdg_mime_mime_type_subclass XDG_ENTRY(mime_type_subclass_p)
+ #define xdg_mime_get_mime_parents XDG_ENTRY(get_mime_parents)
+ #define xdg_mime_list_mime_parents XDG_ENTRY(list_mime_parents)
+ #define xdg_mime_unalias_mime_type XDG_ENTRY(unalias_mime_type)
++#define _xdg_mime_unalias_mime_type XDG_ENTRY(unalias_mime_type_p)
+ #define xdg_mime_get_max_buffer_extents XDG_ENTRY(get_max_buffer_extents)
+ #define xdg_mime_shutdown XDG_ENTRY(shutdown)
+ #define xdg_mime_dump XDG_ENTRY(dump)
diff --git a/x11-toolkits/gtk20/pkg-plist b/x11-toolkits/gtk20/pkg-plist
index 8eeac80c990b..cd3e647f1258 100644
--- a/x11-toolkits/gtk20/pkg-plist
+++ b/x11-toolkits/gtk20/pkg-plist
@@ -63,6 +63,7 @@ include/gtk-2.0/gtk/gtkadjustment.h
include/gtk-2.0/gtk/gtkalignment.h
include/gtk-2.0/gtk/gtkarrow.h
include/gtk-2.0/gtk/gtkaspectframe.h
+include/gtk-2.0/gtk/gtkassistant.h
include/gtk-2.0/gtk/gtkbbox.h
include/gtk-2.0/gtk/gtkbin.h
include/gtk-2.0/gtk/gtkbindings.h
@@ -72,9 +73,11 @@ include/gtk-2.0/gtk/gtkcalendar.h
include/gtk-2.0/gtk/gtkcelleditable.h
include/gtk-2.0/gtk/gtkcelllayout.h
include/gtk-2.0/gtk/gtkcellrenderer.h
+include/gtk-2.0/gtk/gtkcellrendereraccel.h
include/gtk-2.0/gtk/gtkcellrenderercombo.h
include/gtk-2.0/gtk/gtkcellrendererpixbuf.h
include/gtk-2.0/gtk/gtkcellrendererprogress.h
+include/gtk-2.0/gtk/gtkcellrendererspin.h
include/gtk-2.0/gtk/gtkcellrenderertext.h
include/gtk-2.0/gtk/gtkcellrenderertoggle.h
include/gtk-2.0/gtk/gtkcellview.h
@@ -137,6 +140,7 @@ include/gtk-2.0/gtk/gtkitem.h
include/gtk-2.0/gtk/gtkitemfactory.h
include/gtk-2.0/gtk/gtklabel.h
include/gtk-2.0/gtk/gtklayout.h
+include/gtk-2.0/gtk/gtklinkbutton.h
include/gtk-2.0/gtk/gtklist.h
include/gtk-2.0/gtk/gtklistitem.h
include/gtk-2.0/gtk/gtkliststore.h
@@ -154,10 +158,16 @@ include/gtk-2.0/gtk/gtknotebook.h
include/gtk-2.0/gtk/gtkobject.h
include/gtk-2.0/gtk/gtkoldeditable.h
include/gtk-2.0/gtk/gtkoptionmenu.h
+include/gtk-2.0/gtk/gtkpagesetup.h
include/gtk-2.0/gtk/gtkpaned.h
+include/gtk-2.0/gtk/gtkpapersize.h
include/gtk-2.0/gtk/gtkpixmap.h
include/gtk-2.0/gtk/gtkplug.h
include/gtk-2.0/gtk/gtkpreview.h
+include/gtk-2.0/gtk/gtkprintcontext.h
+include/gtk-2.0/gtk/gtkprintoperation.h
+include/gtk-2.0/gtk/gtkprintoperationpreview.h
+include/gtk-2.0/gtk/gtkprintsettings.h
include/gtk-2.0/gtk/gtkprivate.h
include/gtk-2.0/gtk/gtkprogress.h
include/gtk-2.0/gtk/gtkprogressbar.h
@@ -167,6 +177,12 @@ include/gtk-2.0/gtk/gtkradiomenuitem.h
include/gtk-2.0/gtk/gtkradiotoolbutton.h
include/gtk-2.0/gtk/gtkrange.h
include/gtk-2.0/gtk/gtkrc.h
+include/gtk-2.0/gtk/gtkrecentchooser.h
+include/gtk-2.0/gtk/gtkrecentchooserdialog.h
+include/gtk-2.0/gtk/gtkrecentchoosermenu.h
+include/gtk-2.0/gtk/gtkrecentchooserwidget.h
+include/gtk-2.0/gtk/gtkrecentfilter.h
+include/gtk-2.0/gtk/gtkrecentmanager.h
include/gtk-2.0/gtk/gtkruler.h
include/gtk-2.0/gtk/gtkscale.h
include/gtk-2.0/gtk/gtkscrollbar.h
@@ -181,12 +197,14 @@ include/gtk-2.0/gtk/gtksizegroup.h
include/gtk-2.0/gtk/gtksocket.h
include/gtk-2.0/gtk/gtkspinbutton.h
include/gtk-2.0/gtk/gtkstatusbar.h
+include/gtk-2.0/gtk/gtkstatusicon.h
include/gtk-2.0/gtk/gtkstock.h
include/gtk-2.0/gtk/gtkstyle.h
include/gtk-2.0/gtk/gtktable.h
include/gtk-2.0/gtk/gtktearoffmenuitem.h
include/gtk-2.0/gtk/gtktext.h
include/gtk-2.0/gtk/gtktextbuffer.h
+include/gtk-2.0/gtk/gtktextbufferrichtext.h
include/gtk-2.0/gtk/gtktextchild.h
include/gtk-2.0/gtk/gtktextdisplay.h
include/gtk-2.0/gtk/gtktextiter.h
@@ -228,6 +246,10 @@ include/gtk-2.0/gtk/gtkvscrollbar.h
include/gtk-2.0/gtk/gtkvseparator.h
include/gtk-2.0/gtk/gtkwidget.h
include/gtk-2.0/gtk/gtkwindow.h
+include/gtk-unix-print-2.0/gtk/gtkpagesetupunixdialog.h
+include/gtk-unix-print-2.0/gtk/gtkprinter.h
+include/gtk-unix-print-2.0/gtk/gtkprintjob.h
+include/gtk-unix-print-2.0/gtk/gtkprintunixdialog.h
lib/gtk-2.0/%%GTK_VERSION%%/engines/libpixmap.a
lib/gtk-2.0/%%GTK_VERSION%%/engines/libpixmap.la
lib/gtk-2.0/%%GTK_VERSION%%/engines/libpixmap.so
@@ -303,6 +325,15 @@ lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-xbm.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-xpm.a
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-xpm.la
lib/gtk-2.0/%%GTK_VERSION%%/loaders/libpixbufloader-xpm.so
+%%CUPS:%%lib/gtk-2.0/%%GTK_VERSION%%/printbackends/libprintbackend-cups.a
+%%CUPS:%%lib/gtk-2.0/%%GTK_VERSION%%/printbackends/libprintbackend-cups.la
+%%CUPS:%%lib/gtk-2.0/%%GTK_VERSION%%/printbackends/libprintbackend-cups.so
+lib/gtk-2.0/%%GTK_VERSION%%/printbackends/libprintbackend-file.a
+lib/gtk-2.0/%%GTK_VERSION%%/printbackends/libprintbackend-file.la
+lib/gtk-2.0/%%GTK_VERSION%%/printbackends/libprintbackend-file.so
+lib/gtk-2.0/%%GTK_VERSION%%/printbackends/libprintbackend-lpr.a
+lib/gtk-2.0/%%GTK_VERSION%%/printbackends/libprintbackend-lpr.la
+lib/gtk-2.0/%%GTK_VERSION%%/printbackends/libprintbackend-lpr.so
lib/libgdk-x11-2.0.a
lib/libgdk-x11-2.0.la
lib/libgdk-x11-2.0.so
@@ -324,11 +355,13 @@ libdata/pkgconfig/gdk-pixbuf-2.0.pc
libdata/pkgconfig/gdk-pixbuf-xlib-2.0.pc
libdata/pkgconfig/gdk-x11-2.0.pc
libdata/pkgconfig/gtk+-2.0.pc
+libdata/pkgconfig/gtk+-unix-print-2.0.pc
libdata/pkgconfig/gtk+-x11-2.0.pc
share/aclocal/gtk-2.0.m4
share/gtk-2.0/demo/alphatest.png
share/gtk-2.0/demo/apple-red.png
share/gtk-2.0/demo/appwindow.c
+share/gtk-2.0/demo/assistant.c
share/gtk-2.0/demo/background.jpg
share/gtk-2.0/demo/button_box.c
share/gtk-2.0/demo/changedisplay.c
@@ -360,9 +393,11 @@ share/gtk-2.0/demo/menus.c
share/gtk-2.0/demo/panes.c
share/gtk-2.0/demo/pickers.c
share/gtk-2.0/demo/pixbufs.c
+share/gtk-2.0/demo/printing.c
share/gtk-2.0/demo/rotated_text.c
share/gtk-2.0/demo/sizegroup.c
share/gtk-2.0/demo/stock_browser.c
+share/gtk-2.0/demo/textscroll.c
share/gtk-2.0/demo/textview.c
share/gtk-2.0/demo/tree_store.c
share/gtk-2.0/demo/ui_manager.c
@@ -370,6 +405,8 @@ share/locale/af/LC_MESSAGES/gtk20-properties.mo
share/locale/af/LC_MESSAGES/gtk20.mo
share/locale/am/LC_MESSAGES/gtk20-properties.mo
share/locale/am/LC_MESSAGES/gtk20.mo
+share/locale/ang/LC_MESSAGES/gtk20-properties.mo
+share/locale/ang/LC_MESSAGES/gtk20.mo
share/locale/ar/LC_MESSAGES/gtk20-properties.mo
share/locale/ar/LC_MESSAGES/gtk20.mo
share/locale/az/LC_MESSAGES/gtk20-properties.mo
@@ -382,6 +419,8 @@ share/locale/bg/LC_MESSAGES/gtk20-properties.mo
share/locale/bg/LC_MESSAGES/gtk20.mo
share/locale/bn/LC_MESSAGES/gtk20-properties.mo
share/locale/bn/LC_MESSAGES/gtk20.mo
+share/locale/bn_IN/LC_MESSAGES/gtk20-properties.mo
+share/locale/bn_IN/LC_MESSAGES/gtk20.mo
share/locale/br/LC_MESSAGES/gtk20-properties.mo
share/locale/br/LC_MESSAGES/gtk20.mo
share/locale/bs/LC_MESSAGES/gtk20-properties.mo
@@ -474,12 +513,10 @@ share/locale/nl/LC_MESSAGES/gtk20-properties.mo
share/locale/nl/LC_MESSAGES/gtk20.mo
share/locale/nn/LC_MESSAGES/gtk20-properties.mo
share/locale/nn/LC_MESSAGES/gtk20.mo
-share/locale/no/LC_MESSAGES/gtk20-properties.mo
-share/locale/no/LC_MESSAGES/gtk20.mo
share/locale/nso/LC_MESSAGES/gtk20-properties.mo
share/locale/nso/LC_MESSAGES/gtk20.mo
-share/locale/or/LC_MESSAGES/gtk20.mo
share/locale/or/LC_MESSAGES/gtk20-properties.mo
+share/locale/or/LC_MESSAGES/gtk20.mo
share/locale/pa/LC_MESSAGES/gtk20-properties.mo
share/locale/pa/LC_MESSAGES/gtk20.mo
share/locale/pl/LC_MESSAGES/gtk20-properties.mo
@@ -518,8 +555,12 @@ share/locale/tk/LC_MESSAGES/gtk20-properties.mo
share/locale/tk/LC_MESSAGES/gtk20.mo
share/locale/tr/LC_MESSAGES/gtk20-properties.mo
share/locale/tr/LC_MESSAGES/gtk20.mo
+share/locale/tt/LC_MESSAGES/gtk20-properties.mo
+share/locale/tt/LC_MESSAGES/gtk20.mo
share/locale/uk/LC_MESSAGES/gtk20-properties.mo
share/locale/uk/LC_MESSAGES/gtk20.mo
+share/locale/ur/LC_MESSAGES/gtk20-properties.mo
+share/locale/ur/LC_MESSAGES/gtk20.mo
share/locale/uz/LC_MESSAGES/gtk20-properties.mo
share/locale/uz/LC_MESSAGES/gtk20.mo
share/locale/uz@Latn/LC_MESSAGES/gtk20-properties.mo
@@ -541,8 +582,8 @@ share/locale/zh_TW/LC_MESSAGES/gtk20.mo
share/themes/Default/gtk-2.0-key/gtkrc
share/themes/Emacs/gtk-2.0-key/gtkrc
share/themes/Raleigh/gtk-2.0/gtkrc
-@exec /usr/bin/find %%X11BASE%%/share/icons -type d -depth 1 -exec %D/bin/gtk-update-icon-cache -q -f {} \; 2>/dev/null || /usr/bin/true
-@unexec /usr/bin/find %%X11BASE%%/share/icons -type f -depth 2 -name icon-theme.cache -delete 2>/dev/null || /usr/bin/true
+@exec /usr/bin/find %%LOCALBASE%%/share/icons -type d -depth 1 -exec %D/bin/gtk-update-icon-cache -q -f {} \; 2>/dev/null || /usr/bin/true
+@unexec /usr/bin/find %%LOCALBASE%%/share/icons -type f -depth 2 -name icon-theme.cache -delete 2>/dev/null || /usr/bin/true
@dirrm share/themes/Raleigh/gtk-2.0
@dirrm share/themes/Raleigh
@dirrm share/themes/Emacs/gtk-2.0-key
@@ -550,6 +591,8 @@ share/themes/Raleigh/gtk-2.0/gtkrc
@dirrm share/themes/Default/gtk-2.0-key
@dirrm share/gtk-2.0/demo
@dirrm share/gtk-2.0
+@dirrm include/gtk-unix-print-2.0/gtk
+@dirrm include/gtk-unix-print-2.0
@dirrm include/gtk-2.0/gtk
@dirrm include/gtk-2.0/gdk-pixbuf-xlib
@dirrm include/gtk-2.0/gdk-pixbuf
@@ -560,41 +603,90 @@ share/themes/Raleigh/gtk-2.0/gtkrc
@exec /bin/mkdir -p %D/lib/gtk-2.0/%%GTK_VERSION%%/engines
@dirrmtry share/themes/Default
@dirrmtry share/themes
+@dirrmtry lib/gtk-2.0/modules
+@dirrmtry lib/gtk-2.0/%%GTK_VERSION%%/printbackends
+@dirrmtry lib/gtk-2.0/%%GTK_VERSION%%/loaders
+@dirrmtry lib/gtk-2.0/%%GTK_VERSION%%/immodules
+@dirrmtry lib/gtk-2.0/%%GTK_VERSION%%/engines
+@dirrmtry lib/gtk-2.0/%%GTK_VERSION%%
+@dirrmtry lib/gtk-2.0
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
@dirrmtry share/locale/yi/LC_MESSAGES
@dirrmtry share/locale/yi
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
@dirrmtry share/locale/uz@Latn/LC_MESSAGES
@dirrmtry share/locale/uz@Latn
+@dirrmtry share/locale/uz/LC_MESSAGES
+@dirrmtry share/locale/uz
+@dirrmtry share/locale/ur/LC_MESSAGES
+@dirrmtry share/locale/ur
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/tt/LC_MESSAGES
+@dirrmtry share/locale/tt
+@dirrmtry share/locale/tk/LC_MESSAGES
+@dirrmtry share/locale/tk
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
@dirrmtry share/locale/sr@ije/LC_MESSAGES
@dirrmtry share/locale/sr@ije
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
@dirrmtry share/locale/nso/LC_MESSAGES
@dirrmtry share/locale/nso
+@dirrmtry share/locale/nn/LC_MESSAGES
+@dirrmtry share/locale/nn
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
@dirrmtry share/locale/mi/LC_MESSAGES
@dirrmtry share/locale/mi
+@dirrmtry share/locale/li/LC_MESSAGES
+@dirrmtry share/locale/li
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
@dirrmtry share/locale/ia/LC_MESSAGES
@dirrmtry share/locale/ia
@dirrmtry share/locale/hy/LC_MESSAGES
@dirrmtry share/locale/hy
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
-@dirrmtry share/locale/br/LC_MESSAGES
-@dirrmtry share/locale/br
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be/LC_MESSAGES
+@dirrmtry share/locale/be
@dirrmtry share/locale/az_IR/LC_MESSAGES
@dirrmtry share/locale/az_IR
-@dirrmtry lib/gtk-2.0/modules
-@dirrmtry lib/gtk-2.0/%%GTK_VERSION%%/loaders
-@dirrmtry lib/gtk-2.0/%%GTK_VERSION%%/immodules
-@dirrmtry lib/gtk-2.0/%%GTK_VERSION%%/engines
-@dirrmtry lib/gtk-2.0/%%GTK_VERSION%%
-@dirrmtry lib/gtk-2.0
+@dirrmtry share/locale/ang/LC_MESSAGES
+@dirrmtry share/locale/ang