aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk30
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-08-09 06:49:20 +0800
committermezz <mezz@FreeBSD.org>2004-08-09 06:49:20 +0800
commit6cdd053c177ac7d8b50eea151a7fdc0229d02d80 (patch)
treeeb82a7a6891790d50e3e5ae69b82db7973f8fc02 /x11-toolkits/gtk30
parent6d6750455484399378c7c83228fdbfa92ef8492d (diff)
downloadfreebsd-ports-gnome-6cdd053c177ac7d8b50eea151a7fdc0229d02d80.tar.gz
freebsd-ports-gnome-6cdd053c177ac7d8b50eea151a7fdc0229d02d80.tar.zst
freebsd-ports-gnome-6cdd053c177ac7d8b50eea151a7fdc0229d02d80.zip
Use new libtool scheme.
Diffstat (limited to 'x11-toolkits/gtk30')
-rw-r--r--x11-toolkits/gtk30/Makefile2
-rw-r--r--x11-toolkits/gtk30/files/patch-ltmain.sh51
2 files changed, 1 insertions, 52 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 9245bc79b0f2..9d06e6ce6950 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -43,7 +43,7 @@ USE_XPM= yes
USE_REINPLACE= yes
USE_PERL5= yes
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
USE_GNOME= gnomehack atk pango
CONFIGURE_ARGS= --enable-static --with-xinput=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
diff --git a/x11-toolkits/gtk30/files/patch-ltmain.sh b/x11-toolkits/gtk30/files/patch-ltmain.sh
deleted file mode 100644
index 58384ee38d2e..000000000000
--- a/x11-toolkits/gtk30/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Sat Dec 6 14:47:45 2003
-+++ ltmain.sh Tue Dec 9 14:09:01 2003
-@@ -1280,7 +1280,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1290,8 +1290,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -3000,6 +3008,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5428,10 +5439,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"