aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtksourceview3
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-19 23:15:31 +0800
committerkwm <kwm@FreeBSD.org>2013-03-19 23:15:31 +0800
commit18608b14ceb3d76ed34e83306c9e07954e8e5ef6 (patch)
treecb327f365a61d588c556827a47c604b780f171f3 /x11-toolkits/gtksourceview3
parent75c6250f1a8b983cc92e924b0b9b1fe4ff9f4705 (diff)
downloadfreebsd-ports-gnome-18608b14ceb3d76ed34e83306c9e07954e8e5ef6.tar.gz
freebsd-ports-gnome-18608b14ceb3d76ed34e83306c9e07954e8e5ef6.tar.zst
freebsd-ports-gnome-18608b14ceb3d76ed34e83306c9e07954e8e5ef6.zip
Add gtksourceview 3.4.2.
GtkSourceView is a text widget for Gtk+-3 that provides syntax highlighting and other features typically expected in a source code editor. Obtained from: gnome team repo
Diffstat (limited to 'x11-toolkits/gtksourceview3')
-rw-r--r--x11-toolkits/gtksourceview3/Makefile37
-rw-r--r--x11-toolkits/gtksourceview3/distinfo2
-rw-r--r--x11-toolkits/gtksourceview3/files/patch-Makefile.in11
-rw-r--r--x11-toolkits/gtksourceview3/pkg-descr2
-rw-r--r--x11-toolkits/gtksourceview3/pkg-plist296
5 files changed, 348 insertions, 0 deletions
diff --git a/x11-toolkits/gtksourceview3/Makefile b/x11-toolkits/gtksourceview3/Makefile
new file mode 100644
index 000000000000..58b72167b820
--- /dev/null
+++ b/x11-toolkits/gtksourceview3/Makefile
@@ -0,0 +1,37 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/x11-toolkits/gtksourceview3/Makefile,v 1.21 2012/05/31 11:57:38 kwm Exp $
+
+PORTNAME= gtksourceview
+PORTVERSION= 3.4.2
+PORTREVISION?= 0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= GNOME
+PKGNAMESUFFIX= 3
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A text widget that adds syntax highlighting to the GtkTextView widget
+
+USE_XZ= yes
+
+.if !defined(REFERENCE_PORT)
+
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= yes
+USES= pathfix
+USE_GNOME= gnomeprefix gtk30 libxml2 intlhack ltverhack referencehack
+CONFIGURE_ARGS= --enable-compile-warnings=no --enable-glade-catalog=no \
+ --enable-introspection
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|--warn-all||g' \
+ ${WRKSRC}/gtksourceview/Makefile.in
+
+.include <bsd.port.mk>
+
+.endif
diff --git a/x11-toolkits/gtksourceview3/distinfo b/x11-toolkits/gtksourceview3/distinfo
new file mode 100644
index 000000000000..6a01230220f1
--- /dev/null
+++ b/x11-toolkits/gtksourceview3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/gtksourceview-3.4.2.tar.xz) = 5a5712591b2b6487818ac4aadd965fc8397af23d8fd7c5bdd1460c6326a8f4ce
+SIZE (gnome3/gtksourceview-3.4.2.tar.xz) = 1213360
diff --git a/x11-toolkits/gtksourceview3/files/patch-Makefile.in b/x11-toolkits/gtksourceview3/files/patch-Makefile.in
new file mode 100644
index 000000000000..5a7bf7d7c3c6
--- /dev/null
+++ b/x11-toolkits/gtksourceview3/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2011-02-02 00:24:30.000000000 +0000
++++ Makefile.in 2011-02-02 00:24:36.000000000 +0000
+@@ -306,7 +306,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+-SUBDIRS = gtksourceview po data docs tests
++SUBDIRS = gtksourceview po data docs
+ pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = gtksourceview-3.0.pc
+ EXTRA_DIST = \
diff --git a/x11-toolkits/gtksourceview3/pkg-descr b/x11-toolkits/gtksourceview3/pkg-descr
new file mode 100644
index 000000000000..8070096cc763
--- /dev/null
+++ b/x11-toolkits/gtksourceview3/pkg-descr
@@ -0,0 +1,2 @@
+GtkSourceView is a text widget for Gtk+-3 that provides syntax highlighting
+and other features typically expected in a source code editor.
diff --git a/x11-toolkits/gtksourceview3/pkg-plist b/x11-toolkits/gtksourceview3/pkg-plist
new file mode 100644
index 000000000000..2640d7edf55b
--- /dev/null
+++ b/x11-toolkits/gtksourceview3/pkg-plist
@@ -0,0 +1,296 @@
+include/gtksourceview-3.0/gtksourceview/completion-providers/words/gtksourcecompletionwords.h
+include/gtksourceview-3.0/gtksourceview/gtksource.h
+include/gtksourceview-3.0/gtksourceview/gtksourcebuffer.h
+include/gtksourceview-3.0/gtksourceview/gtksourcecompletion.h
+include/gtksourceview-3.0/gtksourceview/gtksourcecompletioncontext.h
+include/gtksourceview-3.0/gtksourceview/gtksourcecompletioninfo.h
+include/gtksourceview-3.0/gtksourceview/gtksourcecompletionitem.h
+include/gtksourceview-3.0/gtksourceview/gtksourcecompletionproposal.h
+include/gtksourceview-3.0/gtksourceview/gtksourcecompletionprovider.h
+include/gtksourceview-3.0/gtksourceview/gtksourcegutter.h
+include/gtksourceview-3.0/gtksourceview/gtksourcegutterrenderer.h
+include/gtksourceview-3.0/gtksourceview/gtksourcegutterrendererpixbuf.h
+include/gtksourceview-3.0/gtksourceview/gtksourcegutterrenderertext.h
+include/gtksourceview-3.0/gtksourceview/gtksourcelanguage.h
+include/gtksourceview-3.0/gtksourceview/gtksourcelanguagemanager.h
+include/gtksourceview-3.0/gtksourceview/gtksourcemark.h
+include/gtksourceview-3.0/gtksourceview/gtksourcemarkattributes.h
+include/gtksourceview-3.0/gtksourceview/gtksourceprintcompositor.h
+include/gtksourceview-3.0/gtksourceview/gtksourcestyle.h
+include/gtksourceview-3.0/gtksourceview/gtksourcestylescheme.h
+include/gtksourceview-3.0/gtksourceview/gtksourcestyleschememanager.h
+include/gtksourceview-3.0/gtksourceview/gtksourceundomanager.h
+include/gtksourceview-3.0/gtksourceview/gtksourceview-typebuiltins.h
+include/gtksourceview-3.0/gtksourceview/gtksourceview.h
+lib/girepository-1.0/GtkSource-3.0.typelib
+lib/libgtksourceview-3.0.a
+lib/libgtksourceview-3.0.la
+lib/libgtksourceview-3.0.so
+lib/libgtksourceview-3.0.so.0
+libdata/pkgconfig/gtksourceview-3.0.pc
+share/gir-1.0/GtkSource-3.0.gir
+share/doc/gtksourceview-3.0/GtkSourceBuffer.html
+share/doc/gtksourceview-3.0/GtkSourceCompletion.html
+share/doc/gtksourceview-3.0/GtkSourceCompletionInfo.html
+share/doc/gtksourceview-3.0/GtkSourceCompletionItem.html
+share/doc/gtksourceview-3.0/GtkSourceCompletionProposal.html
+share/doc/gtksourceview-3.0/GtkSourceCompletionProvider.html
+share/doc/gtksourceview-3.0/GtkSourceGutter.html
+share/doc/gtksourceview-3.0/GtkSourceLanguage.html
+share/doc/gtksourceview-3.0/GtkSourceLanguageManager.html
+share/doc/gtksourceview-3.0/GtkSourceMark.html
+share/doc/gtksourceview-3.0/GtkSourceMarkAttributes.html
+share/doc/gtksourceview-3.0/GtkSourcePrintCompositor.html
+share/doc/gtksourceview-3.0/GtkSourceStyle.html
+share/doc/gtksourceview-3.0/GtkSourceStyleScheme.html
+share/doc/gtksourceview-3.0/GtkSourceStyleSchemeManager.html
+share/doc/gtksourceview-3.0/GtkSourceUndoManager.html
+share/doc/gtksourceview-3.0/GtkSourceView.html
+share/doc/gtksourceview-3.0/annotation-glossary.html
+share/doc/gtksourceview-3.0/api-index-3-0.html
+share/doc/gtksourceview-3.0/api-index-deprecated.html
+share/doc/gtksourceview-3.0/api-index-full.html
+share/doc/gtksourceview-3.0/gtksourceview-3.0-GtkSourceGutterRenderer.html
+share/doc/gtksourceview-3.0/gtksourceview-3.0-GtkSourceGutterRendererPixbuf.html
+share/doc/gtksourceview-3.0/gtksourceview-3.0-GtkSourceGutterRendererText.html
+share/doc/gtksourceview-3.0/gtksourceview-3.0-completioncontext.html
+share/doc/gtksourceview-3.0/gtksourceview-3.0.devhelp2
+share/doc/gtksourceview-3.0/home.png
+share/doc/gtksourceview-3.0/index.html
+share/doc/gtksourceview-3.0/index.sgml
+share/doc/gtksourceview-3.0/lang-reference.html
+share/doc/gtksourceview-3.0/lang-tutorial.html
+share/doc/gtksourceview-3.0/left.png
+share/doc/gtksourceview-3.0/right.png
+share/doc/gtksourceview-3.0/rn01.html
+share/doc/gtksourceview-3.0/rn02.html
+share/doc/gtksourceview-3.0/style-reference.html
+share/doc/gtksourceview-3.0/style.css
+share/doc/gtksourceview-3.0/up.png
+share/gtksourceview-3.0/language-specs/R.lang
+share/gtksourceview-3.0/language-specs/ada.lang
+share/gtksourceview-3.0/language-specs/asp.lang
+share/gtksourceview-3.0/language-specs/automake.lang
+share/gtksourceview-3.0/language-specs/awk.lang
+share/gtksourceview-3.0/language-specs/bennugd.lang
+share/gtksourceview-3.0/language-specs/bibtex.lang
+share/gtksourceview-3.0/language-specs/boo.lang
+share/gtksourceview-3.0/language-specs/c.lang
+share/gtksourceview-3.0/language-specs/cg.lang
+share/gtksourceview-3.0/language-specs/changelog.lang
+share/gtksourceview-3.0/language-specs/check-language.sh
+share/gtksourceview-3.0/language-specs/chdr.lang
+share/gtksourceview-3.0/language-specs/cmake.lang
+share/gtksourceview-3.0/language-specs/cobol.lang
+share/gtksourceview-3.0/language-specs/cpp.lang
+share/gtksourceview-3.0/language-specs/csharp.lang
+share/gtksourceview-3.0/language-specs/css.lang
+share/gtksourceview-3.0/language-specs/cuda.lang
+share/gtksourceview-3.0/language-specs/d.lang
+share/gtksourceview-3.0/language-specs/def.lang
+share/gtksourceview-3.0/language-specs/desktop.lang
+share/gtksourceview-3.0/language-specs/diff.lang
+share/gtksourceview-3.0/language-specs/docbook.lang
+share/gtksourceview-3.0/language-specs/dosbatch.lang
+share/gtksourceview-3.0/language-specs/dot.lang
+share/gtksourceview-3.0/language-specs/dpatch.lang
+share/gtksourceview-3.0/language-specs/dtd.lang
+share/gtksourceview-3.0/language-specs/eiffel.lang
+share/gtksourceview-3.0/language-specs/erlang.lang
+share/gtksourceview-3.0/language-specs/fcl.lang
+share/gtksourceview-3.0/language-specs/forth.lang
+share/gtksourceview-3.0/language-specs/fortran.lang
+share/gtksourceview-3.0/language-specs/fsharp.lang
+share/gtksourceview-3.0/language-specs/gap.lang
+share/gtksourceview-3.0/language-specs/gdb-log.lang
+share/gtksourceview-3.0/language-specs/glsl.lang
+share/gtksourceview-3.0/language-specs/go.lang
+share/gtksourceview-3.0/language-specs/gtk-doc.lang
+share/gtksourceview-3.0/language-specs/gtkrc.lang
+share/gtksourceview-3.0/language-specs/haddock.lang
+share/gtksourceview-3.0/language-specs/haskell-literate.lang
+share/gtksourceview-3.0/language-specs/haskell.lang
+share/gtksourceview-3.0/language-specs/html.lang
+share/gtksourceview-3.0/language-specs/idl.lang
+share/gtksourceview-3.0/language-specs/imagej.lang
+share/gtksourceview-3.0/language-specs/ini.lang
+share/gtksourceview-3.0/language-specs/java.lang
+share/gtksourceview-3.0/language-specs/javascript.lang
+share/gtksourceview-3.0/language-specs/json.lang
+share/gtksourceview-3.0/language-specs/language.dtd
+share/gtksourceview-3.0/language-specs/language.rng
+share/gtksourceview-3.0/language-specs/language2.rng
+share/gtksourceview-3.0/language-specs/latex.lang
+share/gtksourceview-3.0/language-specs/libtool.lang
+share/gtksourceview-3.0/language-specs/lua.lang
+share/gtksourceview-3.0/language-specs/m4.lang
+share/gtksourceview-3.0/language-specs/makefile.lang
+share/gtksourceview-3.0/language-specs/mallard.lang
+share/gtksourceview-3.0/language-specs/markdown.lang
+share/gtksourceview-3.0/language-specs/matlab.lang
+share/gtksourceview-3.0/language-specs/nemerle.lang
+share/gtksourceview-3.0/language-specs/nsis.lang
+share/gtksourceview-3.0/language-specs/objc.lang
+share/gtksourceview-3.0/language-specs/objj.lang
+share/gtksourceview-3.0/language-specs/ocaml.lang
+share/gtksourceview-3.0/language-specs/ocl.lang
+share/gtksourceview-3.0/language-specs/octave.lang
+share/gtksourceview-3.0/language-specs/ooc.lang
+share/gtksourceview-3.0/language-specs/opal.lang
+share/gtksourceview-3.0/language-specs/opencl.lang
+share/gtksourceview-3.0/language-specs/pascal.lang
+share/gtksourceview-3.0/language-specs/perl.lang
+share/gtksourceview-3.0/language-specs/php.lang
+share/gtksourceview-3.0/language-specs/pkgconfig.lang
+share/gtksourceview-3.0/language-specs/po.lang
+share/gtksourceview-3.0/language-specs/prolog.lang
+share/gtksourceview-3.0/language-specs/protobuf.lang
+share/gtksourceview-3.0/language-specs/python.lang
+share/gtksourceview-3.0/language-specs/python3.lang
+share/gtksourceview-3.0/language-specs/rpmspec.lang
+share/gtksourceview-3.0/language-specs/ruby.lang
+share/gtksourceview-3.0/language-specs/scheme.lang
+share/gtksourceview-3.0/language-specs/scilab.lang
+share/gtksourceview-3.0/language-specs/sh.lang
+share/gtksourceview-3.0/language-specs/sml.lang
+share/gtksourceview-3.0/language-specs/sparql.lang
+share/gtksourceview-3.0/language-specs/sql.lang
+share/gtksourceview-3.0/language-specs/systemverilog.lang
+share/gtksourceview-3.0/language-specs/t2t.lang
+share/gtksourceview-3.0/language-specs/tcl.lang
+share/gtksourceview-3.0/language-specs/texinfo.lang
+share/gtksourceview-3.0/language-specs/vala.lang
+share/gtksourceview-3.0/language-specs/vbnet.lang
+share/gtksourceview-3.0/language-specs/verilog.lang
+share/gtksourceview-3.0/language-specs/vhdl.lang
+share/gtksourceview-3.0/language-specs/xml.lang
+share/gtksourceview-3.0/language-specs/xslt.lang
+share/gtksourceview-3.0/language-specs/yacc.lang
+share/gtksourceview-3.0/styles/check-style.sh
+share/gtksourceview-3.0/styles/classic.xml
+share/gtksourceview-3.0/styles/cobalt.xml
+share/gtksourceview-3.0/styles/kate.xml
+share/gtksourceview-3.0/styles/oblivion.xml
+share/gtksourceview-3.0/styles/styles.rng
+share/gtksourceview-3.0/styles/tango.xml
+share/locale/ar/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/as/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ast/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/az/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/be/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/bg/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/bn/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/bn_IN/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/bs/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ca/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ca@valencia/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/cs/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/cy/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/da/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/de/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/dz/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/el/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/en@shaw/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/en_CA/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/en_GB/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/eo/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/es/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/et/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/eu/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/fa/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/fi/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/fr/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ga/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/gl/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/gu/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/he/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/hi/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/hr/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/hu/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/id/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/it/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ja/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/kn/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ko/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/lt/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/lv/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/mai/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/mg/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/mk/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ml/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/mn/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/mr/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ms/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/nb/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ne/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/nl/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/nn/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/oc/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/or/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/pa/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/pl/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/pt/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/pt_BR/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ro/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ru/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/rw/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/si/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/sk/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/sl/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/sq/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/sr/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/sr@latin/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/sv/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ta/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/te/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/th/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/tr/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/ug/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/uk/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/vi/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/xh/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/zh_CN/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/zh_HK/LC_MESSAGES/gtksourceview-3.0.mo
+share/locale/zh_TW/LC_MESSAGES/gtksourceview-3.0.mo
+@dirrm share/gtksourceview-3.0/styles
+@dirrm share/gtksourceview-3.0/language-specs
+@dirrm share/gtksourceview-3.0
+@dirrm share/doc/gtksourceview-3.0/
+@dirrm include/gtksourceview-3.0/gtksourceview/completion-providers/words
+@dirrm include/gtksourceview-3.0/gtksourceview/completion-providers
+@dirrm include/gtksourceview-3.0/gtksourceview
+@dirrm include/gtksourceview-3.0
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as