aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/libxfce4gui/Makefile
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2019-01-22 22:44:38 +0800
committermadpilot <madpilot@FreeBSD.org>2019-01-22 22:44:38 +0800
commitbba326c0aa28c7d297840792c51b7a2504de369a (patch)
tree0b87a1825693d30844e1b681ab080746ab147896 /x11-toolkits/libxfce4gui/Makefile
parent2295fbe73fcb0632fc1753aa5149f612b287ecf5 (diff)
downloadfreebsd-ports-gnome-bba326c0aa28c7d297840792c51b7a2504de369a.tar.gz
freebsd-ports-gnome-bba326c0aa28c7d297840792c51b7a2504de369a.tar.zst
freebsd-ports-gnome-bba326c0aa28c7d297840792c51b7a2504de369a.zip
Clenup xfce ports:
- Add missing dependencies - Remove unneeded patches - Regenerate and rename legacy patches - Add NLS option to ports providing such a knob, and missing the option - Add INSTALL_TARGET=install-strip where missing - Sort things - Remove unneeded += - Cosmetic changes to OPTION related variables to improve readability - Update WWW - Silence portlint warnings about variables order - Bump PORTREVISION where changing dependencies and/or adding install-strip
Diffstat (limited to 'x11-toolkits/libxfce4gui/Makefile')
-rw-r--r--x11-toolkits/libxfce4gui/Makefile31
1 files changed, 19 insertions, 12 deletions
diff --git a/x11-toolkits/libxfce4gui/Makefile b/x11-toolkits/libxfce4gui/Makefile
index 99da5482ea23..4b35ea8624e9 100644
--- a/x11-toolkits/libxfce4gui/Makefile
+++ b/x11-toolkits/libxfce4gui/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libxfce4gui
PORTVERSION= 4.10.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11-toolkits xfce
MASTER_SITES= XFCE/src/archive/libxfcegui4/${PORTVERSION:R}
DISTNAME= libxfcegui4-${PORTVERSION}
@@ -14,24 +14,31 @@ COMMENT= Various Gtk widgets for the Xfce Desktop
LICENSE= GPLv2
-GNU_CONFIGURE= yes
-INSTALLS_ICONS= yes
-USES= gmake libtool pathfix pkgconfig gettext-tools xfce tar:bzip2
-USE_GNOME= gtk20 intltool intlhack libglade2
-USE_LDCONFIG= yes
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= gettext-tools gmake gnome libtool pathfix pkgconfig tar:bzip2 xfce
+USE_GNOME= cairo gtk20 intlhack intltool libglade2
USE_XFCE= libutil
-USE_XORG= sm x11
+USE_XORG= ice sm x11
+USE_LDCONFIG= yes
-CONFIGURE_ARGS+=--disable-gladeui --disable-static \
- --without-html-dir
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= --disable-gladeui --disable-static \
+ --without-html-dir
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= NLS STARTUP
OPTIONS_DEFAULT= STARTUP
-STARTUP_DESC= Startup notification
-NLS_USES= gettext-runtime
+OPTIONS_SUB= yes
+
+STARTUP_DESC= Startup notification
+
+NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
+
STARTUP_LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification
STARTUP_CONFIGURE_ENABLE= startup-notification
-OPTIONS_SUB= yes
.include <bsd.port.mk>