aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/pango/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-03-08 15:42:15 +0800
committerKoop Mast <kwm@FreeBSD.org>2014-03-08 15:42:15 +0800
commit3bf6745ab6c1685b5c18ff8363cd5fcbb4562cb8 (patch)
tree04787c3630ed67b3fe702115e7e83d25861fdd1b /x11-toolkits/pango/Makefile
parent8c3c054f9f25a64c912448947c01495d55ea4a1a (diff)
downloadfreebsd-ports-gnome-3bf6745ab6c1685b5c18ff8363cd5fcbb4562cb8.tar.gz
freebsd-ports-gnome-3bf6745ab6c1685b5c18ff8363cd5fcbb4562cb8.tar.zst
freebsd-ports-gnome-3bf6745ab6c1685b5c18ff8363cd5fcbb4562cb8.zip
Stagify
Use new lib_depend syntax. Switch to USES=libtool Other ports may install pango modules, deal with the fact that etc/pango/pango.modules might have changed since install. Requested by: miwi Obtained from: GNOME dev repo.
Diffstat (limited to 'x11-toolkits/pango/Makefile')
-rw-r--r--x11-toolkits/pango/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/x11-toolkits/pango/Makefile b/x11-toolkits/pango/Makefile
index bce0e013571e..f090a219d5cb 100644
--- a/x11-toolkits/pango/Makefile
+++ b/x11-toolkits/pango/Makefile
@@ -1,6 +1,6 @@
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/x11-toolkits/pango/Makefile 18610 2013-06-30 16:33:05Z marcus $
+# $MCom: ports/trunk/x11-toolkits/pango/Makefile 19012 2014-03-08 07:21:34Z kwm $
PORTNAME= pango
PORTVERSION= 1.34.1
@@ -10,24 +10,23 @@ MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= An open-source framework for the layout and rendering of i18n text
+COMMENT= Open-source framework for the layout and rendering of i18n text
USE_XZ= yes
.if !defined(REFERENCE_PORT)
BUILD_DEPENDS= fontconfig>=2.10.91:${PORTSDIR}/x11-fonts/fontconfig
-LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo \
- freetype:${PORTSDIR}/print/freetype2 \
- harfbuzz:${PORTSDIR}/print/harfbuzz \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libharfbuzz.so:${PORTSDIR}/print/harfbuzz \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= ${FONTSCALE}:${PORTSDIR}/x11-fonts/xorg-fonts-truetype \
${FONTENCOD}:${PORTSDIR}/x11-fonts/encodings
-USES= gettext gmake pathfix pkgconfig
+USES= gettext gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
-USE_GNOME= glib20 gnomehier ltverhack referencehack introspection:build
+GNU_CONFIGURE= yes
+USE_GNOME= cairo glib20 introspection:build referencehack
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -36,17 +35,14 @@ PLIST_SUB= VERSION="1.8.0"
FONTSCALE= ${LOCALBASE}/lib/X11/fonts/TTF/luximb.ttf
FONTENCOD= ${LOCALBASE}/lib/X11/fonts/encodings/encodings.dir
-MAN1= pango-view.1 pango-querymodules.1
-
OPTIONS_DEFINE= X11
OPTIONS_DEFAULT=X11
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
USE_XORG+= xft xrender
-#CONFIGURE_ARGS=--with-xft
+#CONFIGURE_ARGS+=--with-xft
PLIST_SUB+= X11=""
.else
CONFIGURE_ARGS+=--without-xft
@@ -59,6 +55,11 @@ pre-configure:
@${FALSE}
.endif
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/pango/
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpango*-1.0.so.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pango/*/modules/pango-*.so
+
.include <bsd.port.mk>
.endif