aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/pango
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-03-29 13:43:32 +0800
committermarcus <marcus@FreeBSD.org>2003-03-29 13:43:32 +0800
commitdeaa00ca2dac3dc85d9a4f33582dfaed6838108e (patch)
tree95c406e2d8ab8e5459b4515d6af4e0e924d03453 /x11-toolkits/pango
parent0d745b269d48188a9778122bba47347a526ca644 (diff)
downloadfreebsd-ports-gnome-deaa00ca2dac3dc85d9a4f33582dfaed6838108e.tar.gz
freebsd-ports-gnome-deaa00ca2dac3dc85d9a4f33582dfaed6838108e.tar.zst
freebsd-ports-gnome-deaa00ca2dac3dc85d9a4f33582dfaed6838108e.zip
Run fc-cache -f after installing pango just to make sure GNOME 2
gets some fonts registered. The real fix for this will be to make sure each XFree86 font port runs fc-cache after installation. This is being committed here so to fix the GNOME package install for 4.8-RELEASE. Reported by: murray
Diffstat (limited to 'x11-toolkits/pango')
-rw-r--r--x11-toolkits/pango/Makefile7
-rw-r--r--x11-toolkits/pango/pkg-install8
2 files changed, 14 insertions, 1 deletions
diff --git a/x11-toolkits/pango/Makefile b/x11-toolkits/pango/Makefile
index 7d70c96a20b2..dcb3b253421f 100644
--- a/x11-toolkits/pango/Makefile
+++ b/x11-toolkits/pango/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pango
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/${PORTNAME}/1.2,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
@@ -57,5 +57,10 @@ PLIST_SUB+= XFREE4:=""
post-patch:
@${FIND} ${WRKSRC}/pango/opentype -name "*.[ch]" | xargs ${REINPLACE_CMD} -e \
's|internal/tterrors\.h|fterrors.h| ; s|TT_Err_|FT_Err_|g'
+
+post-install:
+.if !defined(PACKAGE_BUILDING)
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/pango/pkg-install b/x11-toolkits/pango/pkg-install
new file mode 100644
index 000000000000..62581669e328
--- /dev/null
+++ b/x11-toolkits/pango/pkg-install
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:${PATH}
+export PATH
+
+if [ "$2" = "POST-INSTALL" ]; then
+ fc-cache -f >/dev/null 2>&1
+fi