aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-qt
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-01-11 05:58:34 +0800
committerlofi <lofi@FreeBSD.org>2005-01-11 05:58:34 +0800
commit37fce21c55b1fff038f510d4c5d56b29bd8e61b1 (patch)
tree12e137c212406f0bd5f631906156e73b116746ab /x11-toolkits/py-qt
parenta40c469b3010ec8b553dd55391737e8da7182a47 (diff)
downloadfreebsd-ports-gnome-37fce21c55b1fff038f510d4c5d56b29bd8e61b1.tar.gz
freebsd-ports-gnome-37fce21c55b1fff038f510d4c5d56b29bd8e61b1.tar.zst
freebsd-ports-gnome-37fce21c55b1fff038f510d4c5d56b29bd8e61b1.zip
Fix build with python 2.4
PR: ports/76009 Submitted by: Tobias Roth <ports@fsck.ch>
Diffstat (limited to 'x11-toolkits/py-qt')
-rw-r--r--x11-toolkits/py-qt/Makefile3
-rw-r--r--x11-toolkits/py-qt/files/patch-sip::qt::qstring.sip11
2 files changed, 13 insertions, 1 deletions
diff --git a/x11-toolkits/py-qt/Makefile b/x11-toolkits/py-qt/Makefile
index 68dcd7713dc8..313e6d50ebe8 100644
--- a/x11-toolkits/py-qt/Makefile
+++ b/x11-toolkits/py-qt/Makefile
@@ -6,6 +6,7 @@
PORTNAME= qt
PORTVERSION= 3.13
+PORTREVISION= 1
CATEGORIES= x11-toolkits python
MASTER_SITES= http://www.river-bank.demon.co.uk/download/PyQt/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,7 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/sip:${PORTSDIR}/devel/py-sip
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_QT_VER= 3
-USE_PYTHON= 2.3
+USE_PYTHON= yes
USE_REINPLACE= yes
.include <bsd.port.pre.mk>
diff --git a/x11-toolkits/py-qt/files/patch-sip::qt::qstring.sip b/x11-toolkits/py-qt/files/patch-sip::qt::qstring.sip
new file mode 100644
index 000000000000..5e64c89a22e4
--- /dev/null
+++ b/x11-toolkits/py-qt/files/patch-sip::qt::qstring.sip
@@ -0,0 +1,11 @@
+--- sip/qt/qstring.sip.orig Sun Jan 9 20:06:08 2005
++++ sip/qt/qstring.sip Sun Jan 9 20:06:25 2005
+@@ -851,7 +851,7 @@
+ int len = PyUnicode_GET_SIZE(sipPy);
+
+ for (int i = 0; i < len; ++i)
+- qs->ref(i) = ucode[i];
++ qs->ref(i) = QChar(uint(ucode[i]));
+ #else
+ qs -> setUnicodeCodes((ushort *)PyUnicode_AS_UNICODE(sipPy),PyUnicode_GET_SIZE(sipPy));
+ #endif \ No newline at end of file