aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qt23
diff options
context:
space:
mode:
authornik <nik@FreeBSD.org>2001-06-22 16:46:34 +0800
committernik <nik@FreeBSD.org>2001-06-22 16:46:34 +0800
commit978fe64e3ce34312c604ffb3854cfa54c302d2e8 (patch)
tree442914c3ab8a9ab49dd4f9ad76efaf241a70cf98 /x11-toolkits/qt23
parent8b8b7155db6b6f08fa0a853ef0bd79a6e3be0f06 (diff)
downloadfreebsd-ports-gnome-978fe64e3ce34312c604ffb3854cfa54c302d2e8.tar.gz
freebsd-ports-gnome-978fe64e3ce34312c604ffb3854cfa54c302d2e8.tar.zst
freebsd-ports-gnome-978fe64e3ce34312c604ffb3854cfa54c302d2e8.zip
Support building QT with debugging turned, keyed off the QT_DEBUG variable.
Approved by: MAINTAINER
Diffstat (limited to 'x11-toolkits/qt23')
-rw-r--r--x11-toolkits/qt23/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index 574991ffd7fc..8f2145bec63e 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -26,6 +26,11 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
-system-libmng -thread -no-opengl \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+.if defined(QT_DEBUG)
+CONFIGURE_ARGS+= -debug
+.endif
+
CONFIGURE_ENV= ${ECHO} yes | QTDIR=${WRKSRC}
.if defined(MAKE_JOBS)
MAKE_ARGS+= MAKE="${GMAKE} -j${MAKE_JOBS}"