aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qt33
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-05-03 02:03:59 +0800
committerlofi <lofi@FreeBSD.org>2004-05-03 02:03:59 +0800
commit228b7064bf827f11dd3c34404342f1b71574c81f (patch)
treeae5f557d01b6d10a71024e7bf47607afdb3c412b /x11-toolkits/qt33
parent0b412f76a6a3f854f887b85a16ef70576adeffe7 (diff)
downloadfreebsd-ports-gnome-228b7064bf827f11dd3c34404342f1b71574c81f.tar.gz
freebsd-ports-gnome-228b7064bf827f11dd3c34404342f1b71574c81f.tar.zst
freebsd-ports-gnome-228b7064bf827f11dd3c34404342f1b71574c81f.zip
Convert build switches to OPTIONS.
Diffstat (limited to 'x11-toolkits/qt33')
-rw-r--r--x11-toolkits/qt33/Makefile32
1 files changed, 10 insertions, 22 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index 990e779b8508..786d8e796c1d 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -57,6 +57,11 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
--exclude '${DISTNAME}/include/jri*' \
--exclude '${DISTNAME}/include/np*'
+OPTIONS= CUPS "Enable CUPS support" on \
+ NAS "Enable NAS support" on \
+ OPENGL "Enable OpenGL support" on \
+ XFT "Enable Xft support" on
+
.include <bsd.port.pre.mk>
# The previous Qt port versions installed qmake and qmake's specs under X11BASE
@@ -77,7 +82,7 @@ CONFIGURE_ARGS+=-platform ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
.if !defined(WITHOUT_XFT)
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
-.else
+.elseif defined(WITHOUT_XFT)
CONFIGURE_ARGS+=-no-xft
.endif
@@ -87,39 +92,22 @@ CONFIGURE_ARGS+=-debug
.if !defined(WITHOUT_OPENGL)
USE_GL= yes
-.else
+.elseif defined(WITHOUT_OPENGL)
CONFIGURE_ARGS+=-disable-opengl
.endif # WITHOUT_OPENGL
.if !defined(WITHOUT_CUPS)
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
CUPS= -cups -L${LOCALBASE}/lib -I${LOCALBASE}/include
-.else
+.elseif defined(WITHOUT_CUPS)
CUPS=
.endif
.if !defined(WITHOUT_NAS)
LIB_DEPENDS+= audio:${PORTSDIR}/audio/nas
CONFIGURE_ARGS+=-system-nas-sound
-
-.if ${MACHINE_ARCH} == "alpha"
-CFLAGS+= -O0
-.endif
-
-.if !defined(WITHOUT_XFT)
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} '===> **************************************************'
- @${ECHO_MSG} '===> If you do not want to build QT with XFT support '
- @${ECHO_MSG} '===> press Ctrl-C and set WITHOUT_XFT'
- @${ECHO_MSG} '===> **************************************************'
-.endif
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} '===> **************************************************'
- @${ECHO_MSG} '===> If you do not want to build QT with NAS support '
- @${ECHO_MSG} '===> press Ctrl-C and set WITHOUT_NAS'
- @${ECHO_MSG} '===> **************************************************'
+.elseif defined(WITHOUT_NAS)
+CONFIGURE_ARGS+=-no-nas-sound
.endif
.if ${XFREE86_VERSION} < 4