aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qt4-gui/Makefile
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-04-20 01:08:04 +0800
committerlofi <lofi@FreeBSD.org>2007-04-20 01:08:04 +0800
commit43404bb558fdbf21dfea86b33ff69de82991385e (patch)
tree7a31726ac01ff730b15d92e60de131efbdf5a4c4 /x11-toolkits/qt4-gui/Makefile
parent18159a3ac1812e45272d9372ab81e073abaedba1 (diff)
downloadfreebsd-ports-gnome-43404bb558fdbf21dfea86b33ff69de82991385e.tar.gz
freebsd-ports-gnome-43404bb558fdbf21dfea86b33ff69de82991385e.tar.zst
freebsd-ports-gnome-43404bb558fdbf21dfea86b33ff69de82991385e.zip
Rename all binaries in qt4 which conflict with binaries installed by
qt33 to ($binary)-qt4 and adjust dependencies accordingly. This avoids conflicts once X11BASE has been changed to /usr/local and incidentally makes the naming scheme of the qt4 executables in ports equal to that of the Fedora Core and Debian packages.
Diffstat (limited to 'x11-toolkits/qt4-gui/Makefile')
-rw-r--r--x11-toolkits/qt4-gui/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11-toolkits/qt4-gui/Makefile b/x11-toolkits/qt4-gui/Makefile
index 5c8d52891e6e..879f7b14e335 100644
--- a/x11-toolkits/qt4-gui/Makefile
+++ b/x11-toolkits/qt4-gui/Makefile
@@ -18,10 +18,10 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
COMMENT?= Qt graphical user interface library
-BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
qmake-qt4:${PORTSDIR}/devel/qmake4 \
rcc:${PORTSDIR}/devel/qt4-rcc \
- uic4:${PORTSDIR}/devel/qt4-uic
+ uic-qt4:${PORTSDIR}/devel/qt4-uic
LIB_DEPENDS?= QtCore:${PORTSDIR}/devel/qt4-corelib \
png:${PORTSDIR}/graphics/png
@@ -88,9 +88,9 @@ pre-configure:
${WRKSRC}/../plugins/imageformats/jpeg/jpeg.pro
${MKDIR} ${WRKSRC}/../../mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../bin/rcc
- ${LN} -sf ${LOCALBASE}/bin/uic4 ${WRKSRC}/../../bin/uic
+ ${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/../../bin/uic
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtGui.pc|${PREFIX}/libdata/pkgconfig/QtGui.pc|g' \