aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qt4-gui/Makefile
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-08-03 06:37:40 +0800
committerlofi <lofi@FreeBSD.org>2007-08-03 06:37:40 +0800
commit92df36cb4f060e53f821e67dff720610621261e0 (patch)
treec51388c2c26e8fc4241309ebb4a13b91e275da69 /x11-toolkits/qt4-gui/Makefile
parentf7bec0a60889d39376e4a9a13050951960059bb2 (diff)
downloadfreebsd-ports-gnome-92df36cb4f060e53f821e67dff720610621261e0.tar.gz
freebsd-ports-gnome-92df36cb4f060e53f821e67dff720610621261e0.tar.zst
freebsd-ports-gnome-92df36cb4f060e53f821e67dff720610621261e0.zip
- bsd.qt.mk:
QT_COMPONENTS can now be depended on at runtime or buildtime only by specifiying them as <component>_build or <component>_run, respectively. Specifying <component> without any suffix will depend on the component at both build- and runtime just like before. - Convert Qt core ports to use the new dependency switches. - Add a patch to corelib to fix Qt4 on ARM, submitted by: Björn König <bkoenig@alpha-tierchen.de>
Diffstat (limited to 'x11-toolkits/qt4-gui/Makefile')
-rw-r--r--x11-toolkits/qt4-gui/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/qt4-gui/Makefile b/x11-toolkits/qt4-gui/Makefile
index 9433e4b16a3e..6fabcecb590a 100644
--- a/x11-toolkits/qt4-gui/Makefile
+++ b/x11-toolkits/qt4-gui/Makefile
@@ -21,7 +21,7 @@ COMMENT= Qt graphical user interface library
LIB_DEPENDS?= png:${PORTSDIR}/graphics/png
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc rcc uic corelib
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build corelib
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -84,7 +84,7 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- -e 's|.*$$(QMAKE).*||g' -e 's|(test -z.*||g' ${WRKSRC}/Makefile
+ -e 's|.*$$(QMAKE).*||g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \