aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/tk83
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-05-10 00:39:18 +0800
committerdinoex <dinoex@FreeBSD.org>2002-05-10 00:39:18 +0800
commit46b3773ca4d1e14f35d20271fe30d080a56b89d0 (patch)
tree644649813f75bb6ebe2b1f3d1642de36a410f8e6 /x11-toolkits/tk83
parent2ae18f01867b47337b0694d27b68394624a00a31 (diff)
downloadfreebsd-ports-gnome-46b3773ca4d1e14f35d20271fe30d080a56b89d0.tar.gz
freebsd-ports-gnome-46b3773ca4d1e14f35d20271fe30d080a56b89d0.tar.zst
freebsd-ports-gnome-46b3773ca4d1e14f35d20271fe30d080a56b89d0.zip
- Set soname for libtk84.so
- Add pkgIndex.tcl submitted by doconnor@gsoft.com.au so "package require Tk" is now supported. - Add pkgIndex.tcl for tk83 and tk84
Diffstat (limited to 'x11-toolkits/tk83')
-rw-r--r--x11-toolkits/tk83/Makefile14
-rw-r--r--x11-toolkits/tk83/files/pkgIndex.tcl3
-rw-r--r--x11-toolkits/tk83/pkg-plist1
3 files changed, 12 insertions, 6 deletions
diff --git a/x11-toolkits/tk83/Makefile b/x11-toolkits/tk83/Makefile
index 15d926b2325f..3b406ca21a98 100644
--- a/x11-toolkits/tk83/Makefile
+++ b/x11-toolkits/tk83/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tk
PORTVERSION= 8.3.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits tk83
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcl
@@ -22,14 +22,15 @@ USE_XLIB= yes
INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}/unix
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared --with-tcl=${PREFIX}/lib/tcl8.3
-CONFIGURE_ENV= PORTSDIR=${PORTSDIR} TK_LIB_FILE=libtk83.so.1
-MAKE_ENV= SHORT_TK_VER=83
+TK_VER= 8.3
+SHORT_TK_VER= 83
+CONFIGURE_ARGS= --enable-shared --with-tcl=${PREFIX}/lib/tcl${TK_VER}
+CONFIGURE_ENV= PORTSDIR=${PORTSDIR} TK_LIB_FILE=libtk${SHORT_TK_VER}.so.1
+MAKE_ENV= SHORT_TK_VER=${SHORT_TK_VER}
+PLIST_SUB= TK_VER=${TK_VER} SHORT_TK_VER=${SHORT_TK_VER}
PKGINSTALL= ${PKGDIR}/pkg-install.wish
PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.wish
-PLIST_SUB= TK_VER=8.3 SHORT_TK_VER=83
-
MANCOMPRESSED= no
MAN1= wish.1
@@ -317,6 +318,7 @@ MLINKS= 3DBorder.3 Tk_Alloc3DBorderFromObj.3 \
.include <bsd.port.pre.mk>
post-install:
+ ${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/tk${TK_VER}/
.if exists(${PKGINSTALL})
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL}
.endif
diff --git a/x11-toolkits/tk83/files/pkgIndex.tcl b/x11-toolkits/tk83/files/pkgIndex.tcl
new file mode 100644
index 000000000000..47743949502f
--- /dev/null
+++ b/x11-toolkits/tk83/files/pkgIndex.tcl
@@ -0,0 +1,3 @@
+# Tcl package index file, version 1.0
+
+package ifneeded Tk 8.3 [list load "[file join [file dirname $dir] libtk83.so.1]" Tk]
diff --git a/x11-toolkits/tk83/pkg-plist b/x11-toolkits/tk83/pkg-plist
index 26b2783a4011..185cf4c99734 100644
--- a/x11-toolkits/tk83/pkg-plist
+++ b/x11-toolkits/tk83/pkg-plist
@@ -120,6 +120,7 @@ lib/tk%%TK_VER%%/msgbox.tcl
lib/tk%%TK_VER%%/obsolete.tcl
lib/tk%%TK_VER%%/optMenu.tcl
lib/tk%%TK_VER%%/palette.tcl
+lib/tk%%TK_VER%%/pkgIndex.tcl
lib/tk%%TK_VER%%/prolog.ps
lib/tk%%TK_VER%%/safetk.tcl
lib/tk%%TK_VER%%/scale.tcl