aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/unique
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-01-22 02:14:00 +0800
committerkwm <kwm@FreeBSD.org>2013-01-22 02:14:00 +0800
commit7e9838c0287d618dd5b9a25bba15132a3bccc444 (patch)
treed6bf59fbe1de9429ad826a24db6c51a7b4514f07 /x11-toolkits/unique
parentd061e94408f78bca5f2962f1df1268c31a650a82 (diff)
downloadfreebsd-ports-gnome-7e9838c0287d618dd5b9a25bba15132a3bccc444.tar.gz
freebsd-ports-gnome-7e9838c0287d618dd5b9a25bba15132a3bccc444.tar.zst
freebsd-ports-gnome-7e9838c0287d618dd5b9a25bba15132a3bccc444.zip
Fix the build with new glib.
While here trim Makefile header, remove shlib version in LIB_DEPENDS and register conflict in nautilus. Obtained from: gnome staging area.
Diffstat (limited to 'x11-toolkits/unique')
-rw-r--r--x11-toolkits/unique/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/x11-toolkits/unique/Makefile b/x11-toolkits/unique/Makefile
index 6ccefdb77ba2..0265c5227ff0 100644
--- a/x11-toolkits/unique/Makefile
+++ b/x11-toolkits/unique/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: libunique
-# Date created: 22 Feb 2009
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/x11-toolkits/unique/Makefile,v 1.9 2010/06/29 21:14:06 kwm Exp $
-#
+# $MCom: ports/x11-toolkits/unique/Makefile,v 1.12 2012/09/03 16:28:30 mezz Exp $
PORTNAME= unique
PORTVERSION= 1.1.6
@@ -16,7 +12,7 @@ DISTNAME= lib${PORTNAME}-${PORTVERSION}
MAINTAINER= kwm@FreeBSD.org
COMMENT= Library for single instance applications
-LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
+LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
USE_XORG= ice
USE_BZIP2= yes
@@ -33,5 +29,10 @@ LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|g' \
${WRKSRC}/configure ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|G_CONST_RETURN|const|g' \
+ ${WRKSRC}/unique/uniqueapp.c \
+ ${WRKSRC}/unique/uniquebackend.[ch] \
+ ${WRKSRC}/unique/uniqueinternals.h \
+ ${WRKSRC}/unique/uniquemessage.[ch]
.include <bsd.port.mk>