aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/wxgtk24/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-06-27 03:33:20 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-06-27 03:33:20 +0800
commited6a4db22ea5f62964b9493c98399f2c841b1163 (patch)
treea606468dc5fffd9ab355f9463e64c1afd05b9bf1 /x11-toolkits/wxgtk24/Makefile
parent44e8898a7a8187b5c9cfad047da4a9a2ddf79ad3 (diff)
downloadfreebsd-ports-gnome-ed6a4db22ea5f62964b9493c98399f2c841b1163.tar.gz
freebsd-ports-gnome-ed6a4db22ea5f62964b9493c98399f2c841b1163.tar.zst
freebsd-ports-gnome-ed6a4db22ea5f62964b9493c98399f2c841b1163.zip
wxWindows (wxGTK). A cross-platform C++ GUI toolkit.
PR: 12298 Submitted by: Alexander Langer <alex@cichlids.com>
Diffstat (limited to 'x11-toolkits/wxgtk24/Makefile')
-rw-r--r--x11-toolkits/wxgtk24/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-toolkits/wxgtk24/Makefile b/x11-toolkits/wxgtk24/Makefile
new file mode 100644
index 000000000000..cc74822defcb
--- /dev/null
+++ b/x11-toolkits/wxgtk24/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: wxGTK
+# Version required: 2.0.2
+# Date created: 18 Jun 1999
+# Whom: Alexander Langer <alex@cichlids.com>
+#
+# $Id$
+#
+
+DISTNAME= wxGTK-2.0.1
+PKGNAME= wxgtk-2.0.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= alex@cichlids.com
+
+LIB_DEPENDS= gtk10:${PORTSDIR}/x11-toolkits/gtk10:install
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= OSTYPE="${OPSYS}"
+USE_GMAKE= yes
+MAKE_ENV= OSTYPE="${OPSYS}"
+
+WRKSRC= ${WRKDIR}/wxGTK
+
+post-install:
+# There are two empty directories that make problems
+# while deinstalling if installed as a .tgz-package.
+ ${TOUCH} ${PREFIX}/include/wx/motif/.placeholder
+ ${TOUCH} ${PREFIX}/include/wx/common/.placeholder
+
+.include <bsd.port.mk>