aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-06-20 23:23:57 +0800
committergahr <gahr@FreeBSD.org>2012-06-20 23:23:57 +0800
commit018b3aaa76ca81f9c6ed898cb774f5ef93657402 (patch)
treee65c6c216ccc5ce9996bbbca0b82b36f628839b0 /x11-toolkits
parent6d3de5eebff9409ef8cf449da5cb5e13133eaf50 (diff)
downloadfreebsd-ports-gnome-018b3aaa76ca81f9c6ed898cb774f5ef93657402.tar.gz
freebsd-ports-gnome-018b3aaa76ca81f9c6ed898cb774f5ef93657402.tar.zst
freebsd-ports-gnome-018b3aaa76ca81f9c6ed898cb774f5ef93657402.zip
- unbreak on amd64 <9 by depending on GCC 4.4+
- i386 remains broken, for now
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox17/Makefile12
-rw-r--r--x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp11
2 files changed, 16 insertions, 7 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 2674a9c6e64f..388daf1740aa 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= http://ftp.fox-toolkit.org/pub/ \
MAINTAINER= gahr@FreeBSD.org
COMMENT= Fast and extensive C++ GUI toolkit -- devel version
-LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
+LIB_DEPENDS= Xft:${PORTSDIR}/x11-fonts/libXft
CONFLICTS= fox-1.4.* fox-1.6.*
@@ -30,6 +30,7 @@ MAJORVER= ${PORTVERSION:R}
PLIST_SUB+= MAJORVER=${MAJORVER}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${MAJORVER}
+USE_GCC= 4.4+
USE_GL= glut
USE_GNOME= gnomehack
USE_LDCONFIG= yes
@@ -52,7 +53,7 @@ BROKEN= does not build
.if defined(WITHOUT_JPEG)
CONFIGURE_ARGS+=--disable-jpeg
.else
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
.endif
.if defined(WITHOUT_PNG)
@@ -64,18 +65,15 @@ LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
.if defined(WITHOUT_TIFF)
CONFIGURE_ARGS+=--disable-tiff
.else
-LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS+= tiff:${PORTSDIR}/graphics/tiff
.endif
.if defined(WITHOUT_WEBP)
CONFIGURE_ARGS+=--disable-webp
.else
-LIB_DEPENDS+= webp.2:${PORTSDIR}/graphics/webp
+LIB_DEPENDS+= webp:${PORTSDIR}/graphics/webp
.endif
-.if ${ARCH} == "amd64" && ${OSVERSION} < 900000
-BROKEN= does not build on amd64
-.endif
.if ${ARCH} == "powerpc"
BROKEN= Does not link on powerpc
.endif
diff --git a/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp b/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp
new file mode 100644
index 000000000000..9fd0773b7ec3
--- /dev/null
+++ b/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp
@@ -0,0 +1,11 @@
+--- lib/FXAtomic.cpp.orig 2012-04-27 18:46:09.000000000 +0200
++++ lib/FXAtomic.cpp 2012-06-20 10:39:15.000000000 +0200
+@@ -298,7 +298,7 @@
+ LONGLONG duet[2]={(LONGLONG)a,(LONGLONG)b};
+ return (_InterlockedCompareExchange128((LONGLONG volatile*)ptr,(LONGLONG)cmpb,(LONGLONG)cmpa,duet));
+ #elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__i386__))
+-#if (defined(__PIC__) || defined(__PIE__)
++#if defined(__PIC__) || defined(__PIE__)
+ register FXbool ret;
+ __asm__ __volatile__ ("xchgl %%esi, %%ebx\n\t"
+ "lock\n\t"