aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2015-03-01 06:47:16 +0800
committernivit <nivit@FreeBSD.org>2015-03-01 06:47:16 +0800
commit109384bdc3342ce233e317819b7a182e2bf50275 (patch)
tree27c4b5943c77c9a5e92f5d39bf7272683db2cd62 /x11-toolkits
parent9428606d4ac32fa42d86cc7f676fc8b214546e1e (diff)
downloadfreebsd-ports-gnome-109384bdc3342ce233e317819b7a182e2bf50275.tar.gz
freebsd-ports-gnome-109384bdc3342ce233e317819b7a182e2bf50275.tar.zst
freebsd-ports-gnome-109384bdc3342ce233e317819b7a182e2bf50275.zip
Perl bindings for the C library "libunique" that provides a mechanism for
writing single instance applications. If you launch a single instance application twice, the second instance will either just quit or will send a message to the running instance. Unique makes it easy to write this kind of applications, by providing a base class, taking care of all the IPC machinery needed to send messages to a running instance, and also handling the startup notification side. WWW: http://search.cpan.org/dist/Gtk2-Unique/
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/p5-Gtk2-Unique/Makefile29
-rw-r--r--x11-toolkits/p5-Gtk2-Unique/distinfo2
-rw-r--r--x11-toolkits/p5-Gtk2-Unique/pkg-descr10
-rw-r--r--x11-toolkits/p5-Gtk2-Unique/pkg-plist16
5 files changed, 58 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 992d7706afc8..bef3887eaf6b 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -143,6 +143,7 @@
SUBDIR += p5-Gtk2-ImageView
SUBDIR += p5-Gtk2-PathButtonBar
SUBDIR += p5-Gtk2-TrayIcon
+ SUBDIR += p5-Gtk2-Unique
SUBDIR += p5-Pango
SUBDIR += p5-Prima
SUBDIR += p5-Tk
diff --git a/x11-toolkits/p5-Gtk2-Unique/Makefile b/x11-toolkits/p5-Gtk2-Unique/Makefile
new file mode 100644
index 000000000000..526a07e6535e
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Unique/Makefile
@@ -0,0 +1,29 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Gtk2-Unique
+PORTVERSION= 0.05
+#PORTREVISION= 0
+CATEGORIES= x11-toolkits gnome perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Perl binding for the C library libunique
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-ExtUtils-Depends>=0:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ p5-ExtUtils-PkgConfig>=0:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
+ p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
+LIB_DEPENDS= libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
+RUN_DEPENDS= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
+
+MAKE_JOBS_UNSAFE= yes
+
+USES= perl5
+USE_GNOME= gconf2
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Gtk2-Unique/distinfo b/x11-toolkits/p5-Gtk2-Unique/distinfo
new file mode 100644
index 000000000000..33f0b92eafe3
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Unique/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Gtk2-Unique-0.05.tar.gz) = ae8dfb0f6844ddaa2ce7b5b44553419490c8e83c24fd35c431406a58f6be0f4f
+SIZE (Gtk2-Unique-0.05.tar.gz) = 11158
diff --git a/x11-toolkits/p5-Gtk2-Unique/pkg-descr b/x11-toolkits/p5-Gtk2-Unique/pkg-descr
new file mode 100644
index 000000000000..de4c7d3d6d6b
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Unique/pkg-descr
@@ -0,0 +1,10 @@
+Perl bindings for the C library "libunique" that provides a mechanism for
+writing single instance applications. If you launch a single instance
+application twice, the second instance will either just quit or will send a
+message to the running instance.
+
+Unique makes it easy to write this kind of applications, by providing a base
+class, taking care of all the IPC machinery needed to send messages to a running
+instance, and also handling the startup notification side.
+
+WWW: http://search.cpan.org/dist/Gtk2-Unique/
diff --git a/x11-toolkits/p5-Gtk2-Unique/pkg-plist b/x11-toolkits/p5-Gtk2-Unique/pkg-plist
new file mode 100644
index 000000000000..463000d02798
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Unique/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_ARCH%%/Gtk2/Unique.pm
+%%SITE_ARCH%%/Gtk2/Unique.pod
+%%SITE_ARCH%%/Gtk2/Unique/Install/Files.pm
+%%SITE_ARCH%%/Gtk2/Unique/Install/unique-autogen.h
+%%SITE_ARCH%%/Gtk2/Unique/Install/unique-perl.h
+%%SITE_ARCH%%/Gtk2/Unique/Install/unique.typemap
+%%SITE_ARCH%%/Gtk2/Unique/index.pod
+%%SITE_ARCH%%/Gtk2/UniqueApp.pod
+%%SITE_ARCH%%/Gtk2/UniqueBackend.pod
+%%SITE_ARCH%%/Gtk2/UniqueMessageData.pod
+%%SITE_ARCH%%/auto/Gtk2/Unique/Unique.so
+%%PERL5_MAN3%%/Gtk2::Unique.3.gz
+%%PERL5_MAN3%%/Gtk2::Unique::index.3.gz
+%%PERL5_MAN3%%/Gtk2::UniqueApp.3.gz
+%%PERL5_MAN3%%/Gtk2::UniqueBackend.3.gz
+%%PERL5_MAN3%%/Gtk2::UniqueMessageData.3.gz