aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-09-07 20:13:53 +0800
committerknu <knu@FreeBSD.org>2000-09-07 20:13:53 +0800
commit22026e5cada26e92bb1411fa85e68e2f5a0e8a41 (patch)
treeac7dc02f47b03b0b6b46ff56997403a5a8ca46df /x11-toolkits
parent892d48cf2a399aef38b34405d80eb0b59d7d32ae (diff)
downloadfreebsd-ports-gnome-22026e5cada26e92bb1411fa85e68e2f5a0e8a41.tar.gz
freebsd-ports-gnome-22026e5cada26e92bb1411fa85e68e2f5a0e8a41.tar.zst
freebsd-ports-gnome-22026e5cada26e92bb1411fa85e68e2f5a0e8a41.zip
Turn USE_GMAKE on, since our make(1) (sys.mk) doesn't use CPPFLAGS.
This is just a workaround and should soon be fixed by changing mkmf.rb.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/ruby-qt/Makefile2
-rw-r--r--x11-toolkits/ruby-qt2/Makefile2
2 files changed, 4 insertions, 0 deletions
diff --git a/x11-toolkits/ruby-qt/Makefile b/x11-toolkits/ruby-qt/Makefile
index da9d815fe021..10f74028a929 100644
--- a/x11-toolkits/ruby-qt/Makefile
+++ b/x11-toolkits/ruby-qt/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= ${QTLIB}.${QTLIB_SHLIBVER}:${PORTSDIR}/x11-toolkits/${QT_PORTNAME}
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+USE_GMAKE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-qt-include=${X11BASE}/include/X11/qt \
--with-qt-lib=${X11BASE}/lib
diff --git a/x11-toolkits/ruby-qt2/Makefile b/x11-toolkits/ruby-qt2/Makefile
index da9d815fe021..10f74028a929 100644
--- a/x11-toolkits/ruby-qt2/Makefile
+++ b/x11-toolkits/ruby-qt2/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= ${QTLIB}.${QTLIB_SHLIBVER}:${PORTSDIR}/x11-toolkits/${QT_PORTNAME}
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+USE_GMAKE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-qt-include=${X11BASE}/include/X11/qt \
--with-qt-lib=${X11BASE}/lib