aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-05-25 23:16:36 +0800
committerlofi <lofi@FreeBSD.org>2004-05-25 23:16:36 +0800
commit23778ab80c9a265e47c0ff7b337a650443edde7c (patch)
tree174e6a09161d95d4aecc88d8ccaa5fccef628d2b /x11-toolkits
parent7cf43bbefebe5e55d60a7b53c5bfe31da25089d9 (diff)
downloadfreebsd-ports-gnome-23778ab80c9a265e47c0ff7b337a650443edde7c.tar.gz
freebsd-ports-gnome-23778ab80c9a265e47c0ff7b337a650443edde7c.tar.zst
freebsd-ports-gnome-23778ab80c9a265e47c0ff7b337a650443edde7c.zip
Patch configure instead of piping echo output to the configure script -
the latter isn't make -s - safe. Noticed by: Jon Noack <noackjr@alumni.rice.edu>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt33/Makefile2
-rw-r--r--x11-toolkits/qt33/files/patch-configure13
2 files changed, 13 insertions, 2 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index ca86638795c4..7316713e3a0b 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+= -system-libpng -system-libjpeg -system-libmng \
-verbose -docdir ${DOCSDIR} -tablet -ipv6 \
-plugindir ${PREFIX}/lib/plugins
-CONFIGURE_ENV?= ${ECHO} yes | QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
MAKE_ENV?= QTDIR=${WRKSRC} \
LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
diff --git a/x11-toolkits/qt33/files/patch-configure b/x11-toolkits/qt33/files/patch-configure
index 75386f4b379c..8c5938d8db68 100644
--- a/x11-toolkits/qt33/files/patch-configure
+++ b/x11-toolkits/qt33/files/patch-configure
@@ -46,4 +46,15 @@
- QMAKE_VARS="$QMAKE_VARS \"QMAKE_CXXFLAGS+=$I_FLAGS\""
+ QMAKE_VARS="$QMAKE_VARS \"INCPATH+=`echo $I_FLAGS | sed s,-I,,g`\""
fi
-
+
+--- configure.orig Tue May 25 17:07:32 2004
++++ configure Tue May 25 17:12:24 2004
+@@ -2305,7 +2305,7 @@
+ else
+ echo "Do you accept the terms of $affix license? \c"
+ fi
+- read acceptance
++ acceptance=yes
+ echo
+ if [ "$acceptance" = "yes" ]; then
+ break