aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-15 06:31:38 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-15 06:31:38 +0800
commit385716ff901f6af51fb6b792fb6de88d7d7f67f2 (patch)
tree9ef70398ce703e7d1cc6d747a449a6194cce4796 /x11-toolkits
parent7167e0b735b7337e524d82ab289c180f28312d46 (diff)
downloadfreebsd-ports-gnome-385716ff901f6af51fb6b792fb6de88d7d7f67f2.tar.gz
freebsd-ports-gnome-385716ff901f6af51fb6b792fb6de88d7d7f67f2.tar.zst
freebsd-ports-gnome-385716ff901f6af51fb6b792fb6de88d7d7f67f2.zip
- Clarify LICENSE
- Add LICENSE_FILE - Switch to options helpers
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtkdatabox/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/x11-toolkits/gtkdatabox/Makefile b/x11-toolkits/gtkdatabox/Makefile
index c9674e62b17d..a90b77d1ebc6 100644
--- a/x11-toolkits/gtkdatabox/Makefile
+++ b/x11-toolkits/gtkdatabox/Makefile
@@ -11,11 +11,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+2 widget to display large amounts of numerical data
-LICENSE= LGPL21
-
-OPTIONS_DEFINE= GLADE GLADEUI DOCS EXAMPLES
-GLADE_DESC= Enable libglade2 support
-GLADEUI_DESC= Enable glade3 support
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= libtool pathfix pkgconfig
USE_GNOME= gtk20
@@ -25,14 +22,16 @@ CONFIGURE_ARGS= --includedir="${PREFIX}/include/${PORTNAME}" \
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-OPTIONS_SUB=yes
-
PORTDOCS= *
PORTEXAMPLES= *
+OPTIONS_DEFINE= GLADE GLADEUI DOCS EXAMPLES
+OPTIONS_SUB= yes
+
+GLADE_DESC= Enable libglade2 support
GLADE_USE= GNOME=libglade2
GLADE_CONFIGURE_ENABLE= libglade
-
+GLADEUI_DESC= Enable glade3 support
GLADEUI_LIB_DEPENDS= libgladeui-1.so:${PORTSDIR}/devel/glade3
GLADEUI_CONFIGURE_ENABLE= glade
@@ -45,9 +44,12 @@ post-patch:
/DISABLE_DEPRECATED/d' ${WRKSRC}/${dir}/Makefile.in
.endfor
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} api ${STAGEDIR}${DOCSDIR})
- (cd ${WRKSRC}/examples && ${INSTALL_DATA} *.c ${STAGEDIR}${EXAMPLESDIR})
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.c ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>