aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2004-07-24 03:10:32 +0800
committeranholt <anholt@FreeBSD.org>2004-07-24 03:10:32 +0800
commit3c76fd7fad82c9f137407348028fde08754f2866 (patch)
tree9818557f7ca7be09aba8db3b18a8262f50280603 /x11-toolkits
parenta861bc861bc7251a2f2399f845d673f742a19ee1 (diff)
downloadfreebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.tar.gz
freebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.tar.zst
freebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.zip
- Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,
and make XFREE86_VERSION map to it. XFREE86_VERSION is now deprecated. - Make xorg the default X_WINDOW_SYSTEM on -current. - Add several new X_*_PORT variables which point to various pieces of X11 based on the setting of X_WINDOW_SYSTEM, and make ports use them. - Add information to CHANGES about how to handle the transition. PR: ports/68763 Approved by: portmgr (marcus) Approved by: re (scottl)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox-devel/Makefile2
-rw-r--r--x11-toolkits/fox14/Makefile2
-rw-r--r--x11-toolkits/open-motif/Makefile6
-rw-r--r--x11-toolkits/pango/Makefile5
-rw-r--r--x11-toolkits/qt33/Makefile6
-rw-r--r--x11-toolkits/viewklass/Makefile12
6 files changed, 13 insertions, 20 deletions
diff --git a/x11-toolkits/fox-devel/Makefile b/x11-toolkits/fox-devel/Makefile
index 02450f49f112..109878013f44 100644
--- a/x11-toolkits/fox-devel/Makefile
+++ b/x11-toolkits/fox-devel/Makefile
@@ -48,7 +48,7 @@ LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
## Additional Options
##
#
-.if ${XFREE86_VERSION} < 4 || defined(WITHOUT_XFT)
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3 || defined(WITHOUT_XFT)
CONFIGURE_ARGS+= --with-xft=no
.else
CONFIGURE_ARGS+= --with-xft=yes
diff --git a/x11-toolkits/fox14/Makefile b/x11-toolkits/fox14/Makefile
index 02450f49f112..109878013f44 100644
--- a/x11-toolkits/fox14/Makefile
+++ b/x11-toolkits/fox14/Makefile
@@ -48,7 +48,7 @@ LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
## Additional Options
##
#
-.if ${XFREE86_VERSION} < 4 || defined(WITHOUT_XFT)
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3 || defined(WITHOUT_XFT)
CONFIGURE_ARGS+= --with-xft=no
.else
CONFIGURE_ARGS+= --with-xft=yes
diff --git a/x11-toolkits/open-motif/Makefile b/x11-toolkits/open-motif/Makefile
index e720a5c41e45..0d6af8f6995b 100644
--- a/x11-toolkits/open-motif/Makefile
+++ b/x11-toolkits/open-motif/Makefile
@@ -21,6 +21,8 @@ DIST_SUBDIR= openmotif
MAINTAINER= steve@FreeBSD.org
COMMENT= Motif X11 Toolkit (industry standard GUI (IEEE 1295))
+RUN_DEPENDS= imake:${X_IMAKE_PORT}
+
CONFLICTS= lesstif-*
USE_X_PREFIX= yes
USE_REINPLACE= yes
@@ -38,10 +40,6 @@ DEMOS_SRC= ${WRKSRC}/demos/programs
.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} >= 4
-RUN_DEPENDS= imake:${PORTSDIR}/devel/imake-4
-.endif
-
# User config option: Build and install Motif demos
.if defined(WITHOUT_OPENMOTIF_DEMOS)
PLIST_SUB+= MOTIF_DEMOS="@comment "
diff --git a/x11-toolkits/pango/Makefile b/x11-toolkits/pango/Makefile
index a2d15fd5fd21..ad7303313522 100644
--- a/x11-toolkits/pango/Makefile
+++ b/x11-toolkits/pango/Makefile
@@ -18,8 +18,8 @@ COMMENT= An open-source framework for the layout and rendering of i18n text
BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2
LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
-RUN_DEPENDS= ${FONTSCALE}:${PORTSDIR}/x11-fonts/XFree86-4-fontScalable \
- ${FONTENCOD}:${PORTSDIR}/x11-fonts/XFree86-4-fontEncodings
+RUN_DEPENDS= ${FONTSCALE}:${X_FONTS_TTF_PORT} \
+ ${FONTENCOD}:${X_FONTS_ENCODINGS_PORT}
USE_BZIP2= yes
USE_GETTEXT= yes
@@ -61,3 +61,4 @@ post-install:
.endif
.include <bsd.port.mk>
+
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index df84d74231ca..487c482138bd 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -115,9 +115,9 @@ CONFIGURE_ARGS+=-system-nas-sound
CONFIGURE_ARGS+=-no-nas-sound
.endif
-.if ${XFREE86_VERSION} < 4
-BROKEN= "The QT ${PORTVERSION} port does not support any XFree86 < 4.x"
-.endif # ${XFREE86_VERSION} < 4
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+IGNORE= "The QT ${PORTVERSION} port does not support any XFree86 < 4.x"
+.endif
.if exists(${X11BASE}/include/qt2/qapp.h)
BROKEN= "You have QT2 headers installed! Installing this port"
diff --git a/x11-toolkits/viewklass/Makefile b/x11-toolkits/viewklass/Makefile
index 4880e6ad8089..d752df59b846 100644
--- a/x11-toolkits/viewklass/Makefile
+++ b/x11-toolkits/viewklass/Makefile
@@ -16,22 +16,16 @@ DISTNAME= ViewKlass-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ Framework for Motif
+BUILD_DEPENDS= xmkmf:${X_IMAKE_PORT}
+
USE_X_PREFIX= yes
USE_MOTIF= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${XFREE86_VERSION} == 3
-BUILD_DEPENDS+= xmkmf:${PORTSDIR}/devel/imake
-.else
-BUILD_DEPENDS+= xmkmf:${PORTSDIR}/devel/imake-4
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's/^CFLAGS=/CFLAGS+=/g ; \
s/^CXXFLAGS=/CXXFLAGS+=/g ; \
s/-g -Wall//g' ${WRKSRC}/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>