aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2011-09-04 00:23:17 +0800
committerdinoex <dinoex@FreeBSD.org>2011-09-04 00:23:17 +0800
commit4ab60887910c2d60b787fe60c146760ff3ac007d (patch)
tree3d4f972b0f7bcd6b027db6363a4fbf37d66647bf /x11-toolkits
parent948c70d2df4f5acd2ea19fd70d73456e694998bf (diff)
downloadfreebsd-ports-gnome-4ab60887910c2d60b787fe60c146760ff3ac007d.tar.gz
freebsd-ports-gnome-4ab60887910c2d60b787fe60c146760ff3ac007d.tar.zst
freebsd-ports-gnome-4ab60887910c2d60b787fe60c146760ff3ac007d.zip
- Security fix for reading GIF images
Security: CVE-2007-5137
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/tk82/Makefile2
-rw-r--r--x11-toolkits/tk82/files/patch-tkImgGIF.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11-toolkits/tk82/Makefile b/x11-toolkits/tk82/Makefile
index 705ca7c12e02..22f33d30cc8f 100644
--- a/x11-toolkits/tk82/Makefile
+++ b/x11-toolkits/tk82/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tk
PORTVERSION= 8.2.3
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= x11-toolkits tk
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= tcl8_2
diff --git a/x11-toolkits/tk82/files/patch-tkImgGIF.c b/x11-toolkits/tk82/files/patch-tkImgGIF.c
new file mode 100644
index 000000000000..6538db708959
--- /dev/null
+++ b/x11-toolkits/tk82/files/patch-tkImgGIF.c
@@ -0,0 +1,11 @@
+--- ../generic/tkImgGIF.c.orig 1999-07-01 02:39:44.000000000 +0200
++++ ../generic/tkImgGIF.c 2011-09-03 18:20:45.000000000 +0200
+@@ -666,7 +666,7 @@
+ ypos += 2; break;
+ }
+
+- while (ypos >= height) {
++ while (ypos >= rows) {
+ ++pass;
+ switch (pass) {
+ case 1: