aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-10-28 21:01:30 +0800
committerlinimon <linimon@FreeBSD.org>2018-10-28 21:01:30 +0800
commit562605d5ff89ffffbf3bd7a6dc883014ab7479d7 (patch)
tree6151d12eb69f8dff205654e6751e961699a50f92 /x11-toolkits
parent683b98fbf75e108d023741bf0ab692b0018615a0 (diff)
downloadfreebsd-ports-gnome-562605d5ff89ffffbf3bd7a6dc883014ab7479d7.tar.gz
freebsd-ports-gnome-562605d5ff89ffffbf3bd7a6dc883014ab7479d7.tar.zst
freebsd-ports-gnome-562605d5ff89ffffbf3bd7a6dc883014ab7479d7.zip
Fix build with GCC-based architectures.
PR: 232400 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qwt6/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/qwt6/Makefile b/x11-toolkits/qwt6/Makefile
index 701a838ac5f6..2e21f7a6eda0 100644
--- a/x11-toolkits/qwt6/Makefile
+++ b/x11-toolkits/qwt6/Makefile
@@ -13,7 +13,7 @@ COMMENT= Qt Widgets for Technical Applications
FLAVORS= qt4 qt5
FLAVOR?= ${FLAVORS:[1]}
-USES= gmake qmake tar:bzip2
+USES= gl gmake qmake tar:bzip2
USE_GL= gl
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
@@ -28,7 +28,7 @@ QMAKE_ARGS+= PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
USES+= qt:4
USE_QT= corelib designer gui opengl svg xml moc_build rcc_build script
.else
-USES+= qt:5
+USES+= compiler:c++11-lang qt:5
USE_QT= buildtools_build widgets gui core designer gui opengl svg xml printsupport concurrent
.endif