aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2019-10-06 12:24:49 +0800
committerjbeich <jbeich@FreeBSD.org>2019-10-06 12:24:49 +0800
commit764ffed6f153661a76a5b54d4b5cb7610d3fb5e2 (patch)
tree6ee25768eec3174f9e701c5e5fdf222bfe774d47 /x11-toolkits
parent1b01478db10ab039f1458a9ef1b4de0604308d30 (diff)
downloadfreebsd-ports-gnome-764ffed6f153661a76a5b54d4b5cb7610d3fb5e2.tar.gz
freebsd-ports-gnome-764ffed6f153661a76a5b54d4b5cb7610d3fb5e2.tar.zst
freebsd-ports-gnome-764ffed6f153661a76a5b54d4b5cb7610d3fb5e2.zip
x11-toolkits/gtk-layer-shell: add new port
PR: 241076 Submitted by: Greg V <greg@unrelenting.technology> A library to write GTK applications that use Layer Shell. Layer Shell is a Wayland protocol for desktop shell components, such as panels, notifications and wallpapers. You can use it to anchor your windows to a corner or edge of the output, or stretch them across the entire output. This library only makes sense on Wayland compositors that support Layer Shell, and will not work on X11. It supports all Layer Shell features including popups and popovers (GTK popups Just Work). https://github.com/wmww/gtk-layer-shell
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/gtk-layer-shell/Makefile29
-rw-r--r--x11-toolkits/gtk-layer-shell/distinfo3
-rw-r--r--x11-toolkits/gtk-layer-shell/pkg-descr10
-rw-r--r--x11-toolkits/gtk-layer-shell/pkg-plist22
5 files changed, 65 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index a69c33fecd6b..68e8f4eb58b5 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -32,6 +32,7 @@
SUBDIR += gstreamer-plugins-pango
SUBDIR += gstreamer1-plugins-gtk
SUBDIR += gstreamer1-plugins-pango
+ SUBDIR += gtk-layer-shell
SUBDIR += gtk-sharp-beans
SUBDIR += gtk-sharp20
SUBDIR += gtk-sharp30
diff --git a/x11-toolkits/gtk-layer-shell/Makefile b/x11-toolkits/gtk-layer-shell/Makefile
new file mode 100644
index 000000000000..e45de198784c
--- /dev/null
+++ b/x11-toolkits/gtk-layer-shell/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= gtk-layer-shell
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.0
+CATEGORIES= x11-toolkits
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= GTK+ library for the Wayland layer-shell protocol
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= compiler:c11 gnome meson pkgconfig
+USE_GNOME= gtk30 introspection:build
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= wmww
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+DOCS_BUILD_DEPENDS= gtk-doc>0:textproc/gtk-doc
+DOCS_MESON_TRUE= docs
+
+EXAMPLES_MESON_TRUE= examples
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk-layer-shell/distinfo b/x11-toolkits/gtk-layer-shell/distinfo
new file mode 100644
index 000000000000..93aaeb712e31
--- /dev/null
+++ b/x11-toolkits/gtk-layer-shell/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568467979
+SHA256 (wmww-gtk-layer-shell-v0.1.0_GH0.tar.gz) = f7569e27ae30b1a94c3ad6c955cf56240d6bc272b760d9d266ce2ccdb94a5cf0
+SIZE (wmww-gtk-layer-shell-v0.1.0_GH0.tar.gz) = 41457
diff --git a/x11-toolkits/gtk-layer-shell/pkg-descr b/x11-toolkits/gtk-layer-shell/pkg-descr
new file mode 100644
index 000000000000..4ed12e14aab2
--- /dev/null
+++ b/x11-toolkits/gtk-layer-shell/pkg-descr
@@ -0,0 +1,10 @@
+A library to write GTK applications that use Layer Shell.
+
+Layer Shell is a Wayland protocol for desktop shell components, such as panels,
+notifications and wallpapers. You can use it to anchor your windows to a corner
+or edge of the output, or stretch them across the entire output.
+This library only makes sense on Wayland compositors that support Layer Shell,
+and will not work on X11. It supports all Layer Shell features including
+popups and popovers (GTK popups Just Work).
+
+WWW: https://github.com/wmww/gtk-layer-shell
diff --git a/x11-toolkits/gtk-layer-shell/pkg-plist b/x11-toolkits/gtk-layer-shell/pkg-plist
new file mode 100644
index 000000000000..b7a1acab2f70
--- /dev/null
+++ b/x11-toolkits/gtk-layer-shell/pkg-plist
@@ -0,0 +1,22 @@
+%%PORTEXAMPLES%%bin/gtk-layer-demo
+include/gtk-layer-shell/gtk-layer-shell.h
+lib/girepository-1.0/GtkLayerShell-0.1.typelib
+lib/libgtk-layer-shell.so
+lib/libgtk-layer-shell.so.0
+lib/libgtk-layer-shell.so.0.1.0
+libdata/pkgconfig/gtk-layer-shell-0.pc
+share/gir-1.0/GtkLayerShell-0.1.gir
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/api-index-full.html
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/deprecated-api-index.html
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/gtk-layer-shell-Gtk-Layer-Shell.html
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/gtk-layer-shell.devhelp2
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/gtk-layer-shell.html
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/home.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/index.html
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/left-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/left.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/right-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/right.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/style.css
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/up-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/up.png