aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-08-01 10:06:55 +0800
committerjylefort <jylefort@FreeBSD.org>2005-08-01 10:06:55 +0800
commit852dff1eac562db80f0f908b5cf9d1b9a2fd44ae (patch)
tree920ee9f9447abc0327d645f45f757c3a4dd6c828 /x11-toolkits
parentf7a47cc86bc5e46902e58e053f3f5bfbaaaacfea (diff)
downloadfreebsd-ports-gnome-852dff1eac562db80f0f908b5cf9d1b9a2fd44ae.tar.gz
freebsd-ports-gnome-852dff1eac562db80f0f908b5cf9d1b9a2fd44ae.tar.zst
freebsd-ports-gnome-852dff1eac562db80f0f908b5cf9d1b9a2fd44ae.zip
Fix yet another thread-safety bug:
http://bugzilla.gnome.org/show_bug.cgi?id=312180
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/libgnomeui/Makefile1
-rw-r--r--x11-toolkits/libgnomeui/files/patch-libgnomeui_gnome-authentication-manager.c30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-toolkits/libgnomeui/Makefile b/x11-toolkits/libgnomeui/Makefile
index 3794996458ae..89ecfea12e81 100644
--- a/x11-toolkits/libgnomeui/Makefile
+++ b/x11-toolkits/libgnomeui/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libgnomeui
PORTVERSION= 2.10.1
+PORTREVISION= 1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
diff --git a/x11-toolkits/libgnomeui/files/patch-libgnomeui_gnome-authentication-manager.c b/x11-toolkits/libgnomeui/files/patch-libgnomeui_gnome-authentication-manager.c
new file mode 100644
index 000000000000..99990e1b9f63
--- /dev/null
+++ b/x11-toolkits/libgnomeui/files/patch-libgnomeui_gnome-authentication-manager.c
@@ -0,0 +1,30 @@
+--- libgnomeui/gnome-authentication-manager.c.orig Mon Aug 1 03:34:03 2005
++++ libgnomeui/gnome-authentication-manager.c Mon Aug 1 03:36:29 2005
+@@ -849,7 +849,11 @@
+ info->response = response;
+ info->response_data = response_data;
+
++ GDK_THREADS_ENTER ();
++
+ present_question_dialog_nonblocking (info);
++
++ GDK_THREADS_LEAVE ();
+ }
+
+ static void /* GnomeVFSModuleCallback */
+@@ -870,11 +874,15 @@
+ in_real = (GnomeVFSModuleCallbackQuestionIn *)in;
+ out_real = (GnomeVFSModuleCallbackQuestionOut *)out;
+
++ GDK_THREADS_ENTER ();
++
+ out_real->answer = -1; /* Set a default value */
+ dialog = create_question_dialog (in_real->primary_message, in_real->secondary_message, in_real->choices);
+ out_real->answer = gtk_dialog_run (GTK_DIALOG(dialog));
+
+ gtk_widget_destroy (GTK_WIDGET (dialog));
++
++ GDK_THREADS_LEAVE ();
+ }
+
+