aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2004-03-25 16:06:19 +0800
committerdemon <demon@FreeBSD.org>2004-03-25 16:06:19 +0800
commit8667fdfcd6e77a1d05c52ee56c348be690b52f30 (patch)
treea9250ee0435d8faf2f6ca12327dc71224078cc63 /x11-toolkits
parent6b4830812f6ff10418a4857ee7285fd893018d55 (diff)
downloadfreebsd-ports-gnome-8667fdfcd6e77a1d05c52ee56c348be690b52f30.tar.gz
freebsd-ports-gnome-8667fdfcd6e77a1d05c52ee56c348be690b52f30.tar.zst
freebsd-ports-gnome-8667fdfcd6e77a1d05c52ee56c348be690b52f30.zip
Link with pthreads only when WITH_THREADS is defined.
Enable antialiased text. Submitted by: Dan Nelson <dnelson@allantgroup.com>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fltk/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index 782f75ec9785..d6c2f231c63d 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -20,7 +20,8 @@ MAINTAINER?= demon@FreeBSD.org
COMMENT?= C++ graphical user interface for X
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ Xft.2:${PORTSDIR}/x11-fonts/libXft
.if defined(WITH_XUNICODE)
PATCH_VERSION= 20010114
@@ -42,15 +43,17 @@ _PORTVERSION+= ${VERSION}
.if defined(WITH_THREADS)
CONFIGURE_ARGS+=--enable-threads
+CPPFLAGS+= "${PTHREAD_CFLAGS}"
+LDFLAGS+= "${PTHREAD_LIBS}"
.endif
VERSION= 1.1.4
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-shared
-CONFIGURE_ENV+= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=--enable-shared --enable-xft
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/${PORTNAME}-${VERSION}
USE_X_PREFIX= yes
USE_MESA= yes