aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-09-13 06:48:25 +0800
committerade <ade@FreeBSD.org>2000-09-13 06:48:25 +0800
commit9d5f7231924910135ecacbbd8ab58b17eedf35a6 (patch)
tree806653c4392dd3861480d67915985e78d3bc001d /x11-toolkits
parent10f02a4e867385af27cc13b689c3a107eb3d2326 (diff)
downloadfreebsd-ports-gnome-9d5f7231924910135ecacbbd8ab58b17eedf35a6.tar.gz
freebsd-ports-gnome-9d5f7231924910135ecacbbd8ab58b17eedf35a6.tar.zst
freebsd-ports-gnome-9d5f7231924910135ecacbbd8ab58b17eedf35a6.zip
Bakery is another C++ Framework for creating GNOME applications
using Gtk-- and Gnome--
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/bakery/Makefile42
-rw-r--r--x11-toolkits/bakery/distinfo1
-rw-r--r--x11-toolkits/bakery/files/patch-aa7
-rw-r--r--x11-toolkits/bakery/pkg-comment1
-rw-r--r--x11-toolkits/bakery/pkg-descr11
-rw-r--r--x11-toolkits/bakery/pkg-plist16
7 files changed, 79 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index a90fda9887cf..c8207d8c3fda 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -4,6 +4,7 @@
SUBDIR += FWF
SUBDIR += Motif-dummy
SUBDIR += Xaw3d
+ SUBDIR += bakery
SUBDIR += blt
SUBDIR += buffy
SUBDIR += clean-theme-gtk
diff --git a/x11-toolkits/bakery/Makefile b/x11-toolkits/bakery/Makefile
new file mode 100644
index 000000000000..f62ff9698646
--- /dev/null
+++ b/x11-toolkits/bakery/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: bakery
+# Date created: 12th September 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bakery
+PORTVERSION= 0.3.0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gtkmm-1.2.1:${PORTSDIR}/x11-toolkits/gtk-- \
+ gnomemm-1.1.3:${PORTSDIR}/x11-toolkits/gnome--
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_X_PREFIX= yes
+USE_PERL5= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/bakery/distinfo b/x11-toolkits/bakery/distinfo
new file mode 100644
index 000000000000..c233c441fcf9
--- /dev/null
+++ b/x11-toolkits/bakery/distinfo
@@ -0,0 +1 @@
+MD5 (bakery-0.3.0.tar.gz) = 12d158cdc86bbdabb1a29107f007766a
diff --git a/x11-toolkits/bakery/files/patch-aa b/x11-toolkits/bakery/files/patch-aa
new file mode 100644
index 000000000000..0eef2b849092
--- /dev/null
+++ b/x11-toolkits/bakery/files/patch-aa
@@ -0,0 +1,7 @@
+--- Makefile.in.orig Tue Sep 5 14:24:47 2000
++++ Makefile.in Tue Sep 12 16:14:59 2000
+@@ -111,3 +111,3 @@
+ # Install the m4 macro to be used by autoconf
+-m4datadir = $(datadir)/aclocal
++m4datadir = $(prefix)/share/aclocal
+ m4data_DATA = $(GENERIC_LIBRARY_NAME).m4
diff --git a/x11-toolkits/bakery/pkg-comment b/x11-toolkits/bakery/pkg-comment
new file mode 100644
index 000000000000..45f580094eab
--- /dev/null
+++ b/x11-toolkits/bakery/pkg-comment
@@ -0,0 +1 @@
+A C++ Application Framework for use with Gnome--
diff --git a/x11-toolkits/bakery/pkg-descr b/x11-toolkits/bakery/pkg-descr
new file mode 100644
index 000000000000..f25efbd3f5be
--- /dev/null
+++ b/x11-toolkits/bakery/pkg-descr
@@ -0,0 +1,11 @@
+Bakery is a C++ Framework for creating GNOME applications using
+Gnome-- and Gtk--.
+
+- provides a Document/View architecture, but it doesn't force you to
+ use the whole architecture.
+- provides default functionality, which can be easily customized.
+- makes it easy to start developing GNOME applications.
+- gives your application structure.
+- will provide easy access to GNOME technologies such as Bonobo and GConf.
+
+WWW: http://bakery.sourceforge.net/
diff --git a/x11-toolkits/bakery/pkg-plist b/x11-toolkits/bakery/pkg-plist
new file mode 100644
index 000000000000..ea21514954cd
--- /dev/null
+++ b/x11-toolkits/bakery/pkg-plist
@@ -0,0 +1,16 @@
+bin/bakery-config
+include/bakery/App/App.h
+include/bakery/App/App_WithDoc.h
+include/bakery/Document/Document.h
+include/bakery/View/View.h
+include/bakery/View/ViewBase.h
+include/bakery/View/View_Composite.h
+include/bakery/bakery.h
+lib/libbakery-0.3.so.1
+lib/libbakery.a
+lib/libbakery.so
+share/aclocal/bakery.m4
+@dirrm include/bakery/View
+@dirrm include/bakery/Document
+@dirrm include/bakery/App
+@dirrm include/bakery