aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-16 23:25:40 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-16 23:25:40 +0800
commitb9ead510b93009bc304fd2a11651dd18130ce1d6 (patch)
treef7049a97e28109d188463f07b91e9b1f61cf49ed /x11-toolkits
parent1fb34516c19e99468a4e212e3689f331937fcb33 (diff)
downloadfreebsd-ports-gnome-b9ead510b93009bc304fd2a11651dd18130ce1d6.tar.gz
freebsd-ports-gnome-b9ead510b93009bc304fd2a11651dd18130ce1d6.tar.zst
freebsd-ports-gnome-b9ead510b93009bc304fd2a11651dd18130ce1d6.zip
Update PyQt5 to 5.11.3
- sip upgrade to 4.19.13 - qscintilla2 upgrade to 2.10.8 - PyQt5 upgrade to 5.11.3 This has been worked on by arrowd and myself. PR: 233954 Exp-run by: antoine
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-qt5-gui/Makefile3
-rw-r--r--x11-toolkits/py-qt5-quick/Makefile3
-rw-r--r--x11-toolkits/py-qt5-quickwidgets/Makefile3
-rw-r--r--x11-toolkits/py-qt5-widgets/Makefile3
4 files changed, 12 insertions, 0 deletions
diff --git a/x11-toolkits/py-qt5-gui/Makefile b/x11-toolkits/py-qt5-gui/Makefile
index 8f920b430df6..c816a98daf50 100644
--- a/x11-toolkits/py-qt5-gui/Makefile
+++ b/x11-toolkits/py-qt5-gui/Makefile
@@ -6,6 +6,9 @@ CATEGORIES= x11-toolkits devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt5 toolkit, QtGui module
+BUILD_DEPENDS= ${PY_ENUM34}
+RUN_DEPENDS= ${PY_ENUM34}
+
CONFIGURE_ARGS= --enable QtGui
PYQT_DIST= yes
diff --git a/x11-toolkits/py-qt5-quick/Makefile b/x11-toolkits/py-qt5-quick/Makefile
index b2e7d8e3f44c..dd5fbfb7f9a6 100644
--- a/x11-toolkits/py-qt5-quick/Makefile
+++ b/x11-toolkits/py-qt5-quick/Makefile
@@ -6,6 +6,9 @@ CATEGORIES= x11-toolkits devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt5 toolkit, QtQuick module
+BUILD_DEPENDS= ${PY_ENUM34}
+RUN_DEPENDS= ${PY_ENUM34}
+
CONFIGURE_ARGS= --enable QtQuick
PYQT_DIST= yes
diff --git a/x11-toolkits/py-qt5-quickwidgets/Makefile b/x11-toolkits/py-qt5-quickwidgets/Makefile
index c2df9bb676bc..5e6024c4d7d0 100644
--- a/x11-toolkits/py-qt5-quickwidgets/Makefile
+++ b/x11-toolkits/py-qt5-quickwidgets/Makefile
@@ -6,6 +6,9 @@ CATEGORIES= x11-toolkits devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt5 toolkit, QtQuickWidgets module
+BUILD_DEPENDS= ${PY_ENUM34}
+RUN_DEPENDS= ${PY_ENUM34}
+
USES= python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run gui_run
diff --git a/x11-toolkits/py-qt5-widgets/Makefile b/x11-toolkits/py-qt5-widgets/Makefile
index 98060de840b9..a0a34db501f2 100644
--- a/x11-toolkits/py-qt5-widgets/Makefile
+++ b/x11-toolkits/py-qt5-widgets/Makefile
@@ -6,6 +6,9 @@ CATEGORIES= x11-toolkits devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt5 toolkit, QtWidgets module
+BUILD_DEPENDS= ${PY_ENUM34}
+RUN_DEPENDS= ${PY_ENUM34}
+
CONFIGURE_ARGS= --enable QtWidgets
PYQT_DIST= yes