aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-08-31 00:18:45 +0800
committersobomax <sobomax@FreeBSD.org>2002-08-31 00:18:45 +0800
commitbfa054283680686ba98fce6d68324ae6892b3aa5 (patch)
tree44a54f43d91bb52c331b0eb26d7b00e8221e9e32 /x11-toolkits
parentb54bd380dbff0fafe18e1eabb62726b64a48d575 (diff)
downloadfreebsd-ports-gnome-bfa054283680686ba98fce6d68324ae6892b3aa5.tar.gz
freebsd-ports-gnome-bfa054283680686ba98fce6d68324ae6892b3aa5.tar.zst
freebsd-ports-gnome-bfa054283680686ba98fce6d68324ae6892b3aa5.zip
Avoid calling strncmp(3) with two arguments - use strcmp(3) instead.
PR: 41257 Submitted by: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/xenostep/Makefile1
-rw-r--r--x11-toolkits/xenostep/files/patch-XenoStep_theme_draw.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/x11-toolkits/xenostep/Makefile b/x11-toolkits/xenostep/Makefile
index b4703109d7c6..7e625d152164 100644
--- a/x11-toolkits/xenostep/Makefile
+++ b/x11-toolkits/xenostep/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xenostep
PORTVERSION= 200011270836
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_THEMES}
MASTER_SITE_SUBDIR= gtk
diff --git a/x11-toolkits/xenostep/files/patch-XenoStep_theme_draw.c b/x11-toolkits/xenostep/files/patch-XenoStep_theme_draw.c
new file mode 100644
index 000000000000..1f1fbf29712a
--- /dev/null
+++ b/x11-toolkits/xenostep/files/patch-XenoStep_theme_draw.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- XenoStep_theme_draw.c 2002/08/30 16:16:48 1.1
++++ XenoStep_theme_draw.c 2002/08/30 16:17:08
+@@ -604,7 +604,7 @@
+ width-=2; height-=2;
+ }
+ } else if (GTK_IS_BUTTON(widget)) {
+- if (detail && !strncmp("buttondefault", detail)) {
++ if (detail && !strcmp("buttondefault", detail)) {
+ newshadow = ((XenoStepThemeData *)style->engine_data)->buttondef_shadow;
+ } else
+ if (!GTK_IS_TOGGLE_BUTTON(widget) && state_type == GTK_STATE_ACTIVE) {