aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-03-17 06:01:12 +0800
committermarcus <marcus@FreeBSD.org>2004-03-17 06:01:12 +0800
commitefa273dac04d18962069b2bd1250c9227f4bca6c (patch)
tree7eb6e92b65a66cf2a2dc0de54f55c41ec94a64f3 /x11-toolkits
parentde5ee69f675f7805a8298d498f1fc1147c3e98b1 (diff)
downloadfreebsd-ports-gnome-efa273dac04d18962069b2bd1250c9227f4bca6c.tar.gz
freebsd-ports-gnome-efa273dac04d18962069b2bd1250c9227f4bca6c.tar.zst
freebsd-ports-gnome-efa273dac04d18962069b2bd1250c9227f4bca6c.zip
Add a patch to prevent the Industrial theme from crashing if handed a NULL
widget.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnome-themes-extras/Makefile2
-rw-r--r--x11-toolkits/gnome-themes-extras/files/patch-Industrial_industrial_style.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/x11-toolkits/gnome-themes-extras/Makefile b/x11-toolkits/gnome-themes-extras/Makefile
index 76cfbb684f31..b8a1699ab1a0 100644
--- a/x11-toolkits/gnome-themes-extras/Makefile
+++ b/x11-toolkits/gnome-themes-extras/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnome-themes-extras
PORTVERSION= 0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
diff --git a/x11-toolkits/gnome-themes-extras/files/patch-Industrial_industrial_style.c b/x11-toolkits/gnome-themes-extras/files/patch-Industrial_industrial_style.c
new file mode 100644
index 000000000000..a95963569336
--- /dev/null
+++ b/x11-toolkits/gnome-themes-extras/files/patch-Industrial_industrial_style.c
@@ -0,0 +1,10 @@
+--- Industrial/industrial_style.c.orig Tue Mar 16 16:55:11 2004
++++ Industrial/industrial_style.c Tue Mar 16 16:58:23 2004
+@@ -1801,6 +1801,7 @@
+ gint width,
+ gint height)
+ {
++ g_return_if_fail (widget != NULL);
+ #if DEBUG
+ printf ("draw_shadow: %p %p %s %i %i %i %i\n", widget, window, detail, x, y,
+ width, height);