aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/afterstep
diff options
context:
space:
mode:
authorsimokawa <simokawa@FreeBSD.org>1999-01-10 22:54:28 +0800
committersimokawa <simokawa@FreeBSD.org>1999-01-10 22:54:28 +0800
commitb5e0e1d1cc9793663c1aea95ff5e63803c489e6c (patch)
treefa4e64f4b461e4c611777639810c3d77333afd61 /x11-wm/afterstep
parent799603eaf703232b0708f699136d6efcecbff48b (diff)
downloadfreebsd-ports-gnome-b5e0e1d1cc9793663c1aea95ff5e63803c489e6c.tar.gz
freebsd-ports-gnome-b5e0e1d1cc9793663c1aea95ff5e63803c489e6c.tar.zst
freebsd-ports-gnome-b5e0e1d1cc9793663c1aea95ff5e63803c489e6c.zip
Fix for alpha.
They assume AlphaArchitecture == OSF/1.
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index 91c04d6e66ab..3a064325e650 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -3,7 +3,7 @@
# Date created: October 29th 1996
# Whom: jfitz@FreeBSD.ORG
#
-# $Id: Makefile,v 1.22 1998/09/17 00:32:56 asami Exp $
+# $Id: Makefile,v 1.23 1999/01/05 01:10:02 steve Exp $
#
DISTNAME= AfterStep-1.0
@@ -20,6 +20,18 @@ INSTALL_TARGET= install install.man
MANCOMPRESSED= yes
MAN1= afterstep.1 asclock.1 Animate.1 Audio.1 Auto.1 Banner.1 Pager.1 Wharf.1
+SRCDIRS= afterstep \
+ modules/Animate modules/Audio modules/Auto \
+ modules/Banner modules/Pager modules/Wharf \
+ modules/Wharf/ASSound
+
+post-patch:
+ @ for i in ${SRCDIRS}; do \
+ cd ${WRKSRC}/$$i; \
+ mv Imakefile Imakefile.orig; \
+ sed -e 's/#ifdef AlphaArchitecture/#if defined(AlphaArchitecture) \&\& !defined(FreeBSDArchitecture)/' < Imakefile.orig > Imakefile; \
+ done
+
pre-build:
@ cd ${WRKSRC}; sh MakeMakefiles