aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/boxtools
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2003-08-28 19:36:56 +0800
committerosa <osa@FreeBSD.org>2003-08-28 19:36:56 +0800
commitb3761b785ac8b1c00ba7374a939c316f54953b81 (patch)
tree35c860b400fcfeba341d7898d7bb4b93f96661f5 /x11-wm/boxtools
parent7b1ef8b3293f561ed9c1b03db1a55cf9e1de3ea5 (diff)
downloadfreebsd-ports-gnome-b3761b785ac8b1c00ba7374a939c316f54953b81.tar.gz
freebsd-ports-gnome-b3761b785ac8b1c00ba7374a939c316f54953b81.tar.zst
freebsd-ports-gnome-b3761b785ac8b1c00ba7374a939c316f54953b81.zip
Fix building on -CURRENT (gcc-3.3)
Submitted by: Stijn Hoop <stijn@win.tue.nl> (maintainer) PR: 56074
Diffstat (limited to 'x11-wm/boxtools')
-rw-r--r--x11-wm/boxtools/Makefile2
-rw-r--r--x11-wm/boxtools/files/patch-src::Window.cc10
2 files changed, 11 insertions, 1 deletions
diff --git a/x11-wm/boxtools/Makefile b/x11-wm/boxtools/Makefile
index 7bc3ac50540b..393aec90295b 100644
--- a/x11-wm/boxtools/Makefile
+++ b/x11-wm/boxtools/Makefile
@@ -23,7 +23,7 @@ USE_REINPLACE= yes
pre-patch:
${REINPLACE_CMD} -e 's#PACKAGE=blackbox#PACKAGE=boxtools#' \
- ${WRKSRC}/configure
+ -e 's#-pedantic##' ${WRKSRC}/configure
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/util/bsetbg ${PREFIX}/bin
diff --git a/x11-wm/boxtools/files/patch-src::Window.cc b/x11-wm/boxtools/files/patch-src::Window.cc
new file mode 100644
index 000000000000..ec6c3afd4e04
--- /dev/null
+++ b/x11-wm/boxtools/files/patch-src::Window.cc
@@ -0,0 +1,10 @@
+--- src/Window.cc.orig Wed Aug 13 12:40:02 2003
++++ src/Window.cc Wed Aug 13 12:41:03 2003
+@@ -44,6 +44,8 @@
+ #endif // HAVE_STDLIB_H
+ }
++#include <cassert>
++
+ #include "i18n.hh"
+ #include "blackbox.hh"
+ #include "GCCache.hh"