aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/ede/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2019-03-11 19:34:07 +0800
committerdanfe <danfe@FreeBSD.org>2019-03-11 19:34:07 +0800
commitfa5e35f377a11ccf1892e097bc215af1485300dd (patch)
tree4aa587891acb9a45b383fe6c2ca616a00fa2fee0 /x11-wm/ede/Makefile
parent29c449054627293624fb5901d3d41089109f0c06 (diff)
downloadfreebsd-ports-gnome-fa5e35f377a11ccf1892e097bc215af1485300dd.tar.gz
freebsd-ports-gnome-fa5e35f377a11ccf1892e097bc215af1485300dd.tar.zst
freebsd-ports-gnome-fa5e35f377a11ccf1892e097bc215af1485300dd.zip
Unbreak the build by fixing two common errors that upset new C++ compilers:
1) evoke/Xsm.cpp:653:17: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal] 2) pekwm/ActionHandler.cc:631:10: error: case value evaluates to 4294967294, which cannot be narrowed to type 'int' [-Wc++11-narrowing]
Diffstat (limited to 'x11-wm/ede/Makefile')
-rw-r--r--x11-wm/ede/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11-wm/ede/Makefile b/x11-wm/ede/Makefile
index f871668d9a8e..10b575613101 100644
--- a/x11-wm/ede/Makefile
+++ b/x11-wm/ede/Makefile
@@ -18,8 +18,6 @@ LICENSE_COMB= multi
LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING
LICENSE_FILE_LGPL20+ = ${EDELIB_WRKSRC}/COPYING
-BROKEN= fails to build
-
BUILD_DEPENDS= doxygen:devel/doxygen \
jam:devel/jam
LIB_DEPENDS= libdbus-1.so:devel/dbus \
@@ -79,6 +77,9 @@ post-patch:
@${REINPLACE_CMD} -e \
's|"\(panel-applets\)"|"../../lib/ede/\1"|' \
${WRKSRC}/ede-panel/Panel.cpp
+ @${REINPLACE_CMD} -e \
+ 's| int direction| uint direction|' \
+ ${WRKSRC}/pekwm/ActionHandler.??
pre-configure:
@(cd ${EDELIB_WRKSRC} \