aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/mcwm/Makefile
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-12-29 00:42:05 +0800
committercrees <crees@FreeBSD.org>2011-12-29 00:42:05 +0800
commitf5bca2f66cac7fe5b0957e8564c44bffdd214e0a (patch)
treef73e87ec5a604262a32cab856b230bd67046d6a3 /x11-wm/mcwm/Makefile
parent47c1ba81c1c7a5bda12671d9438ca727e9e972fc (diff)
downloadfreebsd-ports-gnome-f5bca2f66cac7fe5b0957e8564c44bffdd214e0a.tar.gz
freebsd-ports-gnome-f5bca2f66cac7fe5b0957e8564c44bffdd214e0a.tar.zst
freebsd-ports-gnome-f5bca2f66cac7fe5b0957e8564c44bffdd214e0a.zip
- Fix build with gcc46
- Tidy install code; use do-install instead of patching Makefile PR: ports/163667 Submitted by: Jakub Lach <jakub_lach@mailplus.pl> (maintainer)
Diffstat (limited to 'x11-wm/mcwm/Makefile')
-rw-r--r--x11-wm/mcwm/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/x11-wm/mcwm/Makefile b/x11-wm/mcwm/Makefile
index ae7f4d7af6d1..e3f6b963c48d 100644
--- a/x11-wm/mcwm/Makefile
+++ b/x11-wm/mcwm/Makefile
@@ -38,6 +38,15 @@ post-extract:
@${CP} ${MCWM_CONF} ${WRKSRC}/config.h
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man \
+ ${MAN1PREFIX}/man/man1/${PORTNAME}.1
+
post-install:
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"