aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/olvwm
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2011-06-09 02:06:44 +0800
committercy <cy@FreeBSD.org>2011-06-09 02:06:44 +0800
commit5b93a60254724ab54189cdf8d99708cd819652b9 (patch)
tree9837d2e9f9c84ac9f574b781110c0f0d9dbc87fe /x11-wm/olvwm
parente707dd1c8c93cc3f156e313d51215cfd0537ebf2 (diff)
downloadfreebsd-ports-gnome-5b93a60254724ab54189cdf8d99708cd819652b9.tar.gz
freebsd-ports-gnome-5b93a60254724ab54189cdf8d99708cd819652b9.tar.zst
freebsd-ports-gnome-5b93a60254724ab54189cdf8d99708cd819652b9.zip
Resurrect this port.
Asssume maintainership.
Diffstat (limited to 'x11-wm/olvwm')
-rw-r--r--x11-wm/olvwm/Makefile40
-rw-r--r--x11-wm/olvwm/distinfo6
-rw-r--r--x11-wm/olvwm/files/patch-aa355
-rw-r--r--x11-wm/olvwm/files/patch-ab12
-rw-r--r--x11-wm/olvwm/files/patch-ac11
-rw-r--r--x11-wm/olvwm/files/patch-ad57
-rw-r--r--x11-wm/olvwm/files/patch-ba36
-rw-r--r--x11-wm/olvwm/files/patch-bb18
-rw-r--r--x11-wm/olvwm/pkg-descr6
-rw-r--r--x11-wm/olvwm/pkg-plist2
10 files changed, 543 insertions, 0 deletions
diff --git a/x11-wm/olvwm/Makefile b/x11-wm/olvwm/Makefile
new file mode 100644
index 000000000000..8fbe17e21af3
--- /dev/null
+++ b/x11-wm/olvwm/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: olvwm
+# Date created: 21 October 1994
+# Whom: smace
+#
+# $FreeBSD$
+#
+
+PORTNAME= olvwm
+PORTVERSION= 4.2
+PORTREVISION= 1
+CATEGORIES= x11-wm
+MASTER_SITES= ftp://ftp.x.org/R5contrib/ \
+ ${MASTER_SITE_XCONTRIB}
+MASTER_SITE_SUBDIR= window_managers
+DISTNAME= ${PORTNAME}4
+EXTRACT_SUFX= .tar.Z
+
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= olvwm4.Patch01.Z \
+ olvwm4.Patch02.Z
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= OpenLook Virtual Window manager
+
+LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
+
+REINPLACE_ARGS= -i ""
+NO_WRKSUBDIR= yes
+USE_IMAKE= yes
+USE_XORG= xpm
+MAN1= olvwm.1 olvwmrc.1
+XFREE86_HTML_MAN= no
+
+pre-configure:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|^#endif.*$$|#endif|;s|^#else.*$$|#else|;\
+ s|^/\*\*/#*|XCOMM |'
+
+.include <bsd.port.mk>
diff --git a/x11-wm/olvwm/distinfo b/x11-wm/olvwm/distinfo
new file mode 100644
index 000000000000..993622bba4f6
--- /dev/null
+++ b/x11-wm/olvwm/distinfo
@@ -0,0 +1,6 @@
+SHA256 (olvwm4.tar.Z) = 0e25bda6176489e5111d91c384e44dc1d0df6bf3becaeebaa9aabd26e02b337d
+SIZE (olvwm4.tar.Z) = 631689
+SHA256 (olvwm4.Patch01.Z) = 8e670a95e6c029ca8831a97742e88212d29cbb3f5d8d52ab777408dd55165213
+SIZE (olvwm4.Patch01.Z) = 10506
+SHA256 (olvwm4.Patch02.Z) = f2a6560864980d827aa29fb9fe6925e1d2231be314c934e7b7c78795cc945436
+SIZE (olvwm4.Patch02.Z) = 5992
diff --git a/x11-wm/olvwm/files/patch-aa b/x11-wm/olvwm/files/patch-aa
new file mode 100644
index 000000000000..e9d40b4bceae
--- /dev/null
+++ b/x11-wm/olvwm/files/patch-aa
@@ -0,0 +1,355 @@
+--- Imakefile.orig Mon Oct 26 09:16:54 1998
++++ Imakefile Mon Oct 26 09:27:43 1998
+@@ -48,8 +48,10 @@
+ /**/#MORECCFLAGS=-DOW_I18N_L3 -DSHAPE -DIDENT
+
+ /**/# For a generic Solaris 2.x system, I'd suggest
+-MORECCFLAGS=-DOW_I18N_L3 -DSHAPE -DSVR4 -DSYSV -DIDENT -x O4
++/**/#MORECCFLAGS=-DOW_I18N_L3 -DSHAPE -DSVR4 -DSYSV -DIDENT -x O4
+
++/**/# For FreeBSD
++MORECCFLAGS=-DOW_I18N_L3 -DSHAPE -DMAXPID=30000 -DREGEXP -DXPM -DXVIEW32
+ /**/#
+ /**/# Set MORELDFLAGS to any link options you want. Be sure to add -lxpm if you
+ /**/# want to include XPM support. For a generic Solaris 1.x
+@@ -57,8 +59,11 @@
+ /**/#MORELDFLAGS=-L${OPENWINHOME}/lib
+ /**/#
+ /**/# For Solaris 2.x, I'd suggest
+-MORELDFLAGS=-L${OPENWINHOME}/lib -R ${OPENWINHOME}/lib -lintl
++/**/#MORELDFLAGS=-L${OPENWINHOME}/lib -R ${OPENWINHOME}/lib -lintl
+
++/**/# For FreeBSD
++MORELDFLAGS=-L$(USRLIBDIR) -lXpm
++XPMINCDIR=-I$(INCROOT)/X11
+
+ /**/# No more changes needed
+
+@@ -72,6 +77,7 @@
+ SYS_LIBRARIES = -ll -lm
+ INCLUDES = -I$(HEADER_DEST) -I$(TOP) $(XPMINCDIR)
+ DEPLIBS =
++EXTENSIONLIB = -lXext
+ LOCAL_LIBRARIES = $(MORELDFLAGS) $(OLGXLIB) $(XLIB)
+
+ HEADERS = cmdstream.h cursors.h debug.h defaults.h dsdm.h environ.h error.h \
+@@ -115,26 +121,29 @@
+ ${HEADERS} ${BITMAPS} ${SRCS} \
+ ${MISC} ${INFOFILES} ${MANPAGES} ${SCRIPTS}
+
+-ComplexProgramTarget(olvwm)
+-
+-#if NeedMenuFile
+-InstallNonExecList($(MISC),$(LIBRARY_DEST))
+-#endif
++depend:: olvwmrc.c
+
+ parse.c: parse.l
+- lex -t parse.l > parse.c
++ $(LEX) $(LFALGS) parse.l
++ $(MV) lex.yy.c parse.c
+
+-olvwmrc.c: olvwmrc.y
+- yacc olvwmrc.y
+- mv y.tab.c olvwmrc.c
++olvwmrc.c: parse.c olvwmrc.y
++ $(YACC) olvwmrc.y
++ $(MV) y.tab.c olvwmrc.c
+
+ olvwmrc.o: parse.c olvwmrc.c
+
++ComplexProgramTarget(olvwm)
++
++#if NeedMenuFile
++InstallNonExecList($(MISC),$(LIBRARY_DEST))
++#endif
++
+ version.c: ${SRCS} ${HEADERS}
+ @echo '#ident "@(#)olvwm version compiled '`date`'"' > version.c
+
+ clean::
+- /bin/rm -f parse.c olvwmrc.c version.c
++ /bin/rm -f parse.c olvwmrc.c version.c .depend
+
+ install.man:: $(MANPAGES)
+ @if [ -d $(DESTDIR)$(MANDIR) ]; then set +x; \
+@@ -142,7 +151,11 @@
+ @for i in $(MANPAGES) ;\
+ do \
+ echo "installing $$i"; \
++ $(RM) $(DESTDIR)$(MANDIR)/`basename $$i .man`.$(MANSUFFIX)* ; \
+ $(INSTALL) -c $(INSTMANFLAGS) $$i $(DESTDIR)$(MANDIR)/`basename $$i .man`.$(MANSUFFIX) ; \
++ $(COMPRESSMANCMD) $(DESTDIR)$(MANDIR)/`basename $$i .man`.$(MANSUFFIX) ; \
+ done
++
++depend:: olvwmrc.c
+
+ #include <XView.prog>
+*** defaults.c.orig Thu Jan 13 16:36:03 1994
+--- defaults.c Sun Jan 24 20:50:32 1999
+***************
+*** 30,38 ****
+ #include <X11/Xutil.h>
+ #include <X11/Xatom.h>
+ #include <X11/Xresource.h>
+- #ifdef OW_I18N_L4
+ #include <sys/param.h>
+- #endif
+
+ #include "i18n.h"
+ #include "ollocale.h"
+--- 30,36 ----
+***************
+*** 90,97 ****
+--- 88,99 ----
+ #ifdef SVR4
+ if (sysinfo(SI_HOSTNAME, hostname, sizeof(hostname)) != -1) {
+ #else
++ #ifdef BSD
++ if (0 == gethostname(hostname, sizeof(hostname))) {
++ #else
+ if (0 == gethostname(hostname, sizeof(hostname), &namelen)) {
+ #endif
++ #endif
+ (void) strcat(filename, hostname);
+ fileDB = XrmGetFileDatabase(filename);
+ }
+***************
+*** 159,165 ****
+ return appDB;
+ }
+
+! appDB = XrmGetFileDatabase("/usr/lib/X11/app-defaults/Olwm");
+ return appDB;
+ }
+
+--- 161,167 ----
+ return appDB;
+ }
+
+! appDB = XrmGetFileDatabase("/usr/X11R6/lib/X11/app-defaults/Olwm");
+ return appDB;
+ }
+
+--- gif.c.orig Thu Jan 13 15:36:06 1994
++++ gif.c Mon Oct 19 13:46:15 1998
+@@ -56,6 +56,10 @@
+ int disposal;
+ } Gif89 = { -1, -1, -1, 0 };
+
++static ReadColorMap();
++static DoExtension();
++static GetDataBlock();
++
+ extern XImage* ReadImage();
+
+ XImage *ReadGIF(dpy, fd, pNcolors, pColors)
+@@ -456,7 +460,7 @@
+ return code;
+ }
+
+-static XImage*
++extern XImage*
+ ReadImage(dpy, fd, len, height, cmap, interlace, ignore)
+ Display *dpy;
+ FILE *fd;
+--- mem.c.orig Thu Jan 13 15:36:08 1994
++++ mem.c Mon Oct 19 13:47:49 1998
+@@ -18,7 +18,12 @@
+
+
+ #include <sys/types.h>
++#include <sys/param.h>
++#ifndef __STDC__
+ #include <malloc.h>
++#else
++#include <stdlib.h>
++#endif
+ #include <memory.h>
+ #include <stdio.h>
+
+--- olvwmrc.y.orig Mon Oct 19 14:21:34 1998
++++ olvwmrc.y Mon Oct 19 14:04:33 1998
+@@ -37,7 +37,7 @@
+ char *LookupToken();
+ char *FindOlvwmRC();
+ void resetKeys();
+-char *strexpand();
++static char *strexpand();
+
+ typedef struct progscreen {
+ char *target;
+@@ -527,7 +527,9 @@
+ }
+ %%
+ /* Programs */
++#ifndef YYDEBUG
+ #define YYDEBUG 1
++#endif
+ #include "parse.c"
+
+ extern List *ActiveClientList;
+--- olwm.c.orig Thu Jan 13 15:36:12 1994
++++ olwm.c Mon Oct 19 14:08:54 1998
+@@ -677,9 +677,15 @@
+ pid_t pid;
+ int status;
+ #else
++#ifdef BSD
++ int oldmask;
++ int pid;
++ int status;
++#else
+ int oldmask;
+ int pid;
+ union wait status;
++#endif
+ #endif
+
+ if (!deadChildren)
+*** screen.c.orig Sun Jan 24 20:03:43 1999
+--- screen.c Sun Jan 24 20:58:29 1999
+***************
+*** 66,71 ****
+--- 66,78 ----
+ *-------------------------------------------------------------------------*/
+ List *ScreenInfoList; /* List of managed screens */
+ extern Bool BoolString();
++ static updateScreenWorkspaceColor();
++ static updateScreenWindowColor();
++ static updateScreenForegroundColor();
++ static updateScreenBackgroundColor();
++ static updateScreenBorderColor();
++ static updateScreenInputFocusColor();
++ static updateScreenGlyphFont();
+
+ /*-------------------------------------------------------------------------
+ * Local Data
+***************
+*** 282,287 ****
+--- 289,295 ----
+ case PseudoColor:
+ case GrayScale:
+ case DirectColor:
++ case TrueColor:
+ return True;
+ /*NOTREACHED*/
+ break;
+***************
+*** 523,529 ****
+ * Construct bitmap search path as follows:
+ * $OPENWINHOME/etc/workspace/patterns
+ * $OPENWINHOME/include/X11/include/bitmaps
+! * /usr/X11/include/X11/include/bitmaps
+ *
+ * REMIND: this should be cleaned up so that it doesn't use a fixed-size
+ * array.
+--- 531,537 ----
+ * Construct bitmap search path as follows:
+ * $OPENWINHOME/etc/workspace/patterns
+ * $OPENWINHOME/include/X11/include/bitmaps
+! * /usr/X11R6/include/X11/include/bitmaps
+ *
+ * REMIND: this should be cleaned up so that it doesn't use a fixed-size
+ * array.
+***************
+*** 546,552 ****
+ (void)sprintf(bmPath, "%s/include/X11/bitmaps",owHome);
+ bitmapSearchPath[i++] = MemNewString(bmPath);
+
+! bitmapSearchPath[i++] = MemNewString("/usr/X11/include/X11/bitmaps");
+ bitmapSearchPath[i] = (char *)NULL;
+ }
+
+--- 554,560 ----
+ (void)sprintf(bmPath, "%s/include/X11/bitmaps",owHome);
+ bitmapSearchPath[i++] = MemNewString(bmPath);
+
+! bitmapSearchPath[i++] = MemNewString("/usr/X11R6/include/X11/bitmaps");
+ bitmapSearchPath[i] = (char *)NULL;
+ }
+
+--- st.c.orig Thu Jan 13 15:36:18 1994
++++ st.c Mon Oct 19 14:12:31 1998
+@@ -14,6 +14,7 @@
+ #include "st.h"
+ #include "mem.h"
+
++static rehash();
+
+ #define max(a,b) ((a) > (b) ? (a) : (b))
+ #define nil(type) ((type *) 0)
+--- virtual.c.orig Thu Jan 13 15:36:22 1994
++++ virtual.c Mon Oct 19 14:13:27 1998
+@@ -39,15 +39,18 @@
+ #define TRUE 1
+ #define FALSE 0
+
+-#include <regexp.h>
++#include <regex.h>
+ #ifdef REGEXP
+-regexp *expbuf;
++regex_t expbuf;
+ #endif
+
+ #ifdef IDENT
+ #ident "@(#)virtual.c 1.6 olvwm version 07 Jan 1994"
+ #endif
+
++static rexMatch();
++static rexInit();
++
+ /* Class Function Vector; a virtual pane is the VDM window in which all
+ * the little virtual windows appear (and to which said windows are
+ * parented)
+@@ -2108,14 +2111,16 @@
+ }
+ }
+
++#ifndef REGEXP
+ static char expbuf[256];
++#endif
+
+ static
+ rexMatch(string)
+ char *string;
+ {
+ #ifdef REGEXP
+- return regexec(expbuf, string);
++ return regexec(&expbuf, string, 0, NULL, 0);
+ #else
+ return step(string,expbuf);
+ #endif
+@@ -2152,7 +2157,7 @@
+ newPattern[j++] = '$';
+ newPattern[j++] = '\0';
+ #ifdef REGEXP
+- expbuf = regcomp(newPattern);
++ regcomp(&expbuf, newPattern, 0);
+ #else
+ compile(newPattern, expbuf, &expbuf[256], '\0');
+ #endif
+--- winframe.c.orig Thu Jan 13 15:36:25 1994
++++ winframe.c Mon Oct 19 14:14:26 1998
+@@ -52,6 +52,8 @@
+
+ extern Time TimeFresh();
+
++static headerHeight();
++
+ /***************************************************************************
+ * private data
+ ***************************************************************************/
+--- winicon.c.orig Thu Jan 13 15:36:26 1994
++++ winicon.c Mon Oct 19 14:15:05 1998
+@@ -37,6 +37,10 @@
+ extern Bool PropGetWMName();
+ extern Bool PropGetWMIconName();
+
++static heightTopIcon();
++static heightBottomIcon();
++static widthBothIcon();
++
+ /***************************************************************************
+ * private data
+ ***************************************************************************/
diff --git a/x11-wm/olvwm/files/patch-ab b/x11-wm/olvwm/files/patch-ab
new file mode 100644
index 000000000000..784ff039bdad
--- /dev/null
+++ b/x11-wm/olvwm/files/patch-ab
@@ -0,0 +1,12 @@
+--- menu.c.orig Fri Aug 14 20:35:05 1998
++++ menu.c Fri Aug 14 22:28:13 1998
+@@ -3148,7 +3148,8 @@
+ if (fDefault)
+ state |= OLGX_DEFAULT;
+
+- if (pb->label[pb->which].kind == StringLabel)
++ if (pb->label[pb->which].kind == StringLabel ||
++ pb->label[pb->which].kind == NoType)
+ label = pb->label[pb->which].string;
+ #ifdef OLGX_LABEL_IS_COMB
+ else if (pb->label[pb->which].kind == ComboLabel) {
diff --git a/x11-wm/olvwm/files/patch-ac b/x11-wm/olvwm/files/patch-ac
new file mode 100644
index 000000000000..3f76c09c5650
--- /dev/null
+++ b/x11-wm/olvwm/files/patch-ac
@@ -0,0 +1,11 @@
+--- cursors.c.orig Tue Sep 22 22:16:04 1998
++++ cursors.c Tue Sep 22 22:16:12 1998
+@@ -278,7 +278,7 @@
+ if (our_copy[0] == 'X')
+ font_file = "cursor";
+ else if (our_copy[0] == 'O')
+- font_file = "-sun-open look cursor-----12-120-75-75-p-455-sunolcursor-1";
++ font_file = "-sun-open look cursor-----12-120-75-75-p-160-sunolcursor-1";
+ createCursor(dpy, cmap, pointer, cursor_id, font_file, end, ptr);
+ }
+ else {
diff --git a/x11-wm/olvwm/files/patch-ad b/x11-wm/olvwm/files/patch-ad
new file mode 100644
index 000000000000..adf5f7b6606d
--- /dev/null
+++ b/x11-wm/olvwm/files/patch-ad
@@ -0,0 +1,57 @@
+*** fontset.c.orig Sun Jan 24 20:51:59 1999
+--- fontset.c Sun Jan 24 20:54:54 1999
+***************
+*** 210,216 ****
+
+ if (notFound)
+ {
+! (void) sprintf(filename, "/usr/lib/X11/app-defaults/%s/%s",
+ locale, FONT_SETS);
+ }
+
+--- 210,216 ----
+
+ if (notFound)
+ {
+! (void) sprintf(filename, "/usr/X11R6/lib/X11/app-defaults/%s/%s",
+ locale, FONT_SETS);
+ }
+
+*** ol_button.413.c.orig Sun Jan 24 20:16:16 1999
+--- ol_button.413.c Sun Jan 24 20:21:00 1999
+***************
+*** 8,14 ****
+ * a version of olgx 3.2 (from the xview 3.2 release) and don't want to
+ * use this file, change the define here
+ */
+! #ifndef SVR4
+
+ /*
+ * Based on
+--- 8,14 ----
+ * a version of olgx 3.2 (from the xview 3.2 release) and don't want to
+ * use this file, change the define here
+ */
+! #if !defined(SVR4) && !defined(XVIEW32)
+
+ /*
+ * Based on
+*** ol_button.svr4.c.orig Sun Jan 24 20:21:22 1999
+--- ol_button.svr4.c Sun Jan 24 20:23:34 1999
+***************
+*** 12,18 ****
+ *
+ */
+
+! #ifdef SVR4
+
+ /*
+ * Copyright 1989-1990 Sun Microsystems See LEGAL_NOTICE for terms of
+--- 12,18 ----
+ *
+ */
+
+! #if defined(SVR4) || defined(XVIEW32)
+
+ /*
+ * Copyright 1989-1990 Sun Microsystems See LEGAL_NOTICE for terms of
diff --git a/x11-wm/olvwm/files/patch-ba b/x11-wm/olvwm/files/patch-ba
new file mode 100644
index 000000000000..f152402439e9
--- /dev/null
+++ b/x11-wm/olvwm/files/patch-ba
@@ -0,0 +1,36 @@
+*** pixmap.c.patched Sun Jan 24 20:26:03 1999
+--- pixmap.c Sun Jan 24 20:28:39 1999
+***************
+*** 466,472 ****
+ * Construct bitmap search path as follows:
+ * $OPENWINHOME/etc/workspace/patterns
+ * $OPENWINHOME/include/X11/include/bitmaps
+! * /usr/X11/include/X11/include/bitmaps
+ *
+ * REMIND: this should be cleaned up so that it doesn't use a fixed-size
+ * array.
+--- 466,472 ----
+ * Construct bitmap search path as follows:
+ * $OPENWINHOME/etc/workspace/patterns
+ * $OPENWINHOME/include/X11/include/bitmaps
+! * /usr/X11R6/include/X11/include/bitmaps
+ *
+ * REMIND: this should be cleaned up so that it doesn't use a fixed-size
+ * array.
+***************
+*** 489,495 ****
+ (void)sprintf(bmPath, "%s/include/X11/bitmaps",owHome);
+ bitmapSearchPath[i++] = MemNewString(bmPath);
+
+! bitmapSearchPath[i++] = MemNewString("/usr/X11/include/X11/bitmaps");
+
+ bitmapSearchPath[i] = (char *)NULL;
+ }
+--- 489,495 ----
+ (void)sprintf(bmPath, "%s/include/X11/bitmaps",owHome);
+ bitmapSearchPath[i++] = MemNewString(bmPath);
+
+! bitmapSearchPath[i++] = MemNewString("/usr/X11R6/include/X11/bitmaps");
+
+ bitmapSearchPath[i] = (char *)NULL;
+ }
diff --git a/x11-wm/olvwm/files/patch-bb b/x11-wm/olvwm/files/patch-bb
new file mode 100644
index 000000000000..9cad8cc8dc20
--- /dev/null
+++ b/x11-wm/olvwm/files/patch-bb
@@ -0,0 +1,18 @@
+--- gettext.c.orig Sun Sep 29 02:29:20 2002
++++ gettext.c Sun Sep 29 02:29:47 2002
+@@ -17,12 +17,14 @@
+ #define bzero(a,b) memset(a,0,b)
+ #endif
+
+-char *malloc(), *strdup();
+ char * dgettext();
+ char *_gettext();
+ char *in_path();
++#ifndef __FreeBSD__
++char *malloc(), *strdup();
+ char *fgets(), *getenv();
+ caddr_t mmap(), calloc();
++#endif
+
+ #ifdef NOT
+ static struct domain_binding *firstbind=0, *lastbind=0;
diff --git a/x11-wm/olvwm/pkg-descr b/x11-wm/olvwm/pkg-descr
new file mode 100644
index 000000000000..064bff8c23ef
--- /dev/null
+++ b/x11-wm/olvwm/pkg-descr
@@ -0,0 +1,6 @@
+Olvwm (OPEN LOOK virtual window manager) is an ICCCM compliant window manager
+supplied for use with the XView toolkit. It is derived from olwm, the
+OPEN LOOK window manager supplied with the XView release. This version of
+olvwm is based on version 3 of the XView release.
+
+WWW: http://home.nyc.rr.com/twopks/olvwm/
diff --git a/x11-wm/olvwm/pkg-plist b/x11-wm/olvwm/pkg-plist
new file mode 100644
index 000000000000..6be61568ad4d
--- /dev/null
+++ b/x11-wm/olvwm/pkg-plist
@@ -0,0 +1,2 @@
+bin/olvwm
+lib/help/olvwm.info