aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/pekwm/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-27 20:34:54 +0800
committerbapt <bapt@FreeBSD.org>2012-07-27 20:34:54 +0800
commit15298e376fbc7902703ec729b783064b9e03302c (patch)
treeca2c5dfbf44fd91f07c132d92aac7f5f20e2da10 /x11-wm/pekwm/Makefile
parente0d4b28d70cfd20e1707fa71d2000840c2b78948 (diff)
downloadfreebsd-ports-gnome-15298e376fbc7902703ec729b783064b9e03302c.tar.gz
freebsd-ports-gnome-15298e376fbc7902703ec729b783064b9e03302c.tar.zst
freebsd-ports-gnome-15298e376fbc7902703ec729b783064b9e03302c.zip
- Use USE_PKGCONFIG macro
- Remove useless post-patch
Diffstat (limited to 'x11-wm/pekwm/Makefile')
-rw-r--r--x11-wm/pekwm/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/x11-wm/pekwm/Makefile b/x11-wm/pekwm/Makefile
index 998efb214053..bcb3f76d4752 100644
--- a/x11-wm/pekwm/Makefile
+++ b/x11-wm/pekwm/Makefile
@@ -22,6 +22,7 @@ USE_XORG= xft xpm x11
USE_GMAKE= yes
USE_ICONV= yes
USE_BZIP2= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-shape --enable-xinerama --enable-xrandr \
--enable-xft --enable-image-xpm --enable-image-jpeg \
@@ -34,12 +35,8 @@ MANCOMPRESSED= no
# replace calls to obsolete libpng12 functions
post-extract:
- ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|; \
+ @${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|; \
s|png_check_sig(sig, PImageLoaderPng::PNG_SIG_BYTES) !=|png_sig_cmp(sig, 0, PImageLoaderPng::PNG_SIG_BYTES) ==|' \
${WRKSRC}/src/PImageLoaderPng.cc
-post-patch:
- ${REINPLACE_CMD} -e 's|libpng12|libpng14|g' \
- ${WRKSRC}/configure
-
.include <bsd.port.mk>