aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/plwm
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-06-09 06:30:55 +0800
committermiwi <miwi@FreeBSD.org>2009-06-09 06:30:55 +0800
commitad6dcb178b410931b8a584938b44fc4da53756f8 (patch)
tree8ce0d77d48a49a1635170171ab0c9ebe5244ee5c /x11-wm/plwm
parente4a324dde12b05e8afc0511401cb97ac0ae57582 (diff)
downloadfreebsd-ports-gnome-ad6dcb178b410931b8a584938b44fc4da53756f8.tar.gz
freebsd-ports-gnome-ad6dcb178b410931b8a584938b44fc4da53756f8.tar.zst
freebsd-ports-gnome-ad6dcb178b410931b8a584938b44fc4da53756f8.zip
- Update lang/python26 and make Python 2.6.2 to the default Python version
Tested by: 3 pointyhat runs Thanks to: pav, gahr, lwhsu, mva, amdmi3
Diffstat (limited to 'x11-wm/plwm')
-rw-r--r--x11-wm/plwm/Makefile1
-rw-r--r--x11-wm/plwm/files/patch-plwm_outline.py43
2 files changed, 44 insertions, 0 deletions
diff --git a/x11-wm/plwm/Makefile b/x11-wm/plwm/Makefile
index 5ccfaedc0801..e53996a2dbc1 100644
--- a/x11-wm/plwm/Makefile
+++ b/x11-wm/plwm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= plwm
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= x11-wm python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/x11-wm/plwm/files/patch-plwm_outline.py b/x11-wm/plwm/files/patch-plwm_outline.py
new file mode 100644
index 000000000000..cb6f011c291d
--- /dev/null
+++ b/x11-wm/plwm/files/patch-plwm_outline.py
@@ -0,0 +1,43 @@
+--- plwm/outline.py.orig 2001-11-26 14:48:21.000000000 +0100
++++ plwm/outline.py 2009-06-06 17:47:13.000000000 +0200
+@@ -63,7 +63,7 @@
+
+ if name:
+ self.outline_gc.set_clip_rectangles(0, 0, [coords], X.YXSorted)
+- sx, sy, sw, sh, as = namepos
++ sx, sy, sw, sh, _as = namepos
+ self.screen.root.draw_text(self.outline_gc, sx, sy, name)
+ self.outline_name = (sx, sy, name)
+ else:
+@@ -138,8 +138,8 @@
+ height = s[3] - s[1] + 1)
+
+ if name:
+- sx, sy, sw, sh, as = namepos
+- self.outline_name_window.configure(x = sx, y = sy - as,
++ sx, sy, sw, sh, _as = namepos
++ self.outline_name_window.configure(x = sx, y = sy - _as,
+ width = sw, height = sh)
+
+ if not self.outline_mapped:
+@@ -155,7 +155,7 @@
+ # disappear otherwise...
+ if name:
+ self.outline_name_window.image_text(self.outline_name_gc,
+- 0, as, name)
++ 0, _as, name)
+
+ def outline_hide(self):
+ if self.outline_mapped:
+@@ -246,8 +246,8 @@
+
+ sw = min(r.overall_width, w)
+ sh = min(r.overall_ascent + r.overall_descent, h)
+- as = r.overall_ascent
++ _as = r.overall_ascent
+ else:
+- sx = sy = sw = sh = as = 0
++ sx = sy = sw = sh = _as = 0
+
+- return (x, y, w, h), s, (sx, sy, sw, sh, as)
++ return (x, y, w, h), s, (sx, sy, sw, sh, _as)