aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/w9wm
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-03-18 00:19:14 +0800
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-03-18 00:19:14 +0800
commitd51d80946944f9f871bc9bed6f650d4ebe851f97 (patch)
tree87a667d164afbaaf76134239374e03176e0d4177 /x11-wm/w9wm
parent91ae60d4802d8742aefc505cc6af4c217c295840 (diff)
downloadfreebsd-ports-gnome-d51d80946944f9f871bc9bed6f650d4ebe851f97.tar.gz
freebsd-ports-gnome-d51d80946944f9f871bc9bed6f650d4ebe851f97.tar.zst
freebsd-ports-gnome-d51d80946944f9f871bc9bed6f650d4ebe851f97.zip
w9wm is a quick & dirty hack based on 9wm, the wonderful "template"
window manager made by David Hogan. 9wm is really nice for all day use (I mean, a large Emacs window covering the whole screen and a terminal to use Lynx and browse the web ;-)) provided that you do not have a large number of windows on your screen. But in some occasions it is not the case (ie. you have to telnet to 4-5 remote machines), which is painful with 9wm. This need for virtual screens motivated this about 50 lines hack. w9wm brings support for virtual screens (provided you use the second button, aka middle button to select one virtual screen) as well as for key bindings (to switch from one window to another). PR: ports/25362 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Diffstat (limited to 'x11-wm/w9wm')
-rw-r--r--x11-wm/w9wm/Makefile20
-rw-r--r--x11-wm/w9wm/distinfo1
-rw-r--r--x11-wm/w9wm/files/patch-Makefile.no-imake29
-rw-r--r--x11-wm/w9wm/pkg-comment1
-rw-r--r--x11-wm/w9wm/pkg-descr16
-rw-r--r--x11-wm/w9wm/pkg-plist1
6 files changed, 68 insertions, 0 deletions
diff --git a/x11-wm/w9wm/Makefile b/x11-wm/w9wm/Makefile
new file mode 100644
index 000000000000..b6d61f6f8e21
--- /dev/null
+++ b/x11-wm/w9wm/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: w9wm
+# Date created: 25 February 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= w9wm
+PORTVERSION= 0.4.1
+CATEGORIES= x11-wm
+MASTER_SITES= http://inferno.cs.univ-paris8.fr/~drieu/w9wm/src/
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+USE_X_PREFIX= yes
+MAKEFILE= Makefile.no-imake
+
+MAN1= w9wm.1
+
+.include <bsd.port.mk>
diff --git a/x11-wm/w9wm/distinfo b/x11-wm/w9wm/distinfo
new file mode 100644
index 000000000000..19cdb92e4a02
--- /dev/null
+++ b/x11-wm/w9wm/distinfo
@@ -0,0 +1 @@
+MD5 (w9wm-0.4.1.tar.gz) = 102169e67b9b616f16b21da97bfb8289
diff --git a/x11-wm/w9wm/files/patch-Makefile.no-imake b/x11-wm/w9wm/files/patch-Makefile.no-imake
new file mode 100644
index 000000000000..652b84efb702
--- /dev/null
+++ b/x11-wm/w9wm/files/patch-Makefile.no-imake
@@ -0,0 +1,29 @@
+--- Makefile.no-imake.orig Wed Dec 6 19:02:10 2000
++++ Makefile.no-imake Sat Mar 17 23:17:16 2001
+@@ -6,11 +6,11 @@
+ # if you're using AIX, add "-DBSD_INCLUDES" to "CFLAGS".
+ #
+
+-CFLAGS = -g -DSHAPE
+-LDFLAGS = -lXext -lX11
+-BIN = /usr/bin/X11
++CFLAGS += -DSHAPE -I${X11BASE}/include
++LDFLAGS = -lXext -lX11 -L${X11BASE}/lib
++BIN = ${X11BASE}/bin
+
+-MANDIR = /usr/man/man1
++MANDIR = ${X11BASE}/man/man1
+ MANSUFFIX = 1
+
+ #
+@@ -31,9 +31,7 @@
+
+ install: w9wm
+ cp w9wm $(BIN)/w9wm
+-
+-install.man:
+- cp 9wm.man $(MANDIR)/9wm.$(MANSUFFIX)
++ cp w9wm.1 $(MANDIR)/w9wm.$(MANSUFFIX)
+
+ $(OBJS): $(HFILES)
+
diff --git a/x11-wm/w9wm/pkg-comment b/x11-wm/w9wm/pkg-comment
new file mode 100644
index 000000000000..073696dcfb0a
--- /dev/null
+++ b/x11-wm/w9wm/pkg-comment
@@ -0,0 +1 @@
+A hack of 9wm to give virtual screens
diff --git a/x11-wm/w9wm/pkg-descr b/x11-wm/w9wm/pkg-descr
new file mode 100644
index 000000000000..50d955e8fd1d
--- /dev/null
+++ b/x11-wm/w9wm/pkg-descr
@@ -0,0 +1,16 @@
+w9wm is a quick & dirty hack based on 9wm, the wonderful "template"
+window manager made by David Hogan.
+
+9wm is really nice for all day use (I mean, a large Emacs window
+covering the whole screen and a terminal to use Lynx and browse the
+web ;-)) provided that you do not have a large number of windows on
+your screen. But in some occasions it is not the case (ie. you have
+to telnet to 4-5 remote machines), which is painful with 9wm.
+
+This need for virtual screens motivated this about 50 lines hack.
+w9wm brings support for virtual screens (provided you use the second
+button, aka middle button to select one virtual screen) as well as for
+key bindings (to switch from one window to another).
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/x11-wm/w9wm/pkg-plist b/x11-wm/w9wm/pkg-plist
new file mode 100644
index 000000000000..8b7b381eee22
--- /dev/null
+++ b/x11-wm/w9wm/pkg-plist
@@ -0,0 +1 @@
+bin/w9wm